aboutsummaryrefslogtreecommitdiff
path: root/audio/wmusic/Makefile
diff options
context:
space:
mode:
authorEric Melville <eric@FreeBSD.org>2001-05-14 07:16:05 +0000
committerEric Melville <eric@FreeBSD.org>2001-05-14 07:16:05 +0000
commit9d39fbd949c2ec440a5831e6f9b0c79c13684343 (patch)
treec349e6e2547f4e4f339fae2258cf03d0ee5a7d51 /audio/wmusic/Makefile
parentff3152f15c635fe246b45162fcc09072314f6f42 (diff)
Notes
Diffstat (limited to 'audio/wmusic/Makefile')
-rw-r--r--audio/wmusic/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/audio/wmusic/Makefile b/audio/wmusic/Makefile
index 021ea6da2267..114eabfc20ce 100644
--- a/audio/wmusic/Makefile
+++ b/audio/wmusic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wmusic
-PORTVERSION= 1.4.6
+PORTVERSION= 1.4.7
CATEGORIES= audio windowmaker
MASTER_SITES= http://hadess.net/files/
@@ -16,12 +16,20 @@ BUILD_DEPENDS= xmms:${PORTSDIR}/audio/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${X11BASE}
-CONFIGURE_ENV= PATH_GTKCONFIG=${X11BASE}/bin/gtk12-config
+CONFIGURE_ENV= PATH_GTKCONFIG=${PREFIX}/bin/gtk12-config
USE_GMAKE= yes
USE_GLIB= yes
USE_GTK= yes
USE_X_PREFIX= yes
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/wmusic ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE} \
+ ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
.include <bsd.port.mk>