aboutsummaryrefslogtreecommitdiff
path: root/audio/xfce4-mixer/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-10-19 06:13:49 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-10-19 06:13:49 +0000
commita1c8691e690406dc43bdfbeba1f767ec9c888a56 (patch)
treefa72be9fca7f271adafce1ba7c41564af40b9142 /audio/xfce4-mixer/Makefile
parentec87d489f3c19bca94120cbfd92bd9ecb75f0b92 (diff)
Notes
Diffstat (limited to 'audio/xfce4-mixer/Makefile')
-rw-r--r--audio/xfce4-mixer/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/audio/xfce4-mixer/Makefile b/audio/xfce4-mixer/Makefile
index 1f370e622ec5..3d6dd22fd29b 100644
--- a/audio/xfce4-mixer/Makefile
+++ b/audio/xfce4-mixer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-mixer
PORTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= audio xfce
MASTER_SITES= http://www.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://linux.imp.mx/xfce4/xfce_${PORTVERSION}/src/
@@ -16,7 +17,8 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 volume mixer module for xfce4-panel
BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
-LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
xml2.5:${PORTSDIR}/textproc/libxml2 \
startup-notification-1.0:${PORTSDIR}/x11/startup-notification
@@ -24,7 +26,11 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>