aboutsummaryrefslogtreecommitdiff
path: root/audio/xfce4-pulseaudio-plugin/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-03-27 09:07:45 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-03-27 09:07:45 +0000
commitc2f6844e31cb3ce0d189449bf639ef9eff2a9131 (patch)
tree6205e166957cacfada8ea92f7620ffa2db896534 /audio/xfce4-pulseaudio-plugin/Makefile
parent158a7bb61f550dd3c2b7df6f321b2bd7888021d8 (diff)
downloadports-c2f6844e31cb3ce0d189449bf639ef9eff2a9131.tar.gz
ports-c2f6844e31cb3ce0d189449bf639ef9eff2a9131.zip
Notes
Diffstat (limited to 'audio/xfce4-pulseaudio-plugin/Makefile')
-rw-r--r--audio/xfce4-pulseaudio-plugin/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/xfce4-pulseaudio-plugin/Makefile b/audio/xfce4-pulseaudio-plugin/Makefile
new file mode 100644
index 000000000000..be04376098c0
--- /dev/null
+++ b/audio/xfce4-pulseaudio-plugin/Makefile
@@ -0,0 +1,36 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= xfce4-pulseaudio-plugin
+PORTVERSION= 0.2.2
+CATEGORIES= audio xfce
+MASTER_SITES= XFCE
+MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Panel plugin for controlling PulseAudio mixer
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpulse-mainloop-glib.so:${PORTSDIR}/audio/pulseaudio
+RUN_DEPENDS= pavucontrol>=2.0:${PORTSDIR}/audio/pavucontrol
+
+USES= pkgconfig libtool gmake gettext xfce:gtk3 tar:bzip2
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gtk30 intltool intlhack
+USE_XFCE= panel
+USE_XORG= x11
+INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS=--with-mixer-command=${LOCALBASE}/bin/pavucontrol
+CFLAGS+= -Wno-return-type
+
+OPTIONS_DEFINE= KEYBINDER
+OPTIONS_DEFAULT= KEYBINDER
+KEYBINDER_DESC= Keyboard shortcuts
+KEYBINDER_LIB_DEPENDS= libkeybinder-3.0.so:${PORTSDIR}/x11/keybinder-gtk3
+KEYBINDER_CONFIGURE_ENABLE= keybinder
+
+.include <bsd.port.mk>