aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-arts_output
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2004-04-05 19:31:14 +0000
committerMax Khon <fjoe@FreeBSD.org>2004-04-05 19:31:14 +0000
commit562631fb01ae9865413a3ca3d755e8ed28522f56 (patch)
tree77b2eb481568f567fbe3a1891d71f5c340c10c07 /audio/xmms-arts_output
parent3c3fe1c67e542be540b24ad96c5365ad3ac44e25 (diff)
downloadports-562631fb01ae9865413a3ca3d755e8ed28522f56.tar.gz
ports-562631fb01ae9865413a3ca3d755e8ed28522f56.zip
Notes
Diffstat (limited to 'audio/xmms-arts_output')
-rw-r--r--audio/xmms-arts_output/Makefile6
-rw-r--r--audio/xmms-arts_output/distinfo4
-rw-r--r--audio/xmms-arts_output/files/patch-arts_helper.c12
-rw-r--r--audio/xmms-arts_output/files/patch-audio.c39
4 files changed, 17 insertions, 44 deletions
diff --git a/audio/xmms-arts_output/Makefile b/audio/xmms-arts_output/Makefile
index afa906e632bf..677aa4d3e820 100644
--- a/audio/xmms-arts_output/Makefile
+++ b/audio/xmms-arts_output/Makefile
@@ -7,8 +7,7 @@
PKGNAMEPREFIX= xmms-
PORTNAME= arts_output
-PORTVERSION= 0.6.0
-PORTREVISION= 3
+PORTVERSION= 0.7.1
CATEGORIES= audio
MASTER_SITES= http://havardk.xmms.org/plugins/arts_output/
@@ -23,6 +22,7 @@ USE_GNOME= gtk12
USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-PLIST_FILES= lib/xmms/Output/libarts.so
+PLIST_FILES= lib/xmms/Output/libarts.so \
+ bin/xmms-arts-helper
.include <bsd.port.mk>
diff --git a/audio/xmms-arts_output/distinfo b/audio/xmms-arts_output/distinfo
index 6cee3e195071..2f07b6762341 100644
--- a/audio/xmms-arts_output/distinfo
+++ b/audio/xmms-arts_output/distinfo
@@ -1,2 +1,2 @@
-MD5 (arts_output-0.6.0.tar.gz) = 6539123bd1dbebcf57073392da13d992
-SIZE (arts_output-0.6.0.tar.gz) = 198340
+MD5 (arts_output-0.7.1.tar.gz) = 6d028255ed86e37211bbda0122c14483
+SIZE (arts_output-0.7.1.tar.gz) = 236839
diff --git a/audio/xmms-arts_output/files/patch-arts_helper.c b/audio/xmms-arts_output/files/patch-arts_helper.c
new file mode 100644
index 000000000000..f01133c9e5bd
--- /dev/null
+++ b/audio/xmms-arts_output/files/patch-arts_helper.c
@@ -0,0 +1,12 @@
+--- arts_helper.c.orig Tue Apr 6 02:23:37 2004
++++ arts_helper.c Tue Apr 6 02:22:32 2004
+@@ -243,7 +243,9 @@
+ {
+ going = 0;
+ arts_close_stream(handle);
++#if 0
+ arts_free();
++#endif
+ }
+
+ static int read_all(int fd, void *buf, size_t count)
diff --git a/audio/xmms-arts_output/files/patch-audio.c b/audio/xmms-arts_output/files/patch-audio.c
deleted file mode 100644
index 9c64087dbe7f..000000000000
--- a/audio/xmms-arts_output/files/patch-audio.c
+++ /dev/null
@@ -1,39 +0,0 @@
---- audio.c.orig Thu Aug 21 14:38:53 2003
-+++ audio.c Thu Feb 5 03:27:09 2004
-@@ -10,6 +10,7 @@
- #include <errno.h>
- #include <signal.h>
- #include <pthread.h>
-+#include <dlfcn.h>
-
- static arts_stream_t handle;
-
-@@ -269,6 +270,7 @@
- int artsxmms_open(AFormat fmt, int rate, int nch)
- {
- int err;
-+ static int libstdcpp_preloaded = 0;
-
- pthread_mutex_lock(&artsm);
- /* Stop the arts initialization from complaining */
-@@ -291,6 +293,20 @@
-
- going = 1;
- pthread_mutex_unlock(&artsm);
-+
-+ /*
-+ * This is a hack to prevent unloading of libstdc++
-+ * (required by arts libraries) in arts_free() but before
-+ * this thread is terminated. libstdc++ registers thread cleanup
-+ * handler and xmms crashes when this cleanup function is called
-+ * on thread termination.
-+ */
-+ if (!libstdcpp_preloaded) {
-+ if (dlopen("libstdc++.so", RTLD_NOW) != NULL)
-+ libstdcpp_preloaded = 1;
-+ else
-+ fprintf(stderr, "Failed to preload libstdc++.so\n");
-+ }
- return 1;
- }
-