aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-audiofile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-02-06 10:42:09 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-02-06 10:42:09 +0000
commit98ce03a86ef29f72db143218019dd8d2d7a538ed (patch)
treeb5cffca5e822696ef49da2dcdf8393f1fe16c415 /audio/xmms-audiofile
parent345874229b2c125634b37fe3bafb8196ca161ae2 (diff)
downloadports-98ce03a86ef29f72db143218019dd8d2d7a538ed.tar.gz
ports-98ce03a86ef29f72db143218019dd8d2d7a538ed.zip
Notes
Diffstat (limited to 'audio/xmms-audiofile')
-rw-r--r--audio/xmms-audiofile/Makefile35
-rw-r--r--audio/xmms-audiofile/distinfo1
-rw-r--r--audio/xmms-audiofile/files/patch-audiofile.c11
-rw-r--r--audio/xmms-audiofile/files/patch-ltmain.sh16
-rw-r--r--audio/xmms-audiofile/pkg-comment1
-rw-r--r--audio/xmms-audiofile/pkg-descr8
-rw-r--r--audio/xmms-audiofile/pkg-plist1
7 files changed, 73 insertions, 0 deletions
diff --git a/audio/xmms-audiofile/Makefile b/audio/xmms-audiofile/Makefile
new file mode 100644
index 000000000000..690302f4a1df
--- /dev/null
+++ b/audio/xmms-audiofile/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xmms-audiofile
+# Date created: 4 Feb 2003
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-audiofile
+PORTVERSION= 0.1
+CATEGORIES= audio
+MASTER_SITES= http://www.68k.org/~michael/xmms/
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib ${PTHREAD_CFLAGS}" \
+ LIBS="${LIBS} ${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CFLAGS =|CFLAGS = @CFLAGS@|; \
+ s|LIBS = @AUDIOFILE_LIBS@|LIBS = @AUDIOFILE_LIBS@ @LIBS@|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-audiofile/distinfo b/audio/xmms-audiofile/distinfo
new file mode 100644
index 000000000000..68daead5dc6f
--- /dev/null
+++ b/audio/xmms-audiofile/distinfo
@@ -0,0 +1 @@
+MD5 (xmms-audiofile-0.1.tar.gz) = 81e4be5e596ea82d5907d1600d3f6360
diff --git a/audio/xmms-audiofile/files/patch-audiofile.c b/audio/xmms-audiofile/files/patch-audiofile.c
new file mode 100644
index 000000000000..39c43e6e33c9
--- /dev/null
+++ b/audio/xmms-audiofile/files/patch-audiofile.c
@@ -0,0 +1,11 @@
+--- audiofile.c.orig Thu Sep 12 01:28:40 2002
++++ audiofile.c Thu Sep 12 01:29:11 2002
+@@ -18,7 +18,7 @@
+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+ MA 02111-1307, USA.
+ */
+-
++#include <pthread.h>
+ #include <config.h>
+
+ #include <glib.h>
diff --git a/audio/xmms-audiofile/files/patch-ltmain.sh b/audio/xmms-audiofile/files/patch-ltmain.sh
new file mode 100644
index 000000000000..3f6b404b5bfb
--- /dev/null
+++ b/audio/xmms-audiofile/files/patch-ltmain.sh
@@ -0,0 +1,16 @@
+--- ltmain.sh.orig Wed Mar 27 14:10:10 2002
++++ ltmain.sh Mon Sep 9 02:23:20 2002
+@@ -4209,11 +4209,13 @@
+ IFS="$save_ifs"
+ fi
+
++ if /usr/bin/false; then
+ # Install the pseudo-library for information purposes.
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/xmms-audiofile/pkg-comment b/audio/xmms-audiofile/pkg-comment
new file mode 100644
index 000000000000..11fb2a3f0c78
--- /dev/null
+++ b/audio/xmms-audiofile/pkg-comment
@@ -0,0 +1 @@
+XMMS plugin to allow playing libaudiofile supported files
diff --git a/audio/xmms-audiofile/pkg-descr b/audio/xmms-audiofile/pkg-descr
new file mode 100644
index 000000000000..085eab0e2efc
--- /dev/null
+++ b/audio/xmms-audiofile/pkg-descr
@@ -0,0 +1,8 @@
+This plug-in for XMMS allows users to play any file which the Audio
+File Library can read. Common formats such as AIFF, AIFF-C, WAVE,
+and NeXT/ Sun .snd/.au are supported.
+
+WWW: http://www.68k.org/~michael/xmms/
+
+- David
+dyeske@yahoo.com
diff --git a/audio/xmms-audiofile/pkg-plist b/audio/xmms-audiofile/pkg-plist
new file mode 100644
index 000000000000..3071b4827afc
--- /dev/null
+++ b/audio/xmms-audiofile/pkg-plist
@@ -0,0 +1 @@
+lib/xmms/Input/libaf.so