aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-curses/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2014-04-09 17:23:12 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2014-04-09 17:23:12 +0000
commit55f54114ba19a7ca8aa3e83ca097441bbb4fcbeb (patch)
tree4a5294b670ef92505e95491b4ce09134e7258901 /audio/xmms-curses/Makefile
parenta4a7f338494a6e3e7114123d7bdfd9a5aee1be49 (diff)
downloadports-55f54114ba19a7ca8aa3e83ca097441bbb4fcbeb.tar.gz
ports-55f54114ba19a7ca8aa3e83ca097441bbb4fcbeb.zip
Notes
Diffstat (limited to 'audio/xmms-curses/Makefile')
-rw-r--r--audio/xmms-curses/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/audio/xmms-curses/Makefile b/audio/xmms-curses/Makefile
index 12b247ec7ab2..6e533f9f0932 100644
--- a/audio/xmms-curses/Makefile
+++ b/audio/xmms-curses/Makefile
@@ -18,7 +18,6 @@ RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
USES= gettext iconv
-NO_STAGE= yes
USE_GNOME= gtk12
USE_XORG= x11 xau xcb xdmcp xext xi
@@ -28,11 +27,9 @@ do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} -lncurses `xmms-config --cflags --libs` -o xmms-curses *.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xmms-curses ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
-.if !exists(${PREFIX}/etc/${PORTNAME}.conf)
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmms-curses ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf \
+ ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
.include <bsd.port.mk>