aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-flac/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2013-06-09 19:30:58 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2013-06-09 19:30:58 +0000
commit1f2b1eac8efc6c78fe5812a440328a74c1db3ec5 (patch)
tree45e6d01ac243fc692b2b3dc21ccf4af150938e8d /audio/xmms-flac/Makefile
parentb6702c813611f59c5c532b812919372252db5fc7 (diff)
downloadports-1f2b1eac8efc6c78fe5812a440328a74c1db3ec5.tar.gz
ports-1f2b1eac8efc6c78fe5812a440328a74c1db3ec5.zip
Notes
Diffstat (limited to 'audio/xmms-flac/Makefile')
-rw-r--r--audio/xmms-flac/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index fb7b4a923f9a..b0515a026bb0 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -1,35 +1,33 @@
# $FreeBSD$
PORTNAME= xmms-flac
-PORTVERSION= 1.2.1
-PORTREVISION= 3
+PORTVERSION= 1.3.0
CATEGORIES= audio
-MASTER_SITES= SF/flac/flac-src/flac-${PORTVERSION}-src
+MASTER_SITES= http://downloads.xiph.org/releases/flac/
DISTNAME= flac-${PORTVERSION}
MAINTAINER= naddy@FreeBSD.org
COMMENT= XMMS input plugin for playing FLAC files
-LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
- FLAC.10:${PORTSDIR}/audio/flac \
- pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs \
+LIB_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms \
+ FLAC:${PORTSDIR}/audio/flac \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
ogg:${PORTSDIR}/audio/libogg
-USE_AUTOTOOLS= libtool
USES= gettext iconv
+USE_AUTOTOOLS= libtool
USE_GNOME= gtk12
USE_XORG= x11 xau xcb xdmcp xext xi
-CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
- --with-ogg="${LOCALBASE}" \
- --with-xmms-prefix="${LOCALBASE}"
+USE_XZ= yes
+
+CONFIGURE_ARGS= --disable-silent-rules
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
MAKEFILE= ${FILESDIR}/Makefile
MAKE_JOBS_SAFE= yes
-# "obj" is magic to our make(1)
-post-configure:
- @${RM} -rf ${WRKSRC}/obj
-
# XXX
post-install:
${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la