aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-flac
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2013-06-09 19:30:58 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2013-06-09 19:30:58 +0000
commit1f2b1eac8efc6c78fe5812a440328a74c1db3ec5 (patch)
tree45e6d01ac243fc692b2b3dc21ccf4af150938e8d /audio/xmms-flac
parentb6702c813611f59c5c532b812919372252db5fc7 (diff)
downloadports-1f2b1eac8efc6c78fe5812a440328a74c1db3ec5.tar.gz
ports-1f2b1eac8efc6c78fe5812a440328a74c1db3ec5.zip
Notes
Diffstat (limited to 'audio/xmms-flac')
-rw-r--r--audio/xmms-flac/Makefile26
-rw-r--r--audio/xmms-flac/distinfo4
-rw-r--r--audio/xmms-flac/files/patch-configure14
-rw-r--r--audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in35
-rw-r--r--audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c14
-rw-r--r--audio/xmms-flac/pkg-descr4
6 files changed, 50 insertions, 47 deletions
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index fb7b4a923f9a..b0515a026bb0 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -1,35 +1,33 @@
# $FreeBSD$
PORTNAME= xmms-flac
-PORTVERSION= 1.2.1
-PORTREVISION= 3
+PORTVERSION= 1.3.0
CATEGORIES= audio
-MASTER_SITES= SF/flac/flac-src/flac-${PORTVERSION}-src
+MASTER_SITES= http://downloads.xiph.org/releases/flac/
DISTNAME= flac-${PORTVERSION}
MAINTAINER= naddy@FreeBSD.org
COMMENT= XMMS input plugin for playing FLAC files
-LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
- FLAC.10:${PORTSDIR}/audio/flac \
- pthread-stubs.0:${PORTSDIR}/devel/libpthread-stubs \
+LIB_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms \
+ FLAC:${PORTSDIR}/audio/flac \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
ogg:${PORTSDIR}/audio/libogg
-USE_AUTOTOOLS= libtool
USES= gettext iconv
+USE_AUTOTOOLS= libtool
USE_GNOME= gtk12
USE_XORG= x11 xau xcb xdmcp xext xi
-CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
- --with-ogg="${LOCALBASE}" \
- --with-xmms-prefix="${LOCALBASE}"
+USE_XZ= yes
+
+CONFIGURE_ARGS= --disable-silent-rules
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
MAKEFILE= ${FILESDIR}/Makefile
MAKE_JOBS_SAFE= yes
-# "obj" is magic to our make(1)
-post-configure:
- @${RM} -rf ${WRKSRC}/obj
-
# XXX
post-install:
${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la
diff --git a/audio/xmms-flac/distinfo b/audio/xmms-flac/distinfo
index 72f3a3237456..60d728331dda 100644
--- a/audio/xmms-flac/distinfo
+++ b/audio/xmms-flac/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flac-1.2.1.tar.gz) = 9635a44bceb478bbf2ee8a785cf6986fba525afb5fad1fd4bba73cf71f2d3edf
-SIZE (flac-1.2.1.tar.gz) = 2009217
+SHA256 (flac-1.3.0.tar.xz) = fa2d64aac1f77e31dfbb270aeb08f5b32e27036a52ad15e69a77e309528010dc
+SIZE (flac-1.3.0.tar.xz) = 1084256
diff --git a/audio/xmms-flac/files/patch-configure b/audio/xmms-flac/files/patch-configure
index 75fe5afb534a..f4d604e92fac 100644
--- a/audio/xmms-flac/files/patch-configure
+++ b/audio/xmms-flac/files/patch-configure
@@ -1,14 +1,14 @@
$FreeBSD$
---- configure.orig
-+++ configure
-@@ -23490,7 +23490,7 @@
+--- configure.orig 2013-05-27 10:11:54.740045000 +0200
++++ configure 2013-06-09 18:15:53.000000000 +0200
+@@ -19807,7 +19807,7 @@ else
CPPFLAGS="-DNDEBUG $CPPFLAGS"
if test "x$GCC" = xyes; then
- CPPFLAGS="-DFLaC__INLINE=__inline__ $CPPFLAGS"
-- CFLAGS="-O3 -funroll-loops -finline-functions -Wall -W -Winline $CFLAGS"
-+ CFLAGS="-Wall -W $CFLAGS"
+ if test "x$user_cflags" = x; then
+- CFLAGS="-O3 -funroll-loops -Wall -W -Winline"
++ CFLAGS="-Wall -W"
+ fi
fi
fi
-
diff --git a/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
index 8d8965c55cc2..acdd7b0b88e4 100644
--- a/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
+++ b/audio/xmms-flac/files/patch-src_plugin__xmms_Makefile.in
@@ -1,28 +1,9 @@
$FreeBSD$
---- src/plugin_xmms/Makefile.in.orig
-+++ src/plugin_xmms/Makefile.in
-@@ -147,7 +147,7 @@
- LIBS = @LIBS@
-
- # Don't build a static library
--LIBTOOL = $(top_builddir)/libtool-disable-static
-+LIBTOOL = @LIBTOOL@ --tag=disable-static
- LN_S = @LN_S@
- LTLIBICONV = @LTLIBICONV@
- LTLIBOBJS = @LTLIBOBJS@
-@@ -264,8 +264,7 @@
- $(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
- $(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
- $(top_builddir)/src/share/utf8/libutf8.la \
-- $(top_builddir)/src/libFLAC/libFLAC.la \
-- -L$(top_builddir)/src/libFLAC/.libs \
-+ -lFLAC \
- @OGG_LIBS@ \
- @XMMS_LIBS@ \
- @LIBICONV@
-@@ -283,8 +282,7 @@
+--- src/plugin_xmms/Makefile.in.orig 2013-05-27 10:11:57.951933000 +0200
++++ src/plugin_xmms/Makefile.in 2013-06-09 19:13:03.000000000 +0200
+@@ -127,8 +127,7 @@ libxmms_flac_la_DEPENDENCIES = \
$(top_builddir)/src/share/grabbag/libgrabbag.la \
$(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
$(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
@@ -32,3 +13,13 @@ $FreeBSD$
am__objects_1 = charset.lo configure.lo fileinfo.lo http.lo plugin.lo \
tag.lo
am_libxmms_flac_la_OBJECTS = $(am__objects_1)
+@@ -360,8 +359,7 @@ libxmms_flac_la_LIBADD = \
+ $(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
+ $(top_builddir)/src/share/replaygain_synthesis/libreplaygain_synthesis.la \
+ $(top_builddir)/src/share/utf8/libutf8.la \
+- $(top_builddir)/src/libFLAC/libFLAC.la \
+- -L$(top_builddir)/src/libFLAC/.libs \
++ -lFLAC \
+ @XMMS_LIBS@ \
+ @LIBICONV@
+
diff --git a/audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c b/audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c
new file mode 100644
index 000000000000..6bb679e96229
--- /dev/null
+++ b/audio/xmms-flac/files/patch-src_plugin__xmms_plugin.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/plugin_xmms/plugin.c.orig
++++ src/plugin_xmms/plugin.c
+@@ -140,7 +140,7 @@
+ static unsigned bitrate_history_[BITRATE_HIST_SIZE];
+
+
+-InputPlugin *get_iplugin_info(void)
++FLAC_API InputPlugin *get_iplugin_info(void)
+ {
+ flac_ip.description = g_strdup_printf("Reference FLAC Player v%s", FLAC__VERSION_STRING);
+ return &flac_ip;
diff --git a/audio/xmms-flac/pkg-descr b/audio/xmms-flac/pkg-descr
index 3de8dcdd0c2d..d9fc597580d1 100644
--- a/audio/xmms-flac/pkg-descr
+++ b/audio/xmms-flac/pkg-descr
@@ -1,5 +1,5 @@
-FLAC stands for Free Lossless Audio Codec.
+FLAC is an Open Source lossless audio codec.
This is an XMMS input plugin for FLAC files.
-WWW: http://flac.sourceforge.net/
+WWW: https://www.xiph.org/flac/