aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-imms/Makefile
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2005-01-23 01:03:51 +0000
committerBrian Feldman <green@FreeBSD.org>2005-01-23 01:03:51 +0000
commit39f40eba5915a41e834673e903fa03ab89c93288 (patch)
tree7f9cbb4df1281e601b3353083283b92d79171c9b /audio/xmms-imms/Makefile
parent4656244420e9cfaac9e61e659193bcd7954a2d32 (diff)
downloadports-39f40eba5915a41e834673e903fa03ab89c93288.tar.gz
ports-39f40eba5915a41e834673e903fa03ab89c93288.zip
Notes
Diffstat (limited to 'audio/xmms-imms/Makefile')
-rw-r--r--audio/xmms-imms/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/audio/xmms-imms/Makefile b/audio/xmms-imms/Makefile
index ca267dcbb195..039cf810dd9e 100644
--- a/audio/xmms-imms/Makefile
+++ b/audio/xmms-imms/Makefile
@@ -23,10 +23,6 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
fftw3f.3:${PORTSDIR}/math/fftw3-float \
tag.4:${PORTSDIR}/audio/taglib
-BROKEN= "Does not compile"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
@@ -41,4 +37,15 @@ CONFIGURE_ARGS+=--enable-debug
.endif
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_REINPLACE= yes
+
+post-patch:
+ @cd ${WRKSRC} && \
+ ${REINPLACE_CMD} 's:#include.<stdint\.h>:#include <sys/types.h>:' \
+ players/xmms/plugin.h analyzer/spectrum.h analyzer/analyzer.cc
+.endif
+
+.include <bsd.port.post.mk>