aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-infopipe
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-24 07:34:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-24 07:34:45 +0000
commit4e0793af7d629e294b72ad7cdf897293f0a7458a (patch)
tree7d3d85b1d793f0ce6b1ac1fbf076af267080dbee /audio/xmms-infopipe
parent6d67673b40cc54bff23f50f74cc2e9f38a7e2c9f (diff)
downloadports-4e0793af7d629e294b72ad7cdf897293f0a7458a.tar.gz
ports-4e0793af7d629e294b72ad7cdf897293f0a7458a.zip
Notes
Diffstat (limited to 'audio/xmms-infopipe')
-rw-r--r--audio/xmms-infopipe/Makefile23
-rw-r--r--audio/xmms-infopipe/distinfo1
-rw-r--r--audio/xmms-infopipe/pkg-descr8
-rw-r--r--audio/xmms-infopipe/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/audio/xmms-infopipe/Makefile b/audio/xmms-infopipe/Makefile
new file mode 100644
index 000000000000..0bfa5fdd8dc0
--- /dev/null
+++ b/audio/xmms-infopipe/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: xmms-infopipe
+# Date created: 14 July 2003
+# Whom: mig
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-infopipe
+PORTVERSION= 1.3
+CATEGORIES= audio
+MASTER_SITES= http://www.beastwithin.org/users/wwwwolf/code/xmms/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mig@mig-29.net
+COMMENT= Create a named pipe to retrive xmms info about currently playing song
+
+RUN_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-infopipe/distinfo b/audio/xmms-infopipe/distinfo
new file mode 100644
index 000000000000..71060fb21553
--- /dev/null
+++ b/audio/xmms-infopipe/distinfo
@@ -0,0 +1 @@
+MD5 (xmms-infopipe-1.3.tar.gz) = 1ccc90254c58a81f87abc43720fe71bf
diff --git a/audio/xmms-infopipe/pkg-descr b/audio/xmms-infopipe/pkg-descr
new file mode 100644
index 000000000000..82831165de0e
--- /dev/null
+++ b/audio/xmms-infopipe/pkg-descr
@@ -0,0 +1,8 @@
+Opens a named pipe to /tmp/xmms-info. When read from there, it just
+returns plain text that has information about currently playing
+song.
+
+WWW: http://www.beastwithin.org/users/wwwwolf/code/xmms/infopipe.html
+
+- Manuel Rodrigo Rabade Garcia
+mig@mig-29.net
diff --git a/audio/xmms-infopipe/pkg-plist b/audio/xmms-infopipe/pkg-plist
new file mode 100644
index 000000000000..2a41bfefe207
--- /dev/null
+++ b/audio/xmms-infopipe/pkg-plist
@@ -0,0 +1,7 @@
+lib/xmms/General/libinfopipe-1.3.so.1
+@exec ln -s %D/lib/xmms/General/libinfopipe-1.3.so.1 %D/lib/xmms/General/libinfopipe-1.3.so
+@exec ln -s %D/lib/xmms/General/libinfopipe-1.3.so.1 %D/lib/xmms/General/libinfopipe.so
+lib/xmms/General/libinfopipe.la
+lib/xmms/General/libinfopipe.a
+@unexec rm %D/lib/xmms/General/libinfopipe-1.3.so
+@unexec rm %D/lib/xmms/General/libinfopipe.so