aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-mad
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-03 03:17:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-03 03:17:55 +0000
commit092135c4998244b1b229fc55b0ba1462a801e3ec (patch)
tree447f40f12d039f95bfe5f5f8b1d59fff0b0dcdb3 /audio/xmms-mad
parent5dc9b7f571c5ff107f23c55359449e1320f5bc23 (diff)
downloadports-092135c4998244b1b229fc55b0ba1462a801e3ec.tar.gz
ports-092135c4998244b1b229fc55b0ba1462a801e3ec.zip
Notes
Diffstat (limited to 'audio/xmms-mad')
-rw-r--r--audio/xmms-mad/Makefile28
-rw-r--r--audio/xmms-mad/distinfo1
-rw-r--r--audio/xmms-mad/files/patch-config::ltmain.sh16
-rw-r--r--audio/xmms-mad/files/patch-src::input.c13
-rw-r--r--audio/xmms-mad/pkg-comment1
-rw-r--r--audio/xmms-mad/pkg-descr8
-rw-r--r--audio/xmms-mad/pkg-plist1
7 files changed, 68 insertions, 0 deletions
diff --git a/audio/xmms-mad/Makefile b/audio/xmms-mad/Makefile
new file mode 100644
index 000000000000..e22d0a9c7b5d
--- /dev/null
+++ b/audio/xmms-mad/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xmms-mad
+# Date created: 30 Aug 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-mad
+PORTVERSION= 0.1.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xmms-mad
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-mad/distinfo b/audio/xmms-mad/distinfo
new file mode 100644
index 000000000000..b7cf2df50ddc
--- /dev/null
+++ b/audio/xmms-mad/distinfo
@@ -0,0 +1 @@
+MD5 (xmms-mad-0.1.1.tar.gz) = c0a55a41f4e68f33d581cc88c2a21762
diff --git a/audio/xmms-mad/files/patch-config::ltmain.sh b/audio/xmms-mad/files/patch-config::ltmain.sh
new file mode 100644
index 000000000000..f002aebec32f
--- /dev/null
+++ b/audio/xmms-mad/files/patch-config::ltmain.sh
@@ -0,0 +1,16 @@
+--- config/ltmain.sh.orig Mon Sep 2 23:58:38 2002
++++ config/ltmain.sh Mon Sep 2 23:59:23 2002
+@@ -4246,11 +4246,13 @@
+ IFS="$save_ifs"
+ fi
+
++ if /usr/bin/false; then
+ # Install the pseudo-library for information purposes.
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/xmms-mad/files/patch-src::input.c b/audio/xmms-mad/files/patch-src::input.c
new file mode 100644
index 000000000000..f17277c38a12
--- /dev/null
+++ b/audio/xmms-mad/files/patch-src::input.c
@@ -0,0 +1,13 @@
+--- src/input.c.orig Sat Aug 31 02:39:43 2002
++++ src/input.c Sat Aug 31 02:41:14 2002
+@@ -20,6 +20,10 @@
+ */
+ #include "config.h"
+
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif /* HAVE_SYS_TYPES_H */
++
+ #ifdef HAVE_ASSERT_H
+ #include <assert.h>
+ #endif /* HAVE_ASSERT_H */
diff --git a/audio/xmms-mad/pkg-comment b/audio/xmms-mad/pkg-comment
new file mode 100644
index 000000000000..6319b796e1cb
--- /dev/null
+++ b/audio/xmms-mad/pkg-comment
@@ -0,0 +1 @@
+A XMMS input plugin that uses libmad
diff --git a/audio/xmms-mad/pkg-descr b/audio/xmms-mad/pkg-descr
new file mode 100644
index 000000000000..26e97807e51f
--- /dev/null
+++ b/audio/xmms-mad/pkg-descr
@@ -0,0 +1,8 @@
+xmms-mad is an input plugin for xmms (http://www.xmms.org/) that
+uses libmad (http://mad.sourceforge.net/) to decode MPEG layer 1/2/3
+files and streams.
+
+WWW: http://xmms-mad.sourceforge.net/
+
+- David
+dyeske@yahoo.com
diff --git a/audio/xmms-mad/pkg-plist b/audio/xmms-mad/pkg-plist
new file mode 100644
index 000000000000..1823049bd446
--- /dev/null
+++ b/audio/xmms-mad/pkg-plist
@@ -0,0 +1 @@
+lib/xmms/Input/libxmmsmad.so