aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-mailnotify
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2002-11-15 21:43:38 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2002-11-15 21:43:38 +0000
commitcdbd4b39db297fced3265de995cee1d1463e85cd (patch)
tree357925696c86eb95d2576f6df0023d60e862fd9b /audio/xmms-mailnotify
parentfbe2fe602ee0d585efe2c14842d45b7bbd0ce9e0 (diff)
downloadports-cdbd4b39db297fced3265de995cee1d1463e85cd.tar.gz
ports-cdbd4b39db297fced3265de995cee1d1463e85cd.zip
Notes
Diffstat (limited to 'audio/xmms-mailnotify')
-rw-r--r--audio/xmms-mailnotify/Makefile23
-rw-r--r--audio/xmms-mailnotify/distinfo1
-rw-r--r--audio/xmms-mailnotify/files/patch-aa19
-rw-r--r--audio/xmms-mailnotify/pkg-comment1
-rw-r--r--audio/xmms-mailnotify/pkg-descr4
-rw-r--r--audio/xmms-mailnotify/pkg-plist2
6 files changed, 50 insertions, 0 deletions
diff --git a/audio/xmms-mailnotify/Makefile b/audio/xmms-mailnotify/Makefile
new file mode 100644
index 000000000000..0ac944b43887
--- /dev/null
+++ b/audio/xmms-mailnotify/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: xmms-mailnotify
+# Date created: 03.02.2002
+# Whom: Tilman Linneweh <arved@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= xmms-mailnotify
+PORTVERSION= 0.2.0
+CATEGORIES= audio
+MASTER_SITES= http://iso.kapsobor.de/xmms/
+
+MAINTAINER= arved@FreeBSD.org
+
+LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-mailnotify/distinfo b/audio/xmms-mailnotify/distinfo
new file mode 100644
index 000000000000..de5c2538fe49
--- /dev/null
+++ b/audio/xmms-mailnotify/distinfo
@@ -0,0 +1 @@
+MD5 (xmms-mailnotify-0.2.0.tar.gz) = 83d4bcb11c9fcdcf17c73a0a4a9cbd77
diff --git a/audio/xmms-mailnotify/files/patch-aa b/audio/xmms-mailnotify/files/patch-aa
new file mode 100644
index 000000000000..f3c9db43bf07
--- /dev/null
+++ b/audio/xmms-mailnotify/files/patch-aa
@@ -0,0 +1,19 @@
+--- mailnotify.c.orig Sun Feb 3 21:12:45 2002
++++ mailnotify.c Sun Feb 3 21:13:05 2002
+@@ -82,14 +82,14 @@
+ gchar command[256];
+ gboolean runcmd;
+ gchar alertfile[256];
+- } folders[MAX_FOLDERS] = {0};
++ } folders[MAX_FOLDERS] = {{{0}}};
+
+ struct origin {
+ gchar senderaddr[256];
+ gboolean runcmd;
+ gchar command[256];
+ gchar alertfile[256];
+- } origins[MAX_ORIGINS] = {0};
++ } origins[MAX_ORIGINS] = {{{0}}};
+
+
+ /* #if !defined(UTIMBUF)
diff --git a/audio/xmms-mailnotify/pkg-comment b/audio/xmms-mailnotify/pkg-comment
new file mode 100644
index 000000000000..55943544858e
--- /dev/null
+++ b/audio/xmms-mailnotify/pkg-comment
@@ -0,0 +1 @@
+XMMS plugin, that plays a sound on incoming mail and opens the MUA
diff --git a/audio/xmms-mailnotify/pkg-descr b/audio/xmms-mailnotify/pkg-descr
new file mode 100644
index 000000000000..20c3deee5dc8
--- /dev/null
+++ b/audio/xmms-mailnotify/pkg-descr
@@ -0,0 +1,4 @@
+XMMS plugin, that plays a sound on incoming mail and opens the MUA
+
+WWW: http://iso.kapsobor.de/xmms/
+Author: Felix Willmann <iso@kapsobor.de>
diff --git a/audio/xmms-mailnotify/pkg-plist b/audio/xmms-mailnotify/pkg-plist
new file mode 100644
index 000000000000..68a00565d21b
--- /dev/null
+++ b/audio/xmms-mailnotify/pkg-plist
@@ -0,0 +1,2 @@
+lib/xmms/General/libmailnotify.so
+lib/xmms/General/alert.wav