aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-midi
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-10-28 00:21:40 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-10-28 00:21:40 +0000
commita4cb8c9f6c3ca604e7a3a2fbc0d1ee1338a34f56 (patch)
treee82fa32251aa3ac5c2bb2a0662b73cee6459b4d4 /audio/xmms-midi
parent1d3ebb6ef6395e097141cf577dad83ed42304c91 (diff)
downloadports-a4cb8c9f6c3ca604e7a3a2fbc0d1ee1338a34f56.tar.gz
ports-a4cb8c9f6c3ca604e7a3a2fbc0d1ee1338a34f56.zip
Notes
Diffstat (limited to 'audio/xmms-midi')
-rw-r--r--audio/xmms-midi/Makefile24
-rw-r--r--audio/xmms-midi/distinfo1
-rw-r--r--audio/xmms-midi/files/patch-Makefile.am17
-rw-r--r--audio/xmms-midi/files/patch-config.h13
-rw-r--r--audio/xmms-midi/files/patch-mix.c14
-rw-r--r--audio/xmms-midi/files/patch-resample.c14
-rw-r--r--audio/xmms-midi/files/patch-xmms__a.c14
-rw-r--r--audio/xmms-midi/pkg-comment1
-rw-r--r--audio/xmms-midi/pkg-descr4
-rw-r--r--audio/xmms-midi/pkg-plist2
10 files changed, 104 insertions, 0 deletions
diff --git a/audio/xmms-midi/Makefile b/audio/xmms-midi/Makefile
new file mode 100644
index 000000000000..7af5f51d5fb7
--- /dev/null
+++ b/audio/xmms-midi/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xmms-midi
+# Date created: 2002-10-14
+# Whom: Hendrik Scholz <hendrik@scholz.net>
+#
+# $FreeBSD$
+
+PORTNAME= xmms-midi
+PORTVERSION= 0.03
+CATEGORIES= audio
+MASTER_SITES= http://ban.joh.cam.ac.uk/~cr212/xmms-midi/
+
+MAINTAINER= hendrik@scholz.net
+
+LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms
+RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
+
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_X_PREFIX= yes
+
+USE_AUTOMAKE= yes
+USE_LIBTOOL= yes
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-midi/distinfo b/audio/xmms-midi/distinfo
new file mode 100644
index 000000000000..a1f857d64af6
--- /dev/null
+++ b/audio/xmms-midi/distinfo
@@ -0,0 +1 @@
+MD5 (xmms-midi-0.03.tar.gz) = a35c62378fc3ccdf420fe81636e5b2f8
diff --git a/audio/xmms-midi/files/patch-Makefile.am b/audio/xmms-midi/files/patch-Makefile.am
new file mode 100644
index 000000000000..899d88a15220
--- /dev/null
+++ b/audio/xmms-midi/files/patch-Makefile.am
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- Makefile.am.orig Sat Oct 26 23:59:48 2002
++++ Makefile.am Sun Oct 27 00:02:18 2002
+@@ -1,9 +1,9 @@
+-xmmsinputdir = $(prefix)/xmms/Input
++xmmsinputdir = $(prefix)/lib/xmms/Input
+
+ xmmsinput_LTLIBRARIES = libmid.la
+
+ CFLAGS = @CFLAGS@ -DTIMID_VERSION=\"0.2i\"
+
+ libmid_la_SOURCES = common.c controls.c dumb_c.c filter.c instrum.c mid.c mix.c output.c playmidi.c readmidi.c resample.c tables.c timidity.c xmms_a.c
+-
++libmid_la_LDFLAGS = -module -export-dynamic -avoid-version
+
diff --git a/audio/xmms-midi/files/patch-config.h b/audio/xmms-midi/files/patch-config.h
new file mode 100644
index 000000000000..6f83b99c7b04
--- /dev/null
+++ b/audio/xmms-midi/files/patch-config.h
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- config.h.orig Mon Jan 24 01:18:02 2000
++++ config.h Sat Oct 26 23:24:50 2002
+@@ -359,3 +359,7 @@
+ #include <errno.h>
+ #define PI 3.14159265358979323846
+ #endif
++
++#ifdef __FreeBSD__
++#define PI 3.14159265358979323846
++#endif
diff --git a/audio/xmms-midi/files/patch-mix.c b/audio/xmms-midi/files/patch-mix.c
new file mode 100644
index 000000000000..dd111d9114dc
--- /dev/null
+++ b/audio/xmms-midi/files/patch-mix.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- mix.c.orig Mon Jan 24 01:18:02 2000
++++ mix.c Sat Oct 26 23:24:50 2002
+@@ -23,7 +23,7 @@
+
+ #include <math.h>
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #include "config.h"
+ #include "common.h"
diff --git a/audio/xmms-midi/files/patch-resample.c b/audio/xmms-midi/files/patch-resample.c
new file mode 100644
index 000000000000..dca94b962193
--- /dev/null
+++ b/audio/xmms-midi/files/patch-resample.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- resample.c.orig Sat Oct 26 23:32:35 2002
++++ resample.c Sat Oct 26 23:32:51 2002
+@@ -22,7 +22,7 @@
+
+ #include <math.h>
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #include "config.h"
+ #include "common.h"
diff --git a/audio/xmms-midi/files/patch-xmms__a.c b/audio/xmms-midi/files/patch-xmms__a.c
new file mode 100644
index 000000000000..717755f639ea
--- /dev/null
+++ b/audio/xmms-midi/files/patch-xmms__a.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- xmms_a.c.orig Sat Oct 26 23:38:05 2002
++++ xmms_a.c Sat Oct 26 23:38:08 2002
+@@ -37,7 +37,7 @@
+ #include <stdio.h>
+
+ #ifdef __FreeBSD__
+-#include <machine/soundcard.h>
++#include <sys/soundcard.h>
+ #endif
+
+ #include "mid.h"
diff --git a/audio/xmms-midi/pkg-comment b/audio/xmms-midi/pkg-comment
new file mode 100644
index 000000000000..4580e2f48322
--- /dev/null
+++ b/audio/xmms-midi/pkg-comment
@@ -0,0 +1 @@
+XMMS input plugin to play midi files
diff --git a/audio/xmms-midi/pkg-descr b/audio/xmms-midi/pkg-descr
new file mode 100644
index 000000000000..ac471240e22d
--- /dev/null
+++ b/audio/xmms-midi/pkg-descr
@@ -0,0 +1,4 @@
+xmms-midi is a XMMS Input plugin to play midi files.
+
+WWW: http://ban.joh.cam.ac.uk/~cr212/xmms-midi/
+- Hendrik Scholz <hendrik@scholz.net>
diff --git a/audio/xmms-midi/pkg-plist b/audio/xmms-midi/pkg-plist
new file mode 100644
index 000000000000..08e458df9b63
--- /dev/null
+++ b/audio/xmms-midi/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+lib/xmms/Input/libmid.so