aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-modplug
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-08 13:08:55 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-08 13:08:55 +0000
commitdf257a16f518b7a000dab212801b0ab918ba7fee (patch)
treec06806719bd2c7deb7ef95574b66bb8b2fdc6489 /audio/xmms-modplug
parentf248828a9c6e4d62b76a4fb770bcaa235a03b2ac (diff)
downloadports-df257a16f518b7a000dab212801b0ab918ba7fee.tar.gz
ports-df257a16f518b7a000dab212801b0ab918ba7fee.zip
Notes
Diffstat (limited to 'audio/xmms-modplug')
-rw-r--r--audio/xmms-modplug/Makefile30
-rw-r--r--audio/xmms-modplug/distinfo3
-rw-r--r--audio/xmms-modplug/pkg-descr8
3 files changed, 41 insertions, 0 deletions
diff --git a/audio/xmms-modplug/Makefile b/audio/xmms-modplug/Makefile
new file mode 100644
index 000000000000..b7ba5e65ff9a
--- /dev/null
+++ b/audio/xmms-modplug/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xmms-modplug
+# Date created: 8 January 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= modplug
+PORTVERSION= 2.0.5
+CATEGORIES?= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}-${PKGNAMEPREFIX:S/-//}
+PKGNAMEPREFIX= xmms-
+DISTNAME= ${PORTNAME}${PKGNAMEPREFIX}2.05
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A modplug-based plugin for XMMS
+
+LIB_DEPENDS?= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= modplug.0:${PORTSDIR}/audio/libmodplug
+
+USE_X_PREFIX= yes
+HAS_CONFIGURE= yes
+PLUGDIR?= lib/xmms/Input
+PLIST_FILES= ${PLUGDIR}/libmodplugxmms.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/modplugxmms/.libs/libmodplugxmms.so ${PREFIX}/${PLUGDIR}/
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-modplug/distinfo b/audio/xmms-modplug/distinfo
new file mode 100644
index 000000000000..2b3b12bc486c
--- /dev/null
+++ b/audio/xmms-modplug/distinfo
@@ -0,0 +1,3 @@
+MD5 (modplugxmms-2.05.tar.gz) = 2dd9b88a02978d3001b48863b8cffc5b
+SHA256 (modplugxmms-2.05.tar.gz) = d79d1bca3e9705f93b9101e473410a92e0a5d6b83dbc0ef739ed434e45314778
+SIZE (modplugxmms-2.05.tar.gz) = 242595
diff --git a/audio/xmms-modplug/pkg-descr b/audio/xmms-modplug/pkg-descr
new file mode 100644
index 000000000000..e3f356c5a264
--- /dev/null
+++ b/audio/xmms-modplug/pkg-descr
@@ -0,0 +1,8 @@
+This port is the ModPlug plugin for XMMS. ModPlug is
+arguably the best mod-like music rendering engine
+capable of playing 22 different module formats. This
+plugin can also handle zip, rar, gzip and bzip2
+compressed mods (provided unzip, gunzip, unrar are
+installed).
+
+WWW: http://modplug-xmms.sourceforge.net/