aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-mp3cue/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-14 14:44:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-14 14:44:20 +0000
commit9bf0e19f7c88ba7266505cabece49fb4e0af137e (patch)
treea9cec143eef24cd0fdd243eda7c4d3b362e20777 /audio/xmms-mp3cue/Makefile
parentbaef2ac6ad39728712d5795037bd5fc9de3b32bf (diff)
Notes
Diffstat (limited to 'audio/xmms-mp3cue/Makefile')
-rw-r--r--audio/xmms-mp3cue/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/xmms-mp3cue/Makefile b/audio/xmms-mp3cue/Makefile
new file mode 100644
index 000000000000..9b1b74d27a06
--- /dev/null
+++ b/audio/xmms-mp3cue/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: XMMS-mp3cue
+# Date created: 12 February 2004
+# Whom: Vaidas Zlotkus <r2@music.lt>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-mp3cue
+PORTVERSION= 0.94
+CATEGORIES= audio
+MASTER_SITES= http://brianvictor.tripod.com/
+DISTNAME= XMMS-mp3cue-${PORTVERSION}
+
+MAINTAINER= r2@music.lt
+COMMENT= XMMS mp3cue adds cue file support to XMMS
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+PLIST_SUB= PORTDOCS=${DISTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/*.c
+
+.include <bsd.port.mk>