aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-openspc/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-11 20:31:11 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-11 20:31:11 +0000
commitd6afa0cff7cf571f77de7b3bf63b025bc8eed667 (patch)
treeef576207f8affc7c826ef45535580330006bd6a2 /audio/xmms-openspc/Makefile
parent577bdf19e8809517f6bd7aac17899c0278002ca5 (diff)
downloadports-d6afa0cff7cf571f77de7b3bf63b025bc8eed667.tar.gz
ports-d6afa0cff7cf571f77de7b3bf63b025bc8eed667.zip
Notes
Diffstat (limited to 'audio/xmms-openspc/Makefile')
-rw-r--r--audio/xmms-openspc/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/xmms-openspc/Makefile b/audio/xmms-openspc/Makefile
new file mode 100644
index 000000000000..4bf453297326
--- /dev/null
+++ b/audio/xmms-openspc/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: xmms-openspc
+# Date created: 11 June 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-openspc
+PORTVERSION= 0.0.3
+CATEGORIES= audio
+MASTER_SITES= http://staff.xmms.org/zinx/misc/tmp/
+DISTNAME= xmms-OpenSPC-${PORTVERSION}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= An SPC player for XMMS using OpenSPC
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
+ xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+PLIST_FILES= lib/xmms/Input/openspc.so
+
+ONLY_FOR_ARCHS= i386 # contains x86 assembler code
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+
+.include <bsd.port.mk>