aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-real-random
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-10-04 17:02:53 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-10-04 17:02:53 +0000
commitc8b6c3ab658021ce3d2f9aef0a335938a3a4c16c (patch)
treeb0649aa6c9ac8842c25062bb38044eefd10621ac /audio/xmms-real-random
parent901bdb71de907312eccf7023acb062ba4e5d5fba (diff)
downloadports-c8b6c3ab658021ce3d2f9aef0a335938a3a4c16c.tar.gz
ports-c8b6c3ab658021ce3d2f9aef0a335938a3a4c16c.zip
Notes
Diffstat (limited to 'audio/xmms-real-random')
-rw-r--r--audio/xmms-real-random/Makefile33
-rw-r--r--audio/xmms-real-random/distinfo1
-rw-r--r--audio/xmms-real-random/files/patch-Makefile21
-rw-r--r--audio/xmms-real-random/pkg-descr4
-rw-r--r--audio/xmms-real-random/pkg-plist2
5 files changed, 61 insertions, 0 deletions
diff --git a/audio/xmms-real-random/Makefile b/audio/xmms-real-random/Makefile
new file mode 100644
index 000000000000..1be05b966291
--- /dev/null
+++ b/audio/xmms-real-random/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xmms-real-random
+# Date created: 03.10.2003
+# Whom: Ulrich Spoerlein <q@uni.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-real-random
+PORTVERSION= 0.2
+CATEGORIES= audio
+MASTER_SITES= http://kingleo.home.pages.at/development/stuff/
+DISTNAME= real_random-${PORTVERSION}
+
+MAINTAINER= q@uni.de
+COMMENT= REAL shuffle mode for xmms
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_X_PREFIX= yes
+
+CONFIGURE_ENV= CFLAGS='${CFLAGS}'
+
+post-patch:
+.for Makefile in Makefile.am Makefile.in
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/' ${WRKSRC}/${Makefile}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-real-random/distinfo b/audio/xmms-real-random/distinfo
new file mode 100644
index 000000000000..1fc3328b2384
--- /dev/null
+++ b/audio/xmms-real-random/distinfo
@@ -0,0 +1 @@
+MD5 (real_random-0.2.tar.gz) = d50c70e8406b21582e7286747ac43981
diff --git a/audio/xmms-real-random/files/patch-Makefile b/audio/xmms-real-random/files/patch-Makefile
new file mode 100644
index 000000000000..d75a6d835dd6
--- /dev/null
+++ b/audio/xmms-real-random/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.am.orig Fri Oct 3 16:41:10 2003
++++ Makefile.am Fri Oct 3 16:42:27 2003
+@@ -1,6 +1,6 @@
+ lib_LTLIBRARIES = libreal_random.la
+
+-CFLAGS = $$(xmms-config --cflags)
++CFLAGS = @CFLAGS@ $$(xmms-config --cflags)
+ libreal_random_la_SOURCES = real_random.c
+ libreal_random_la_LDFLAGS= -module -avoid-version -nostdlib -lpthread
+
+--- Makefile.in.orig Fri Oct 3 16:39:36 2003
++++ Makefile.in Fri Oct 3 16:42:20 2003
+@@ -82,7 +82,7 @@
+
+ lib_LTLIBRARIES = libreal_random.la
+
+-CFLAGS = $$(xmms-config --cflags)
++CFLAGS = @CFLAGS@ $$(xmms-config --cflags)
+ libreal_random_la_SOURCES = real_random.c
+ libreal_random_la_LDFLAGS = -module -avoid-version -nostdlib -lpthread
+ CCLD = "gcc -nostdlib"
diff --git a/audio/xmms-real-random/pkg-descr b/audio/xmms-real-random/pkg-descr
new file mode 100644
index 000000000000..5e20e04e5cc1
--- /dev/null
+++ b/audio/xmms-real-random/pkg-descr
@@ -0,0 +1,4 @@
+The shuffle mode of xmms is not as I expected it. So I created this plugin
+-- Martin Oberzalek
+
+WWW: http://kingleo.home.pages.at/index_stuff.xml.php
diff --git a/audio/xmms-real-random/pkg-plist b/audio/xmms-real-random/pkg-plist
new file mode 100644
index 000000000000..753e2ddb59c5
--- /dev/null
+++ b/audio/xmms-real-random/pkg-plist
@@ -0,0 +1,2 @@
+lib/xmms/General/libreal_random.la
+lib/xmms/General/libreal_random.so