aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-sid
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-11 17:26:31 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-11 17:26:31 +0000
commit70b023e79373396db0e6aaf77b75de9db10e0543 (patch)
tree198eb47fb963b118909da97fd7878c31e5e94775 /audio/xmms-sid
parent75da8cdd2c851345db9a9d679331154d2794b5d0 (diff)
downloadports-70b023e79373396db0e6aaf77b75de9db10e0543.tar.gz
ports-70b023e79373396db0e6aaf77b75de9db10e0543.zip
Notes
Diffstat (limited to 'audio/xmms-sid')
-rw-r--r--audio/xmms-sid/Makefile32
-rw-r--r--audio/xmms-sid/distinfo1
-rw-r--r--audio/xmms-sid/files/patch-ltmain.sh16
-rw-r--r--audio/xmms-sid/pkg-comment1
-rw-r--r--audio/xmms-sid/pkg-descr9
-rw-r--r--audio/xmms-sid/pkg-plist1
6 files changed, 60 insertions, 0 deletions
diff --git a/audio/xmms-sid/Makefile b/audio/xmms-sid/Makefile
new file mode 100644
index 000000000000..3cc7739fa979
--- /dev/null
+++ b/audio/xmms-sid/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xmms-sid
+# Date created: 9 Sep 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-sid
+PORTVERSION= 0.7.4
+CATEGORIES= audio
+MASTER_SITES= http://www.tnsp.org/xs-files/
+
+MAINTAINER= dyeske@yahoo.com
+
+LIB_DEPENDS= sidplay.1:${PORTSDIR}/audio/libsidplay
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS = -O2 -W -Wall|CFLAGS = @CFLAGS@ |; \
+ s|-lstdc++||; \
+ s|^LIBS = -lsidplay|LIBS = -lsidplay -lstdc++|' \
+ ${BUILD_WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-sid/distinfo b/audio/xmms-sid/distinfo
new file mode 100644
index 000000000000..c843c4d9d13f
--- /dev/null
+++ b/audio/xmms-sid/distinfo
@@ -0,0 +1 @@
+MD5 (xmms-sid-0.7.4.tar.bz2) = 02bff37834fe8dd713e87511bb2213a4
diff --git a/audio/xmms-sid/files/patch-ltmain.sh b/audio/xmms-sid/files/patch-ltmain.sh
new file mode 100644
index 000000000000..3f6b404b5bfb
--- /dev/null
+++ b/audio/xmms-sid/files/patch-ltmain.sh
@@ -0,0 +1,16 @@
+--- ltmain.sh.orig Wed Mar 27 14:10:10 2002
++++ ltmain.sh Mon Sep 9 02:23:20 2002
+@@ -4209,11 +4209,13 @@
+ IFS="$save_ifs"
+ fi
+
++ if /usr/bin/false; then
+ # Install the pseudo-library for information purposes.
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/xmms-sid/pkg-comment b/audio/xmms-sid/pkg-comment
new file mode 100644
index 000000000000..8061446dbe34
--- /dev/null
+++ b/audio/xmms-sid/pkg-comment
@@ -0,0 +1 @@
+XMMS input plugin to play SID files
diff --git a/audio/xmms-sid/pkg-descr b/audio/xmms-sid/pkg-descr
new file mode 100644
index 000000000000..6400c7b7659d
--- /dev/null
+++ b/audio/xmms-sid/pkg-descr
@@ -0,0 +1,9 @@
+XMMS-SID is a plugin for XMMS (X MultiMedia System) which provides
+support for playing the so-called "SID tunes". For the actual
+playing, XMMS-SID uses the excellent libsidplay SID-chip/6502
+emulator engine
+
+WWW: http://www.tnsp.org/xmms-sid.php
+
+- David
+dyeske@yahoo.com
diff --git a/audio/xmms-sid/pkg-plist b/audio/xmms-sid/pkg-plist
new file mode 100644
index 000000000000..934884896d36
--- /dev/null
+++ b/audio/xmms-sid/pkg-plist
@@ -0,0 +1 @@
+lib/xmms/Input/libsid.so