aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-wma
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-10-23 04:05:18 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-10-23 04:05:18 +0000
commitda04a33ff0df45edd67b3b94e8d7acca72b82db7 (patch)
tree657a7b31cf3ddfa00c9135f190b11ece703d5098 /audio/xmms-wma
parentbdafe33dc0e689d5ded4de6a134ae704061e8570 (diff)
Notes
Diffstat (limited to 'audio/xmms-wma')
-rw-r--r--audio/xmms-wma/Makefile4
-rw-r--r--audio/xmms-wma/distinfo4
-rw-r--r--audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c41
3 files changed, 18 insertions, 31 deletions
diff --git a/audio/xmms-wma/Makefile b/audio/xmms-wma/Makefile
index 8f294663f8ff..f3e8657c56b5 100644
--- a/audio/xmms-wma/Makefile
+++ b/audio/xmms-wma/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmms-wma
-PORTVERSION= 1.0.4
-PORTREVISION= 2
+PORTVERSION= 1.0.4.1
CATEGORIES= audio
MASTER_SITES= http://mcmcc.bat.ru/xmms-wma/
@@ -36,6 +35,7 @@ pre-everything::
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} " "
@${ECHO_MSG} "WITH_ICONV=yes Enable tag recoding support using iconv"
+ @${ECHO_MSG} " "
.endif
post-extract:
diff --git a/audio/xmms-wma/distinfo b/audio/xmms-wma/distinfo
index 1f8294d8cdf4..1f8423c1de54 100644
--- a/audio/xmms-wma/distinfo
+++ b/audio/xmms-wma/distinfo
@@ -1,2 +1,2 @@
-MD5 (xmms-wma-1.0.4.tar.bz2) = 069cd8197a13047901876b35e91eb82e
-SIZE (xmms-wma-1.0.4.tar.bz2) = 145691
+MD5 (xmms-wma-1.0.4.1.tar.bz2) = 737ba66d42b6fb1bd95cc509cd51af62
+SIZE (xmms-wma-1.0.4.1.tar.bz2) = 145399
diff --git a/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
index 3047e2c1b390..94331b046cf0 100644
--- a/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
+++ b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
@@ -1,13 +1,13 @@
---- ffmpeg-strip-wma/asf.c.orig Wed May 26 19:16:39 2004
-+++ ffmpeg-strip-wma/asf.c Mon Jun 13 08:18:01 2005
+--- ffmpeg-strip-wma/asf.c.orig Sun Oct 23 08:03:33 2005
++++ ffmpeg-strip-wma/asf.c Sun Oct 23 08:03:37 2005
@@ -16,10 +16,13 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
+
-+#ifdef USE_ICONV
++#if defined(USE_ICONV)
+#include <iconv.h>
-+#endif
++#endif /* USE_ICONV */
+
#include "avformat.h"
#include "avi.h"
@@ -20,12 +20,12 @@
return str;
}
-+#ifdef USE_ICONV
- static void tag_recode(char *before, int len)
++#if defined(USE_ICONV)
+ static void tag_recode(char *before, unsigned int len)
{
int result;
@@ -842,7 +846,7 @@
- int length = len;
+ unsigned int length = len;
memcpy(ansb, before, len);
- frt = iconv_open(getlocale(), "UNICODE");
@@ -37,30 +37,17 @@
return;
return;
}
-+#endif
++#endif /* USE_ICONV */
static void get_str16_nolen(ByteIOContext *pb, int len, char *buf, int buf_size)
{
-@@ -868,12 +873,17 @@
- q = buf;
- lenz = len;
- while (len > 0) {
-- c = get_byte(pb);
-- if ((q - buf) < buf_size-1)
-- *q++ = c;
-- len--;
-+ c = get_byte(pb);
-+ if ((q - buf) < buf_size - 1)
-+ *q++ = c;
-+ len--;
+@@ -873,7 +878,9 @@
+ *q++ = c;
+ len--;
}
-- tag_recode(buf, lenz);
-+
-+#ifdef USE_ICONV
-+ tag_recode(buf, lenz);
-+#else
-+ *q = '\0';
-+#endif
++#if defined(USE_ICONV)
+ tag_recode(buf, lenz);
++#endif /* USE_ICONV */
}
static int asf_probe(AVProbeData *pd)