aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-xymms/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-04 18:48:54 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-04 18:48:54 +0000
commit2ffbea1568d45e1a758e9289b4aef24e3e55dc9c (patch)
treec4c367dfcd82a25612586cf0c27d76e98895b337 /audio/xmms-xymms/Makefile
parent98f62693ce7f8a9b0a5d9113413257c8c21cf1e7 (diff)
downloadports-2ffbea1568d45e1a758e9289b4aef24e3e55dc9c.tar.gz
ports-2ffbea1568d45e1a758e9289b4aef24e3e55dc9c.zip
Notes
Diffstat (limited to 'audio/xmms-xymms/Makefile')
-rw-r--r--audio/xmms-xymms/Makefile19
1 files changed, 5 insertions, 14 deletions
diff --git a/audio/xmms-xymms/Makefile b/audio/xmms-xymms/Makefile
index ca64bcb68115..aee3d735e232 100644
--- a/audio/xmms-xymms/Makefile
+++ b/audio/xmms-xymms/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xymms
DISTVERSION= 0.9.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= SF
PKGNAMEPREFIX= xmms-
@@ -11,29 +11,20 @@ PKGNAMEPREFIX= xmms-
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Sega Genesis GYM plugin for XMMS
-BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS= libxmms.so:${PORTSDIR}/multimedia/xmms
GNU_CONFIGURE= yes
+USES= libtool
USE_GNOME= gtk12
USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-static
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-
-PLIST_FILES= lib/xmms/Input/libxymms.a \
- lib/xmms/Input/libxymms.la \
- lib/xmms/Input/libxymms.so \
+PLIST_FILES= lib/xmms/Input/libxymms.so \
%%EXAMPLESDIR%%/sample.gym
PLIST_DIRS= %%EXAMPLESDIR%%
-post-patch:
- @${REINPLACE_CMD} -e 's|-D_REENTRANT||' ${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
-
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/samples/sample.gym ${STAGEDIR}${EXAMPLESDIR}
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>