aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms2-scrobbler
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-08-27 16:25:00 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-08-27 16:25:00 +0000
commiteda2196af7f0a281f2db87772e2af5674ed63e92 (patch)
treeec866fbad478124df71f248ce363dc67335ffd69 /audio/xmms2-scrobbler
parent11ca99259e19ec86795fc635b317db50f64c78e8 (diff)
downloadports-eda2196af7f0a281f2db87772e2af5674ed63e92.tar.gz
ports-eda2196af7f0a281f2db87772e2af5674ed63e92.zip
Notes
Diffstat (limited to 'audio/xmms2-scrobbler')
-rw-r--r--audio/xmms2-scrobbler/Makefile41
-rw-r--r--audio/xmms2-scrobbler/distinfo3
-rw-r--r--audio/xmms2-scrobbler/files/pkg-message.in8
-rw-r--r--audio/xmms2-scrobbler/pkg-descr4
4 files changed, 56 insertions, 0 deletions
diff --git a/audio/xmms2-scrobbler/Makefile b/audio/xmms2-scrobbler/Makefile
new file mode 100644
index 000000000000..f8076f894692
--- /dev/null
+++ b/audio/xmms2-scrobbler/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: snett
+# Date created: 06 Apr 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+
+PORTNAME= xmms2-scrobbler
+PORTVERSION= 0.1.1
+CATEGORIES= audio ruby
+MASTER_SITES= ftp://ftp.code-monkey.de/pub/xmms2-scrobbler/
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= A last.fm submission client for XMMS2
+
+BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/xmmsclient.so:${PORTSDIR}/audio/ruby-xmms2 \
+ ${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/gems/event-loop-0.2/gemspec.rb:${PORTSDIR}/devel/rubygem-event-loop \
+ ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/xmmsclient.so:${PORTSDIR}/audio/ruby-xmms2 \
+ ${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/gems/event-loop-0.2/gemspec.rb:${PORTSDIR}/devel/rubygem-event-loop
+
+USE_RUBY= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/xmms2-scrobbler
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on FreeBSD 4.x
+.endif
+
+do-install:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/rake PREFIX=${PREFIX}/ ${INSTALL_TARGET}
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+.include <bsd.port.post.mk>
diff --git a/audio/xmms2-scrobbler/distinfo b/audio/xmms2-scrobbler/distinfo
new file mode 100644
index 000000000000..cd75535b737a
--- /dev/null
+++ b/audio/xmms2-scrobbler/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmms2-scrobbler-0.1.1.tar.gz) = fd9764be000957434eb3e4aef9e042db
+SHA256 (xmms2-scrobbler-0.1.1.tar.gz) = 958c093a065ff2d14f63d1a83e0aeaf3aa08fac070292b7cae1b0447a8ac3077
+SIZE (xmms2-scrobbler-0.1.1.tar.gz) = 5923
diff --git a/audio/xmms2-scrobbler/files/pkg-message.in b/audio/xmms2-scrobbler/files/pkg-message.in
new file mode 100644
index 000000000000..937afdfd6bf3
--- /dev/null
+++ b/audio/xmms2-scrobbler/files/pkg-message.in
@@ -0,0 +1,8 @@
+To use XMMS2Scrobbler write your username and password to the config file
+like this:
+
+ printf "user: foo\npassword: bar" > \
+ ~/.xmms2/clients/xmms2-scrobbler/config
+
+If you wish for XMMS2Scrobbler to start when you start xmms2d, make a
+symbolic link from %%PREFIX%%/bin/xmms2-scrobbler to ~/.xmms2/startup.d/
diff --git a/audio/xmms2-scrobbler/pkg-descr b/audio/xmms2-scrobbler/pkg-descr
new file mode 100644
index 000000000000..4b496dd27ae5
--- /dev/null
+++ b/audio/xmms2-scrobbler/pkg-descr
@@ -0,0 +1,4 @@
+XMMS2-Scrobbler is a client for XMMS2 that feeds information about the songs
+you played to last.fm, formerly known as AudioScrobbler.
+
+WWW: http://code-monkey.de/pages/xmms2-scrobbler