aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms2
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2010-06-06 20:39:21 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2010-06-06 20:39:21 +0000
commitf613ac049d40272c3b27a76dbab7f6723f2a2ba2 (patch)
treee62b67c39f729f55f17b68f6438f9f1beeadd10c /audio/xmms2
parent2f2aafd9bf4a01f681da4598e18663001e4a9406 (diff)
downloadports-f613ac049d40272c3b27a76dbab7f6723f2a2ba2.tar.gz
ports-f613ac049d40272c3b27a76dbab7f6723f2a2ba2.zip
Notes
Diffstat (limited to 'audio/xmms2')
-rw-r--r--audio/xmms2/Makefile4
-rw-r--r--audio/xmms2/files/patch-src_plugins_ao_ao.c10
2 files changed, 12 insertions, 2 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 33191d46e10c..6ef5d28c588a 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= xmms2
PORTVERSION= 0.6
-PORTREVISION= 5
+PORTREVISION= 6
DISTVERSIONSUFFIX=DrMattDestruction
CATEGORIES?= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20DrMattDestruction
@@ -97,7 +97,7 @@ PLIST_SUB+= AIRPLAY="@comment "
.endif
.if !defined(WITHOUT_AO)
-LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
PLIST_SUB+= AO=""
.else
EXCLUDE+= --without-plugins="ao"
diff --git a/audio/xmms2/files/patch-src_plugins_ao_ao.c b/audio/xmms2/files/patch-src_plugins_ao_ao.c
new file mode 100644
index 000000000000..c05085ab24f1
--- /dev/null
+++ b/audio/xmms2/files/patch-src_plugins_ao_ao.c
@@ -0,0 +1,10 @@
+--- src/plugins/ao/ao.c.orig
++++ src/plugins/ao/ao.c
+@@ -160,6 +160,7 @@
+
+ /* let's just use some common format to check if the device
+ * name is valid */
++ memset(&format, 0, sizeof(format));
+ format.bits = 16;
+ format.rate = 44100;
+ format.channels = 2;