aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms2
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-05-27 22:58:34 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-05-27 22:58:34 +0000
commita4deae8088def95d808fbcb497e3a52724d16b74 (patch)
treeeb4491afbc2688a231e65d74641cfae5cda3229a /audio/xmms2
parent54ead12ec2d7ea955099a2fc6dcfd33b717188fd (diff)
downloadports-a4deae8088def95d808fbcb497e3a52724d16b74.tar.gz
ports-a4deae8088def95d808fbcb497e3a52724d16b74.zip
Notes
Diffstat (limited to 'audio/xmms2')
-rw-r--r--audio/xmms2/Makefile111
-rw-r--r--audio/xmms2/distinfo6
-rw-r--r--audio/xmms2/files/patch-src_clients_sdl-vis_Program10
-rw-r--r--audio/xmms2/files/patch-src_include_xmms_wscript11
-rw-r--r--audio/xmms2/files/patch-src_plugins_faad_Plugin17
-rw-r--r--audio/xmms2/files/patch-src_plugins_faad_mp4ff_mp4ff_int_types.h11
-rw-r--r--audio/xmms2/files/patch-src_plugins_sid_Plugin9
-rw-r--r--audio/xmms2/files/patch-src_xmms_Program17
-rw-r--r--audio/xmms2/files/slaveport-src_include_wscript11
-rw-r--r--audio/xmms2/files/slaveport-wscript11
-rw-r--r--audio/xmms2/pkg-plist26
11 files changed, 123 insertions, 117 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 552af278c6a3..c8e16dde6637 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME?= xmms2
-PORTVERSION= 0.2.d.8
-PORTREVISION= 1
-DISTVERSION= 0.2DrHouse
+PORTVERSION= 0.2.d.9
+DISTVERSION= 0.2DrJekyll
CATEGORIES?= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,8 +22,7 @@ LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
.endif
USE_BZIP2= yes
-USE_SCONS= yes
-SCONS_ARGS= INSTALLDIR=${DESTDIR} SHAREDIR=${DATADIR} EXCLUDE="${EXCLUDE}"
+USE_PYTHON_BUILD= yes
.if !defined(XMMS2_SLAVE)
USE_GNOME= glib20
@@ -34,7 +32,7 @@ USE_LDCONFIG= yes
.endif
.if !defined(XMMS2_SLAVE)
-MAN1= xmms2.1 xmms2-et.1 xmms2d.1 xmms2-launcher.1 xmms2-mdns-avahi.1
+MAN1= xmms2.1 xmms2-et.1 xmms2d.1 xmms2-launcher.1
MANCOMPRESSED= yes
OPTIONS= FAAD "Support to playback AAC files" on \
@@ -42,7 +40,7 @@ OPTIONS= FAAD "Support to playback AAC files" on \
MODPLUG "Support to playback MOD files" off \
MUSEPACK "Support to playback MPC files" off \
SID "Support to playback SID files" off \
- WMA "Support to playback WMA files" off \
+ AVCODEC "Support to playback files with avcodec/avformat" off \
APE "Support to playback Monkey's Audio files" off \
CURL "Support to playback files via HTTP" on \
LASTFM "Support to playback audio via Last.fm radio" on \
@@ -50,6 +48,8 @@ OPTIONS= FAAD "Support to playback AAC files" on \
MMS "Support to playback streams via MMS" off \
SAMBA "Support to playback files via SMB" off \
DAAP "Support to playback files via DAAP" on \
+ OFA "Support to collect MusicDNS fingerprints" off \
+ XML "Support for XML based playlists (XSPF, RSS)" off \
FAM "Support to update Media Library on file change" off \
MDNS_AVAHI "Support to announce XMMS2d via mDNS (Avahi)" off \
MDNS_APPLE "Support to announce XMMS2d via mDNS (Apple)" on \
@@ -62,26 +62,33 @@ OPTIONS= FAAD "Support to playback AAC files" on \
.include <bsd.port.pre.mk>
+.if defined(XMMS2_SLAVE)
+EXCLUDE+= --without-xmms2d=1
+EXTRA_PATCHES= ${PATCHDIR}/slaveport-wscript ${PATCHDIR}/slaveport-src_include_wscript
+.endif
+
.if defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} == "python"
-EXCLUDE+= ruby java xmmsclient-ecore xmmsclient++ xmmsclient++-glib
+EXCLUDE+= --with-optionals="python"
.elif defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} == "ruby"
-EXCLUDE+= python java xmmsclient-ecore xmmsclient++ xmmsclient++-glib
+EXCLUDE+= --with-optionals="ruby"
+.elif defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} == "perl"
+EXCLUDE+= --with-optionals="perl"
.elif defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} == "ruby-ecore"
-EXCLUDE+= python java xmmsclient++ xmmsclient++-glib
-.elif defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} == "java"
-EXCLUDE+= ruby python xmmsclient-ecore xmmsclient++ xmmsclient++-glib
+EXCLUDE+= --with-optionals="ruby" --with-optionals="xmmsclient-ecore"
.elif defined(XMMS2_SLAVE) && ${XMMS2_SLAVE} == "cpp"
-EXCLUDE+= ruby python java xmmsclient-ecore
+EXCLUDE+= --with-optionals="xmmsclient++" --with-optionals="xmmsclient++-glib"
.elif !defined(XMMS2_SLAVE)
-EXCLUDE+= python ruby java xmmsclient-ecore xmmsclient++ xmmsclient++-glib
+EXCLUDE+= --without-optionals="python" --without-optionals="ruby" --without-optionals="xmmsclient-ecore" --without-optionals="xmmsclient++" --without-optionals="xmmsclient++-glib" --without-optionals="perl"
.endif
.if !defined(XMMS2_SLAVE)
+
+EXCLUDE+= --without-plugins="cdda"
.if !defined(WITHOUT_CURL)
LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
PLIST_SUB+= CURL=""
.else
-EXCLUDE+= curl
+EXCLUDE+= --without-plugins="curl" --without-plugins="icymetaint"
PLIST_SUB+= CURL="@comment "
.endif
@@ -91,7 +98,7 @@ LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
.endif
PLIST_SUB+= LASTFM=""
.else
-EXCLUDE+= lastfm lastfmeta
+EXCLUDE+= --without-plugins="lastfm" --without-plugins="lastfmeta"
PLIST_SUB+= LASTFM="@comment "
.endif
@@ -99,7 +106,7 @@ PLIST_SUB+= LASTFM="@comment "
LIB_DEPENDS+= sidplay2.[0-9]:${PORTSDIR}/audio/libsidplay2
PLIST_SUB+= SID=""
.else
-EXCLUDE+= sid
+EXCLUDE+= --without-plugins="sid"
PLIST_SUB+= SID="@comment "
.endif
@@ -107,7 +114,7 @@ PLIST_SUB+= SID="@comment "
LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
PLIST_SUB+= FLAC=""
.else
-EXCLUDE+= flac
+EXCLUDE+= --without-plugins="flac"
PLIST_SUB+= FLAC="@comment "
.endif
@@ -115,15 +122,15 @@ PLIST_SUB+= FLAC="@comment "
LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
PLIST_SUB+= FAAD=""
.else
-EXCLUDE+= faad
+EXCLUDE+= --without-plugins="faad" --without-plugins="mp4"
PLIST_SUB+= FAAD="@comment "
.endif
-.if defined(WITH_WMA)
+.if defined(WITH_AVCODEC)
LIB_DEPENDS+= avutil.1:${PORTSDIR}/multimedia/ffmpeg
PLIST_SUB+= WMA=""
.else
-EXCLUDE+= wma
+EXCLUDE+= --without-plugins="avcodec" --without-plugins="avformat"
PLIST_SUB+= WMA="@comment "
.endif
@@ -131,7 +138,7 @@ PLIST_SUB+= WMA="@comment "
LIB_DEPENDS+= mac.2:${PORTSDIR}/audio/mac
PLIST_SUB+= MAC=""
.else
-EXCLUDE+= mac
+EXCLUDE+= --without-plugins="mac"
PLIST_SUB+= MAC="@comment "
.endif
@@ -141,7 +148,6 @@ USE_SDL= sdl ttf
PLIST_SUB+= SDL=""
#EXTRA_PATCHES+= ${FILESDIR}/extraPatch-src::clients::sdl-vis::Program
.else
-EXCLUDE+= sdl-vis
PLIST_SUB+= SDL="@comment "
.endif
@@ -149,16 +155,15 @@ PLIST_SUB+= SDL="@comment "
LIB_DEPENDS+= mpcdec.5:${PORTSDIR}/audio/libmpcdec
PLIST_SUB+= MUSEPACK=""
.else
-EXCLUDE+= musepack
+EXCLUDE+= --without-plugins="musepack"
PLIST_SUB+= MUSEPACK="@comment "
.endif
.if defined(WITH_JACK)
-IGNORE= the Jack plugin has not been updated to the Transforms API
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
PLIST_SUB+= JACK=""
.else
-EXCLUDE+= jack
+EXCLUDE+= --without-plugins="jack"
PLIST_SUB+= JACK="@comment "
.endif
@@ -166,22 +171,38 @@ PLIST_SUB+= JACK="@comment "
LIB_DEPENDS+= modplug.0:${PORTSDIR}/audio/libmodplug
PLIST_SUB+= MODPLUG=""
.else
-EXCLUDE+= modplug
+EXCLUDE+= --without-plugins="modplug"
PLIST_SUB+= MODPLUG="@comment "
.endif
+.if defined(WITH_OFA)
+LIB_DEPENDS+= ofa.0:${PORTSDIR}/audio/libofa
+PLIST_SUB+= OFA=""
+.else
+EXCLUDE+= --without-plugins="ofa"
+PLIST_SUB+= OFA="@comment "
+.endif
+
+.if defined(WITH_XML)
+USE_GNOME= xml2
+PLIST_SUB+= XML=""
+.else
+EXCLUDE+= --without-plugins="xml" --without-plugins="rss" --without-plugins="xspf"
+PLIST_SUB+= XML="@comment "
+.endif
+
.if defined(WITH_SAMBA)
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
PLIST_SUB+= SAMBA=""
.else
-EXCLUDE+= samba
+EXCLUDE+= --without-plugins="samba"
PLIST_SUB+= SAMBA="@comment "
.endif
.if !defined(WITHOUT_DAAP)
PLIST_SUB+= DAAP=""
.else
-EXCLUDE+= daap
+EXCLUDE+= --without-plugins="daap"
PLIST_SUB+= DAAP="@comment "
.endif
@@ -189,7 +210,7 @@ PLIST_SUB+= DAAP="@comment "
USE_GNOME+= gnomevfs2
PLIST_SUB+= GNOMEVFS=""
.else
-EXCLUDE+= gnomevfs
+EXCLUDE+= --without-plugins="gnomevfs"
PLIST_SUB+= GNOMEVFS="@comment "
.endif
@@ -197,7 +218,7 @@ PLIST_SUB+= GNOMEVFS="@comment "
LIB_DEPENDS+= mms.0:${PORTSDIR}/net/libmms
PLIST_SUB+= MMS=""
.else
-EXCLUDE+= mms
+EXCLUDE+= --without-plugins="mms"
PLIST_SUB+= MMS="@comment "
.endif
@@ -206,7 +227,7 @@ USE_FAM= yes
WANT_FAM_SYSTEM=gamin
PLIST_SUB+= FAM=""
.else
-EXCLUDE+= medialib-updater
+EXCLUDE+= --without-optionals="medialib-updater"
PLIST_SUB+= FAM="@comment "
.endif
@@ -214,7 +235,7 @@ PLIST_SUB+= FAM="@comment "
LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
PLIST_SUB+= ICES=""
.else
-EXCLUDE+= ices
+EXCLUDE+= --without-plugins="ices"
PLIST_SUB+= ICES="@comment "
.endif
@@ -222,7 +243,7 @@ PLIST_SUB+= ICES="@comment "
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
PLIST_SUB+= AO=""
.else
-EXCLUDE+= ao
+EXCLUDE+= --without-plugins="ao"
PLIST_SUB+= AO="@comment "
.endif
@@ -230,11 +251,12 @@ PLIST_SUB+= AO="@comment "
.if !defined(WITHOUT_MDNS_APPLE)
BROKEN= You may choose either MDNS_APPLE or MDNS_AVAHI, but not both
.endif
-EXCLUDE+= dnssd dns_sd
+EXCLUDE+= --without-optionals="dnssd"
LIB_DEPENDS+= avahi-core:${PORTSDIR}/net/avahi
PLIST_SUB+= MDNS_AVAHI=""
+MAN1+= xmms2-mdns-avahi.1
.else
-EXCLUDE+= avahi
+EXCLUDE+= --without-optionals="avahi"
PLIST_SUB+= MDNS_AVAHI="@comment "
.endif
@@ -242,22 +264,31 @@ PLIST_SUB+= MDNS_AVAHI="@comment "
.if defined(WITH_MDNS_AVAHI)
BROKEN= You may choose either MDNS_APPLE or MDNS_AVAHI, but not both
.endif
-EXCLUDE+= avahi
+EXCLUDE+= --without-optionals="avahi"
LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/mDNSResponder
PLIST_SUB+= MDNS_APPLE=""
.else
-EXCLUDE+= dnssd dns_sd
+EXCLUDE+= --without-optionals="dnssd"
PLIST_SUB+= MDNS_APPLE="@comment "
.endif
-.endif
.if defined(WITH_VOCODER)
LIB_DEPENDS+= fftw3f.4:${PORTSDIR}/math/fftw3-float
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
PLIST_SUB+= VOCODER=""
.else
-EXCLUDE+= vocoder
+EXCLUDE+= --without-plugins="vocoder"
PLIST_SUB+= VOCODER="@comment "
.endif
+.endif
+
+do-configure:
+ cd ${WRKSRC} && ./waf configure --conf-prefix=${LOCALBASE} --prefix=${PREFIX} --with-mandir=${PREFIX}/man ${EXCLUDE}
+
+do-build:
+ cd ${WRKSRC} && ./waf build
+
+do-install:
+ cd ${WRKSRC} && ./waf install
.include <bsd.port.post.mk>
diff --git a/audio/xmms2/distinfo b/audio/xmms2/distinfo
index 5233ad3ff1de..d30090122fb7 100644
--- a/audio/xmms2/distinfo
+++ b/audio/xmms2/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmms2-0.2DrHouse.tar.bz2) = 8f7293b21bd6cb28e7705559a9deab10
-SHA256 (xmms2-0.2DrHouse.tar.bz2) = b87191f137c8a53e85ef502fadc648958848d5229f0b4b6b899e4d1655363c26
-SIZE (xmms2-0.2DrHouse.tar.bz2) = 1059473
+MD5 (xmms2-0.2DrJekyll.tar.bz2) = 768de76a98b6a9766cec157ff0a12543
+SHA256 (xmms2-0.2DrJekyll.tar.bz2) = 7d46baaeaac50d3f4e6db2d492de4ba8fa4fbaed6d42816df5b57d9116a50ff4
+SIZE (xmms2-0.2DrJekyll.tar.bz2) = 1207014
diff --git a/audio/xmms2/files/patch-src_clients_sdl-vis_Program b/audio/xmms2/files/patch-src_clients_sdl-vis_Program
deleted file mode 100644
index 2c4b3b177a2d..000000000000
--- a/audio/xmms2/files/patch-src_clients_sdl-vis_Program
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/clients/sdl-vis/Program.orig Sun Dec 18 08:35:27 2005
-+++ src/clients/sdl-vis/Program Sun Dec 18 14:36:51 2005
-@@ -7,5 +7,5 @@
- env.Prepend(LIBPATH="src/clients/lib/xmmsclient-glib")
- env.Append(LIBS=["xmmsclient-glib"])
- env.pkgconfig("glib-2.0")
-- env.configcmd("sdl-config --libs --cflags")
-- env.checklib("SDL_ttf", "TTF_Init")
-+ env.configcmd("sdl11-config --libs --cflags")
-+ env.Append(LIBS=["SDL_ttf"])
diff --git a/audio/xmms2/files/patch-src_include_xmms_wscript b/audio/xmms2/files/patch-src_include_xmms_wscript
new file mode 100644
index 000000000000..3588ba5ca8ae
--- /dev/null
+++ b/audio/xmms2/files/patch-src_include_xmms_wscript
@@ -0,0 +1,11 @@
+--- src/include/xmms/wscript.orig Fri May 25 16:49:48 2007
++++ src/include/xmms/wscript Fri May 25 16:50:17 2007
+@@ -45,7 +45,7 @@
+
+ conf.env['XMMS_DEFS'] = defs
+ conf.env['PLUGINDIR'] = defs['PKGLIBDIR']
+- conf.env['PKGCONFIGDIR'] = os.path.join(conf.env["PREFIX"], "lib", "pkgconfig")
++ conf.env['PKGCONFIGDIR'] = os.path.join(conf.env["PREFIX"], "libdata", "pkgconfig")
+
+ for i in defs:
+ conf.add_define(i, defs[i])
diff --git a/audio/xmms2/files/patch-src_plugins_faad_Plugin b/audio/xmms2/files/patch-src_plugins_faad_Plugin
deleted file mode 100644
index 8c20d2479bec..000000000000
--- a/audio/xmms2/files/patch-src_plugins_faad_Plugin
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/plugins/faad/Plugin.orig Tue Sep 26 20:35:50 2006
-+++ src/plugins/faad/Plugin Tue Sep 26 20:36:04 2006
-@@ -2,13 +2,7 @@
- source=['faad.c', 'mp4ff/drms.c', 'mp4ff/mp4atom.c', 'mp4ff/mp4ff.c', 'mp4ff/mp4meta.c', 'mp4ff/mp4sample.c', 'mp4ff/mp4tagupdate.c', 'mp4ff/mp4util.c']
-
- def config(env):
-- try:
-- env.checklib("faad", "faacDecInit2")
-- except ConfigError:
-- env.checklib("faad", "NeAACDecInit2")
-- except ConfigError:
-- raise ConfigError("Could not find libfaad")
--
-+ env.Append(LIBS=['faad'])
- env.Append(CPPDEFINES=['USE_TAGGING'])
-
- # to use iTunes DRM change this to true
diff --git a/audio/xmms2/files/patch-src_plugins_faad_mp4ff_mp4ff_int_types.h b/audio/xmms2/files/patch-src_plugins_faad_mp4ff_mp4ff_int_types.h
deleted file mode 100644
index 309a124bfd6b..000000000000
--- a/audio/xmms2/files/patch-src_plugins_faad_mp4ff_mp4ff_int_types.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/plugins/faad/mp4ff/mp4ff_int_types.h.orig Fri Jul 7 03:00:50 2006
-+++ src/plugins/faad/mp4ff/mp4ff_int_types.h Fri Jul 7 03:01:16 2006
-@@ -15,7 +15,7 @@
-
- #else
-
--#include <stdint.h>
-+#include <inttypes.h>
-
- #endif
-
diff --git a/audio/xmms2/files/patch-src_plugins_sid_Plugin b/audio/xmms2/files/patch-src_plugins_sid_Plugin
deleted file mode 100644
index db9c4004e45a..000000000000
--- a/audio/xmms2/files/patch-src_plugins_sid_Plugin
+++ /dev/null
@@ -1,9 +0,0 @@
---- src/plugins/sid/Plugin.orig Thu Jul 6 22:25:16 2006
-+++ src/plugins/sid/Plugin Thu Jul 6 22:27:29 2006
-@@ -6,4 +6,5 @@
- builder_path = env.run("pkg-config libsidplay2 --variable=builders").strip()
- if builder_path:
- env.Append(LIBPATH=["-L%s" % builder_path])
-- env.checklib("resid-builder", "resid_version_string")
-+ env.Append(LINKFLAGS=['-rpath=%s' % builder_path])
-+ env.Append(LIBS=["resid-builder"])
diff --git a/audio/xmms2/files/patch-src_xmms_Program b/audio/xmms2/files/patch-src_xmms_Program
deleted file mode 100644
index ce954718f6ff..000000000000
--- a/audio/xmms2/files/patch-src_xmms_Program
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/xmms/Program.orig Sat Dec 2 15:01:08 2006
-+++ src/xmms/Program Sat Dec 2 19:53:19 2006
-@@ -27,10 +27,10 @@
-
- def config(env):
- pluginenv = env.Copy()
-- env.pkgconfig("glib-2.0 >= 2.6.0", fail=True)
-- env.pkgconfig("gmodule-2.0", fail=True)
-- env.pkgconfig("gthread-2.0", fail=True)
-- env.pkgconfig("sqlite3", fail=True)
-+ env.pkgconfig("glib-2.0 >= 2.6.0")
-+ env.pkgconfig("gmodule-2.0")
-+ env.pkgconfig("gthread-2.0")
-+ env.pkgconfig("sqlite3")
- env.Prepend(LIBPATH=["src/lib/xmmsutils"])
- env.Prepend(LIBPATH=["src/lib/xmmsipc"])
- env.Prepend(LIBPATH=["src/lib/xmmssocket"])
diff --git a/audio/xmms2/files/slaveport-src_include_wscript b/audio/xmms2/files/slaveport-src_include_wscript
new file mode 100644
index 000000000000..f26fc665ff3f
--- /dev/null
+++ b/audio/xmms2/files/slaveport-src_include_wscript
@@ -0,0 +1,11 @@
+--- src/include/wscript.orig Fri May 25 16:27:44 2007
++++ src/include/wscript Fri May 25 16:27:51 2007
+@@ -5,8 +5,6 @@
+ paths = ['xmms', 'xmmsc', 'xmmsclient', 'xmmsclient/xmmsclient++']
+ for p in paths:
+ bld.add_subdirs(p)
+- f = [os.path.join(p, a) for a in os.listdir(os.path.join('src','include',p)) if a.endswith('.h')]
+- Common.install_files('PREFIX', os.path.join('include', 'xmms2', p), " ".join(f))
+
+ def configure(conf):
+ conf.sub_config("xmms")
diff --git a/audio/xmms2/files/slaveport-wscript b/audio/xmms2/files/slaveport-wscript
new file mode 100644
index 000000000000..38ee21ff7e29
--- /dev/null
+++ b/audio/xmms2/files/slaveport-wscript
@@ -0,0 +1,11 @@
+--- wscript.orig Fri May 25 16:27:23 2007
++++ wscript Fri May 25 16:27:28 2007
+@@ -41,8 +41,6 @@
+ src/lib/xmmssocket
+ src/lib/xmmsipc
+ src/lib/xmmsutils
+- src/clients/lib/xmmsclient
+- src/clients/lib/xmmsclient-glib
+ src/include
+ src/includepriv
+ """.split()
diff --git a/audio/xmms2/pkg-plist b/audio/xmms2/pkg-plist
index 73060e12259a..8f957d28234d 100644
--- a/audio/xmms2/pkg-plist
+++ b/audio/xmms2/pkg-plist
@@ -8,7 +8,6 @@ bin/xmms2-launcher
bin/xmms2d
include/xmms2/xmms/xmms_bindata.h
include/xmms2/xmms/xmms_config.h
-include/xmms2/xmms/xmms_defs.h
include/xmms2/xmms/xmms_effect.h
include/xmms2/xmms/xmms_effectplugin.h
include/xmms2/xmms/xmms_error.h
@@ -17,13 +16,13 @@ include/xmms2/xmms/xmms_log.h
include/xmms2/xmms/xmms_medialib.h
include/xmms2/xmms/xmms_object.h
include/xmms2/xmms/xmms_outputplugin.h
-include/xmms2/xmms/xmms_plsplugins.h
include/xmms2/xmms/xmms_plugin.h
include/xmms2/xmms/xmms_sample.h
include/xmms2/xmms/xmms_streamtype.h
include/xmms2/xmms/xmms_strfunc.h
+include/xmms2/xmms/xmms_util.h
include/xmms2/xmms/xmms_xformplugin.h
-include/xmms2/xmmsc/xmmsc_asyncns.h
+include/xmms2/xmmsc/xmmsc_coll.h
include/xmms2/xmmsc/xmmsc_errorcodes.h
include/xmms2/xmmsc/xmmsc_idnumbers.h
include/xmms2/xmmsc/xmmsc_inline.h
@@ -39,6 +38,8 @@ include/xmms2/xmmsc/xmmsc_util.h
include/xmms2/xmmsclient/xmmsclient++/bindata.h
include/xmms2/xmmsclient/xmmsclient++/client.h
include/xmms2/xmmsclient/xmmsclient++/config.h
+include/xmms2/xmmsclient/xmmsclient++/coll.h
+include/xmms2/xmmsclient/xmmsclient++/collection.h
include/xmms2/xmmsclient/xmmsclient++/dict.h
include/xmms2/xmmsclient/xmmsclient++/exceptions.h
include/xmms2/xmmsclient/xmmsclient++/helpers.h
@@ -48,6 +49,7 @@ include/xmms2/xmmsclient/xmmsclient++/mainloop.h
include/xmms2/xmmsclient/xmmsclient++/medialib.h
include/xmms2/xmmsclient/xmmsclient++/playback.h
include/xmms2/xmmsclient/xmmsclient++/playlist.h
+include/xmms2/xmmsclient/xmmsclient++/result.h
include/xmms2/xmmsclient/xmmsclient++/signal.h
include/xmms2/xmmsclient/xmmsclient++/stats.h
include/xmms2/xmmsclient/xmmsclient++/typedefs.h
@@ -59,12 +61,16 @@ include/xmms2/xmmsclient/xmmsclient-ecore.h
include/xmms2/xmmsclient/xmmsclient-glib.h
include/xmms2/xmmsclient/xmmsclient-qt.h
include/xmms2/xmmsclient/xmmsclient.h
-lib/libxmmsclient-glib.a
lib/libxmmsclient-glib.so
-lib/libxmmsclient.a
+lib/libxmmsclient-glib.so.1
+lib/libxmmsclient-glib.so.1.0.0
lib/libxmmsclient.so
+lib/libxmmsclient.so.2
+lib/libxmmsclient.so.2.0.0
%%AO%%lib/xmms2/libxmms_ao.so
-%%CURL%%lib/xmms2/libxmms_curl_http.so
+lib/xmms2/libxmms_asx.so
+lib/xmms2/libxmms_cue.so
+%%CURL%%lib/xmms2/libxmms_curl.so
lib/xmms2/libxmms_diskwrite.so
lib/xmms2/libxmms_equalizer.so
%%DAAP%%lib/xmms2/libxmms_daap.so
@@ -78,24 +84,24 @@ lib/xmms2/libxmms_file.so
lib/xmms2/libxmms_icymetaint.so
lib/xmms2/libxmms_id3v2.so
%%JACK%%lib/xmms2/libxmms_jack.so
+lib/xmms2/libxmms_m3u.so
lib/xmms2/libxmms_mad.so
%%MAC%%lib/xmms2/libxmms_mac.so
%%MMS%%lib/xmms2/libxmms_mms.so
%%MODPLUG%%lib/xmms2/libxmms_modplug.so
+%%FAAD%%lib/xmms2/libxmms_mp4.so
%%MUSEPACK%%lib/xmms2/libxmms_musepack.so
lib/xmms2/libxmms_null.so
lib/xmms2/libxmms_nulstripper.so
lib/xmms2/libxmms_oss.so
+lib/xmms2/libxmms_pls.so
lib/xmms2/libxmms_replaygain.so
%%SAMBA%%lib/xmms2/libxmms_samba.so
%%SID%%lib/xmms2/libxmms_sid.so
%%VOCODER%%lib/xmms2/libxmms_vocoder.so
-lib/xmms2/libxmms_vorbisfile.so
+lib/xmms2/libxmms_vorbis.so
lib/xmms2/libxmms_wave.so
%%WMA%%lib/xmms2/libxmms_wma.so
-libdata/pkgconfig/xmms2-client-cpp.pc
-libdata/pkgconfig/xmms2-client-cpp-glib.pc
-libdata/pkgconfig/xmms2-client-ecore.pc
libdata/pkgconfig/xmms2-client-glib.pc
libdata/pkgconfig/xmms2-client.pc
libdata/pkgconfig/xmms2-plugin.pc