aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-24 23:38:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-24 23:38:28 +0000
commit978257688077164e975a097e816f4e1491fc3a9f (patch)
treea39d9e34bbca45d1a4b0af28fa811751878b46ba /audio/xmms2
parent9992960752387703d799e84dd822eeb1b61bee99 (diff)
downloadports-978257688077164e975a097e816f4e1491fc3a9f.tar.gz
ports-978257688077164e975a097e816f4e1491fc3a9f.zip
Notes
Diffstat (limited to 'audio/xmms2')
-rw-r--r--audio/xmms2/Makefile27
-rw-r--r--audio/xmms2/distinfo5
-rw-r--r--audio/xmms2/files/patch-src-plugins-airplay-wscript10
-rw-r--r--audio/xmms2/files/patch-wscript19
-rw-r--r--audio/xmms2/pkg-plist9
5 files changed, 46 insertions, 24 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 3ebf29b22557..d405a1a235c2 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME?= xmms2
-PORTVERSION= 0.6
-PORTREVISION= 8
-DISTVERSIONSUFFIX=DrMattDestruction
+PORTVERSION= 0.7
+DISTVERSIONSUFFIX=DrNo
CATEGORIES?= audio
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20DrMattDestruction
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20${DISTVERSIONSUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT?= Rewrite of xmms as a client/server system (developer release)
@@ -37,6 +36,7 @@ OPTIONS= AIRPLAY "Support output via Airport Express" off \
FAAD "Support to playback AAC files" on \
FAM "Support to update Media Library on file change" off \
FLAC "Support to playback FLAC files" on \
+ GME "Support to playback video game music files" off \
GVFS "Support to playback files via GVFS" off \
ICES "Support to playback files to an icecast server" off \
JACK "Support to output via the Jack output server" off \
@@ -52,6 +52,7 @@ OPTIONS= AIRPLAY "Support output via Airport Express" off \
SAMBA "Support to playback files via SMB" off \
SID "Support to playback SID files" off \
SPEEX "Support to playback SPEEX files" off \
+ TREMOR "Support to playback OGG files" off \
VISUAL "Support for visualization plugins" off \
VOCODER "Phase Vocoder effect plugin" off \
VORBIS "Support to playback OGG files" on \
@@ -162,6 +163,14 @@ EXCLUDE+= --without-plugins="flac"
PLIST_SUB+= FLAC="@comment "
.endif
+.if !defined(WITHOUT_GME)
+LIB_DEPENDS+= gme.0:${PORTSDIR}/audio/libgme
+PLIST_SUB+= GME=""
+.else
+EXCLUDE+= --without-plugins="gme"
+PLIST_SUB+= GME="@comment "
+.endif
+
.if !defined(WITHOUT_GVFS)
USE_GNOME+= gvfs
PLIST_SUB+= GVFS=""
@@ -289,6 +298,14 @@ EXCLUDE+= --without-plugins="speex"
PLIST_SUB+= SPEEX="@comment "
.endif
+.if !defined(WITHOUT_TREMOR)
+LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
+PLIST_SUB+= TREMOR=""
+.else
+EXCLUDE+= --without-plugins="tremor"
+PLIST_SUB+= TREMOR="@comment "
+.endif
+
# xmms2-ripper
.if !defined(WITHOUT_VISUAL) && !defined(WITHOUT_VORBIS)
LIB_DEPENDS+= vorbisenc.2:${PORTSDIR}/audio/libvorbis
@@ -344,7 +361,7 @@ PLIST_SUB+= XML="@comment "
do-configure:
cd ${WRKSRC} && ./waf configure --conf-prefix=${LOCALBASE} \
- --prefix=${PREFIX} --with-mandir=${PREFIX}/man ${EXCLUDE}
+ --prefix=${PREFIX} --mandir=${PREFIX}/man ${EXCLUDE}
do-build:
cd ${WRKSRC} && ./waf build
diff --git a/audio/xmms2/distinfo b/audio/xmms2/distinfo
index 1c713b14a195..80536b0417f8 100644
--- a/audio/xmms2/distinfo
+++ b/audio/xmms2/distinfo
@@ -1,3 +1,2 @@
-MD5 (xmms2-0.6DrMattDestruction.tar.bz2) = 954fb9c76b5db5e324a105e81b273200
-SHA256 (xmms2-0.6DrMattDestruction.tar.bz2) = 4fb4f469816d8a1a676f6660e370b0c73a07e3d7e59d07f57a43b67216291db8
-SIZE (xmms2-0.6DrMattDestruction.tar.bz2) = 1631304
+SHA256 (xmms2-0.7DrNo.tar.bz2) = 59c58d9380e6b002920a8dc75f0fd4629ab175b82f29b6637f7816fdc9832b2c
+SIZE (xmms2-0.7DrNo.tar.bz2) = 1519973
diff --git a/audio/xmms2/files/patch-src-plugins-airplay-wscript b/audio/xmms2/files/patch-src-plugins-airplay-wscript
index c7589b83ff23..9a06e08da61c 100644
--- a/audio/xmms2/files/patch-src-plugins-airplay-wscript
+++ b/audio/xmms2/files/patch-src-plugins-airplay-wscript
@@ -1,9 +1,13 @@
---- src/plugins/airplay/wscript~
-+++ src/plugins/airplay/wscript
-@@ -1,11 +1,6 @@
+--- src/plugins/airplay/wscript.orig 2010-02-19 18:43:54.000000000 +0100
++++ src/plugins/airplay/wscript 2010-03-17 15:14:34.459359323 +0100
+@@ -1,15 +1,6 @@
from waftools.plugin import plugin
-def plugin_configure(conf):
+- # MinGW doesn't ship sys/select.h
+- if not conf.check_cc(header_name='sys/select.h'):
+- return False
+-
- if not conf.check_cfg(package="openssl", args="--cflags --libs", uselib_store="openssl"):
- return False
- return True
diff --git a/audio/xmms2/files/patch-wscript b/audio/xmms2/files/patch-wscript
index c28784b2bb66..e953ae0ee506 100644
--- a/audio/xmms2/files/patch-wscript
+++ b/audio/xmms2/files/patch-wscript
@@ -1,24 +1,27 @@
---- wscript~
-+++ wscript
-@@ -297,7 +297,7 @@ def configure(conf):
+--- wscript.orig 2010-02-19 18:43:54.000000000 +0100
++++ wscript 2010-03-17 15:21:16.184861151 +0100
+@@ -303,7 +303,7 @@
conf.env['PKGCONFIGDIR'] = Options.options.pkgconfigdir
print(conf.env['PKGCONFIGDIR'])
else:
-- conf.env['PKGCONFIGDIR'] = os.path.join(conf.env["PREFIX"], "lib", "pkgconfig")
+- conf.env['PKGCONFIGDIR'] = os.path.join(conf.env["LIBDIR"], "pkgconfig")
+ conf.env['PKGCONFIGDIR'] = os.path.join(conf.env["PREFIX"], "libdata", "pkgconfig")
if Options.options.config_prefix:
for dir in Options.options.config_prefix:
-@@ -476,12 +476,5 @@ def set_options(opt):
+@@ -480,15 +480,6 @@
opt.sub_options(o)
def shutdown():
-- if Options.commands['install'] and os.geteuid() == 0:
+- if Options.commands['install'] and (
+- Options.options.ldconfig or
+- (Options.options.ldconfig is None and os.geteuid() == 0)
+- ):
- ldconfig = '/sbin/ldconfig'
- if os.path.isfile(ldconfig):
- libprefix = Utils.subst_vars('${PREFIX}/lib', Build.bld.env)
- try: Utils.cmd_output(ldconfig + ' ' + libprefix)
- except: pass
--
+
if Options.options.run_tests:
- os.system(os.path.join(os.getenv('WAF_HOME'), "default/tests/test_xmmstypes"))
+ os.system(os.path.join(blddir, "default/tests/test_xmmstypes"))
diff --git a/audio/xmms2/pkg-plist b/audio/xmms2/pkg-plist
index ab36d7649723..148eeb6d8076 100644
--- a/audio/xmms2/pkg-plist
+++ b/audio/xmms2/pkg-plist
@@ -22,7 +22,6 @@ bin/xmms2d
%%INCLUDEDIR%%/xmms/xmms_plugin.h
%%INCLUDEDIR%%/xmms/xmms_sample.h
%%INCLUDEDIR%%/xmms/xmms_streamtype.h
-%%INCLUDEDIR%%/xmms/xmms_strfunc.h
%%INCLUDEDIR%%/xmms/xmms_util.h
%%INCLUDEDIR%%/xmms/xmms_xformplugin.h
%%INCLUDEDIR%%/xmmsc/xmmsc_compiler.h
@@ -70,15 +69,14 @@ lib/libxmmsclient-glib.so
lib/libxmmsclient-glib.so.1
lib/libxmmsclient-glib.so.1.0.0
lib/libxmmsclient.so
-lib/libxmmsclient.so.5
-lib/libxmmsclient.so.5.0.0
+lib/libxmmsclient.so.6
+lib/libxmmsclient.so.6.0.0
%%AIRPLAY%%%%LIBDIR%%/libxmms_airplay.so
%%AO%%%%LIBDIR%%/libxmms_ao.so
%%LIBDIR%%/libxmms_apefile.so
%%LIBDIR%%/libxmms_asf.so
%%LIBDIR%%/libxmms_asx.so
%%AVCODEC%%%%LIBDIR%%/libxmms_avcodec.so
-%%AVCODEC%%%%LIBDIR%%/libxmms_avformat.so
%%CDDA%%%%LIBDIR%%/libxmms_cdda.so
%%LIBDIR%%/libxmms_cue.so
%%CURL%%%%LIBDIR%%/libxmms_curl.so
@@ -89,7 +87,7 @@ lib/libxmmsclient.so.5.0.0
%%LIBDIR%%/libxmms_file.so
%%FLAC%%%%LIBDIR%%/libxmms_flac.so
%%LIBDIR%%/libxmms_flv.so
-%%LIBDIR%%/libxmms_gme.so
+%%GME%%%%LIBDIR%%/libxmms_gme.so
%%GVFS%%%%LIBDIR%%/libxmms_gvfs.so
%%LIBDIR%%/libxmms_html.so
%%ICES%%%%LIBDIR%%/libxmms_ices.so
@@ -117,6 +115,7 @@ lib/libxmmsclient.so.5.0.0
%%SAMBA%%%%LIBDIR%%/libxmms_samba.so
%%SID%%%%LIBDIR%%/libxmms_sid.so
%%SPEEX%%%%LIBDIR%%/libxmms_speex.so
+%%TREMOR%%%%LIBDIR%%/libxmms_tremor.so
%%LIBDIR%%/libxmms_tta.so
%%VOCODER%%%%LIBDIR%%/libxmms_vocoder.so
%%VORBIS%%%%LIBDIR%%/libxmms_vorbis.so