aboutsummaryrefslogtreecommitdiff
path: root/audio/xmmsctrl
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2013-10-31 23:33:13 +0000
committerJason E. Hale <jhale@FreeBSD.org>2013-10-31 23:33:13 +0000
commite5f33c73dee0da1027e5791473f07ba5e8a08ef5 (patch)
treec7ad9bb8b544067bf4f03342ffcc13374435e825 /audio/xmmsctrl
parent983682fc726003b6498b68292e954cb6abbc8dfb (diff)
Notes
Diffstat (limited to 'audio/xmmsctrl')
-rw-r--r--audio/xmmsctrl/Makefile18
-rw-r--r--audio/xmmsctrl/pkg-plist24
2 files changed, 20 insertions, 22 deletions
diff --git a/audio/xmmsctrl/Makefile b/audio/xmmsctrl/Makefile
index 7d46fdbc59e3..55d4b4f68333 100644
--- a/audio/xmmsctrl/Makefile
+++ b/audio/xmmsctrl/Makefile
@@ -18,24 +18,22 @@ BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
USES= gmake
-NO_STAGE= yes
+USE_CSTD= gnu89
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PORTDOCS= Changelog README
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xmmsctrl ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
- ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmmsctrl ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/samples && \
${INSTALL_DATA} emacs-transcriber twmrc_bindings \
- ${EXAMPLESDIR} && \
- ${INSTALL_SCRIPT} *.sh ${EXAMPLESDIR}
+ ${STAGEDIR}${EXAMPLESDIR} && \
+ ${INSTALL_SCRIPT} *.sh ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/audio/xmmsctrl/pkg-plist b/audio/xmmsctrl/pkg-plist
index c5da5a948a43..12535745e362 100644
--- a/audio/xmmsctrl/pkg-plist
+++ b/audio/xmmsctrl/pkg-plist
@@ -1,13 +1,13 @@
bin/xmmsctrl
-%%EXAMPLESDIR%%/emacs-transcriber
-%%EXAMPLESDIR%%/pause_stop_play.sh
-%%EXAMPLESDIR%%/play_pause.sh
-%%EXAMPLESDIR%%/play_unpause_next.sh
-%%EXAMPLESDIR%%/playlist2html.sh
-%%EXAMPLESDIR%%/twmrc_bindings
-%%EXAMPLESDIR%%/win_playlist.sh
-%%EXAMPLESDIR%%/window_shown.sh
-%%EXAMPLESDIR%%/xmmsnext.sh
-%%EXAMPLESDIR%%/xmmsprev.sh
-%%EXAMPLESDIR%%/xmmsswitch.sh
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/emacs-transcriber
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pause_stop_play.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/play_pause.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/play_unpause_next.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/playlist2html.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/twmrc_bindings
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win_playlist.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/window_shown.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xmmsnext.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xmmsprev.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xmmsswitch.sh
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%