aboutsummaryrefslogtreecommitdiff
path: root/audio/xmp/files
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-09-18 20:46:21 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-09-18 20:46:21 +0000
commit9fa8d14cc8e771b6a0796d30dcad44b4ae7292f1 (patch)
tree513e10d5294c9eb37762d26eb17251fc9d567d77 /audio/xmp/files
parentae8e0c16782d71868edd399688a79484302853a3 (diff)
Notes
Diffstat (limited to 'audio/xmp/files')
-rw-r--r--audio/xmp/files/patch-aa20
-rw-r--r--audio/xmp/files/patch-ab19
-rw-r--r--audio/xmp/files/patch-ac21
3 files changed, 60 insertions, 0 deletions
diff --git a/audio/xmp/files/patch-aa b/audio/xmp/files/patch-aa
new file mode 100644
index 000000000000..dec5f80919be
--- /dev/null
+++ b/audio/xmp/files/patch-aa
@@ -0,0 +1,20 @@
+--- src/player/readrc.c.orig Sat Jul 3 17:13:04 1999
++++ src/player/readrc.c Sat Sep 18 13:11:48 1999
+@@ -49,7 +49,7 @@
+
+ if ((rc = fopen (myrc2, "r")) == NULL) {
+ if ((rc = fopen (myrc, "r")) == NULL) {
+- if ((rc = fopen ("/etc/xmp.conf", "r")) == NULL) {
++ if ((rc = fopen ("/usr/local/etc/xmp.conf", "r")) == NULL) {
+ free (myrc);
+ return -1;
+ }
+@@ -191,7 +191,7 @@
+
+ myrc = malloc ((home ? strlen (home) : 0) + 20);
+ sprintf (myrc, "%s/.xmp/modules.conf", home);
+- parse_modconf (ctl, "/etc/xmp-modules.conf", crc, size);
++ parse_modconf (ctl, "/usr/local/etc/xmp-modules.conf", crc, size);
+ parse_modconf (ctl, myrc, crc, size);
+ free (myrc);
+ }
diff --git a/audio/xmp/files/patch-ab b/audio/xmp/files/patch-ab
new file mode 100644
index 000000000000..1b63134be24d
--- /dev/null
+++ b/audio/xmp/files/patch-ab
@@ -0,0 +1,19 @@
+*** etc/Makefile.orig Sat Sep 18 14:29:28 1999
+--- etc/Makefile Sat Sep 18 14:29:39 1999
+***************
+*** 21,27 ****
+ @if [ -f /etc/xmp-modules.conf]; then \
+ mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
+ fi
+! $(INSTALL) -m644 xmp.conf xmp-modules.conf /etc
+
+ xmp.spec: xmp.spec.in ../Makefile.rules
+ cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@
+--- 21,27 ----
+ @if [ -f /etc/xmp-modules.conf]; then \
+ mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
+ fi
+! $(INSTALL) -m644 xmp.conf xmp-modules.conf $(PREFIX)/etc
+
+ xmp.spec: xmp.spec.in ../Makefile.rules
+ cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@
diff --git a/audio/xmp/files/patch-ac b/audio/xmp/files/patch-ac
new file mode 100644
index 000000000000..12789321356e
--- /dev/null
+++ b/audio/xmp/files/patch-ac
@@ -0,0 +1,21 @@
+*** Makefile.orig Sat Sep 18 15:34:54 1999
+--- Makefile Sat Sep 18 15:35:29 1999
+***************
+*** 39,46 ****
+
+ install::
+ @echo
+! @echo " Installation complete. To customize, copy /etc/xmp.conf to"
+! @echo " \$$HOME/.xmp/xmp.conf and /etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
+ @echo
+
+ uninstall:
+--- 39,46 ----
+
+ install::
+ @echo
+! @echo " Installation complete. To customize, copy ${PREFIX}/etc/xmp.conf to"
+! @echo " \$$HOME/.xmp/xmp.conf and ${PREFIX}/etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
+ @echo
+
+ uninstall: