aboutsummaryrefslogtreecommitdiff
path: root/audio/xsynth-dssi/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-28 00:23:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-28 00:23:01 +0000
commitebd06441e9341215e8895aa4978fdc1cc7057fcb (patch)
treedac4297ed086032ab581e1ebc628d18e1ce88051 /audio/xsynth-dssi/Makefile
parent7bdcc8c67263b38f8a4b899ffbd6237faf8accb7 (diff)
downloadports-ebd06441e9341215e8895aa4978fdc1cc7057fcb.tar.gz
ports-ebd06441e9341215e8895aa4978fdc1cc7057fcb.zip
Notes
Diffstat (limited to 'audio/xsynth-dssi/Makefile')
-rw-r--r--audio/xsynth-dssi/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/xsynth-dssi/Makefile b/audio/xsynth-dssi/Makefile
new file mode 100644
index 000000000000..44ebc9ce99db
--- /dev/null
+++ b/audio/xsynth-dssi/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xsynth-dssi
+# Date created: 2007-01-20
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsynth-dssi
+PORTVERSION= 0.9.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dssi
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Classic analog style software synthesizer
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+CFLAGS+= -I${LOCALBASE}/include/dssi
+USE_AUTOTOOLS= libtool:15
+
+.include <bsd.port.mk>