aboutsummaryrefslogtreecommitdiff
path: root/audio/xwave/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-29 15:26:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-29 15:26:46 +0000
commit00f98890b1d5485e93e38da7aed866426b951574 (patch)
treecb2d62161e1e76c5e2d510befafaf9e2e24c7bcd /audio/xwave/Makefile
parent7e66fcf5cb05458f50a14d8a7a2647267cf43304 (diff)
downloadports-00f98890b1d5485e93e38da7aed866426b951574.tar.gz
ports-00f98890b1d5485e93e38da7aed866426b951574.zip
Notes
Diffstat (limited to 'audio/xwave/Makefile')
-rw-r--r--audio/xwave/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/audio/xwave/Makefile b/audio/xwave/Makefile
new file mode 100644
index 000000000000..7dc2b95ab510
--- /dev/null
+++ b/audio/xwave/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: xwave
+# Date created: 2000-06-11
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $NetBSD: Makefile,v 1.8 2000/04/24 14:52:33 hubertf Exp $
+# $FreeBSD$
+#
+
+PORTNAME= xwave
+PORTVERSION= 2
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.vex.net/pub/software/
+DISTNAME= xwave2
+
+MAINTAINER= trevor@jpj.net
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+
+DOC_FILES= README README-XWAVE2 README.v06 COPYING INSTALL
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xwave ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/XWave ${PREFIX}/lib/X11/app-defaults/
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xwave2
+.for i in ${DOC_FILES}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${PREFIX}/share/doc/xwave2
+.endfor
+.endif
+
+.include <bsd.port.mk>