aboutsummaryrefslogtreecommitdiff
path: root/audio/yammi
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2003-10-01 16:17:50 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2003-10-01 16:17:50 +0000
commit56503fc664209df2abe8f4e7dd3ced4adac7a9d3 (patch)
treead5061d08e4b907db092b65d21e2ade187d3a11c /audio/yammi
parenta7271ee6768d1713e895360b074a8342854bad28 (diff)
downloadports-56503fc664209df2abe8f4e7dd3ced4adac7a9d3.tar.gz
ports-56503fc664209df2abe8f4e7dd3ced4adac7a9d3.zip
Notes
Diffstat (limited to 'audio/yammi')
-rw-r--r--audio/yammi/Makefile55
-rw-r--r--audio/yammi/distinfo1
-rw-r--r--audio/yammi/files/patch-configure65
-rw-r--r--audio/yammi/pkg-descr22
-rw-r--r--audio/yammi/pkg-plist12
5 files changed, 155 insertions, 0 deletions
diff --git a/audio/yammi/Makefile b/audio/yammi/Makefile
new file mode 100644
index 000000000000..b1e937f4813a
--- /dev/null
+++ b/audio/yammi/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: yammi
+# Date created: 27 September 2003
+# Whom: Arjan van Leeuwen <avleeuwen@piwebs.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yammi
+PORTVERSION= 1.0.r1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.0.r/.0-rc/}
+
+MAINTAINER= avleeuwen@piwebs.com
+COMMENT= A QT-based music manager with fuzzy search
+
+LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis \
+ id3-3.8.2:${PORTSDIR}/audio/id3lib \
+ xmms.4:${PORTSDIR}/multimedia/xmms
+
+USE_QT_VER= 3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --program-prefix=''
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/noatun)
+WITH_NOATUN=yes
+.endif # exists(${LOCALBASE}/bin/noatun)
+
+.if defined(WITH_NOATUN)
+BUILD_DEPENDS+= noatun:${PORTSDIR}/multimedia/kdemultimedia3
+WITH_KDE=yes
+.endif # defined(WITH_NOATUN)
+
+.if exists(${LOCALBASE}/lib/libkdecore.so)
+WITH_KDE=yes
+.endif # exists(${LOCALBASE}/lib/libkdecore.so)
+
+.if defined(WITH_KDE)
+USE_KDELIBS_VER=3
+.endif # defined(WITH_KDE)
+
+pre-configure::
+ @${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/configure
+
+post-configure::
+ @${REINPLACE_CMD} -e 's@$$(DESTDIR)$$(KDEDIR)@$$(prefix)@g' ${WRKSRC}/yammi/docs/en/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/audio/yammi/distinfo b/audio/yammi/distinfo
new file mode 100644
index 000000000000..70bae8404faf
--- /dev/null
+++ b/audio/yammi/distinfo
@@ -0,0 +1 @@
+MD5 (yammi-1.0-rc1.tar.gz) = 7cbc79fbd2fa80b00f4451b7ed3f8f2f
diff --git a/audio/yammi/files/patch-configure b/audio/yammi/files/patch-configure
new file mode 100644
index 000000000000..083ee480b69e
--- /dev/null
+++ b/audio/yammi/files/patch-configure
@@ -0,0 +1,65 @@
+--- configure.orig Fri Sep 5 21:43:28 2003
++++ configure Fri Sep 5 21:43:31 2003
+@@ -21260,7 +21260,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-logg $LIBS"
++LIBS="-logg $LIBS $USER_LDFLAGS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 21265 "configure"
+ #include "confdefs.h"
+@@ -21322,7 +21322,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lvorbis $LIBS"
++LIBS="-lvorbis $LIBS $USER_LDFLAGS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 21327 "configure"
+ #include "confdefs.h"
+@@ -21386,7 +21386,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lvorbisfile $LIBS"
++LIBS="-lvorbisfile $LIBS $USER_LDFLAGS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 21391 "configure"
+ #include "confdefs.h"
+@@ -21450,7 +21450,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgdk $LIBS"
++LIBS="-lgdk12 $LIBS $USER_LDFLAGS $X_LDFLAGS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 21455 "configure"
+ #include "confdefs.h"
+@@ -21498,7 +21498,7 @@
+ #define HAVE_LIBGDK 1
+ EOF
+
+- LIBS="-lgdk $LIBS"
++ LIBS="-lgdk12 $LIBS"
+
+ else
+ configure_enable_ogglibs=no
+@@ -21527,7 +21527,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lz $LIBS"
++LIBS="-lz $LIBS $USER_LDFLAGS $X_LDFLAGS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 21532 "configure"
+ #include "confdefs.h"
+@@ -21589,7 +21589,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lid3 $LIBS"
++LIBS="-lid3 $LIBS $USER_LDFLAGS $X_LDFLAGS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 21594 "configure"
+ #include "confdefs.h"
diff --git a/audio/yammi/pkg-descr b/audio/yammi/pkg-descr
new file mode 100644
index 000000000000..14b6c7e9b2a1
--- /dev/null
+++ b/audio/yammi/pkg-descr
@@ -0,0 +1,22 @@
+Yammi ("Yet Another Music Manager I...") is a tool to manage your song
+collection (mp3, ogg, wav). For playing songs the program serves as a front-end
+for either XMMS or Noatun.
+
+Features:
+- conveniently search for songs (fuzzy search)
+- organize your songs into playlists/categories
+- keep statistics (when/how many times was song x played?)
+- support for id3 and ogg tag reading and writing (including id3v2)
+- easily keep your song info (tags and filenames) consistent
+- assist in burning your song collection to multiple CDs
+- act as a jukebox, loading song files on demand from removable media
+- prelisten to songs on headphone to DJ your own party (needs a second sound
+ device)
+- invoke other programs such as k3b, cdlabelgen or your own scripts to burn CDs,
+ generate CD labels or execute other commands using the information from
+ Yammi's song database
+
+WWW: http://yammi.sourceforge.net/
+
+- Arjan
+avleeuwen@piwebs.com
diff --git a/audio/yammi/pkg-plist b/audio/yammi/pkg-plist
new file mode 100644
index 000000000000..fd1962274941
--- /dev/null
+++ b/audio/yammi/pkg-plist
@@ -0,0 +1,12 @@
+bin/yammi
+bin/yammiGrabAndEncode
+share/doc/HTML/en/yammi/index-1.html
+share/doc/HTML/en/yammi/index-2.html
+share/doc/HTML/en/yammi/index-3.html
+share/doc/HTML/en/yammi/index-4.html
+share/doc/HTML/en/yammi/index-5.html
+share/doc/HTML/en/yammi/index-6.html
+share/doc/HTML/en/yammi/index.html
+@dirrm share/doc/HTML/en/yammi
+@dirrm share/doc/HTML/en
+@dirrm share/doc/HTML