aboutsummaryrefslogtreecommitdiff
path: root/audio/yell/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-13 18:41:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-13 18:41:51 +0000
commit92090216409817821b0d5ae827a16d495258fd7d (patch)
tree6012035aa4d9ee5b01ba01ca3fe4b0a47c1397c3 /audio/yell/Makefile
parentc4cafa53d10d2bf10ccbc22f3b500cadb133251e (diff)
downloadports-92090216409817821b0d5ae827a16d495258fd7d.tar.gz
ports-92090216409817821b0d5ae827a16d495258fd7d.zip
Notes
Diffstat (limited to 'audio/yell/Makefile')
-rw-r--r--audio/yell/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/audio/yell/Makefile b/audio/yell/Makefile
new file mode 100644
index 000000000000..0a78b454c080
--- /dev/null
+++ b/audio/yell/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: yell
+# Date created: 10 August 2004
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yell
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= http://www.critical.ch/yell/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line speaker bell using machine/speaker.h
+
+PLIST_FILES= bin/yell
+
+pre-everything::
+.if !defined(WITH_SUID)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "You can define WITH_SUID if you want yell to be installed with"
+ @${ECHO_CMD} "the sticky bit (mode 4110)"
+ @${ECHO_CMD} ""
+.endif
+
+do-build:
+ ${CC} ${WRKSRC}/yell.c ${CFLAGS} -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+.if defined(WITH_SUID)
+ ${INSTALL_PROGRAM} -m 4110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.else
+ ${INSTALL_PROGRAM} -m 0100 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>