aboutsummaryrefslogtreecommitdiff
path: root/audio/ympd
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2018-07-12 15:44:24 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2018-07-12 15:44:24 +0000
commit6fa6d8c005c3ea31d71853d65860086c3cee251f (patch)
tree7f40b9887033053c1ddb412f869f9ba6572aa7da /audio/ympd
parent0ee99c6851d6b910158df26d58fe9728f16993bd (diff)
downloadports-6fa6d8c005c3ea31d71853d65860086c3cee251f.tar.gz
ports-6fa6d8c005c3ea31d71853d65860086c3cee251f.zip
Notes
Diffstat (limited to 'audio/ympd')
-rw-r--r--audio/ympd/Makefile26
-rw-r--r--audio/ympd/distinfo3
-rw-r--r--audio/ympd/files/ympd.in39
-rw-r--r--audio/ympd/pkg-descr5
-rw-r--r--audio/ympd/pkg-message11
5 files changed, 84 insertions, 0 deletions
diff --git a/audio/ympd/Makefile b/audio/ympd/Makefile
new file mode 100644
index 000000000000..8ec4ce3023bb
--- /dev/null
+++ b/audio/ympd/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= ympd
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.0
+CATEGORIES= audio www
+MASTER_SITES= GH
+
+MAINTAINER= dch@FreeBSD.org
+COMMENT= Stand-alone lightweight web UI controller for audio/musicpd
+
+LICENSE= GPLv2 BSD3CLAUSE MIT
+LICENSE_COMB= multi
+
+LIB_DEPENDS= libmpdclient.so:audio/libmpdclient
+
+USES= cmake ssl
+USE_GITHUB= yes
+GH_ACCOUNT= notandy
+
+USE_RC_SUBR= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/man/man1/${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/audio/ympd/distinfo b/audio/ympd/distinfo
new file mode 100644
index 000000000000..86fc1b1964db
--- /dev/null
+++ b/audio/ympd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1531151012
+SHA256 (notandy-ympd-v1.3.0_GH0.tar.gz) = d9f68920cd93d1cfa971e1d7b9162a2b1724909bc9753c1338cecb3688d234d5
+SIZE (notandy-ympd-v1.3.0_GH0.tar.gz) = 350115
diff --git a/audio/ympd/files/ympd.in b/audio/ympd/files/ympd.in
new file mode 100644
index 000000000000..0f093a7a1c2a
--- /dev/null
+++ b/audio/ympd/files/ympd.in
@@ -0,0 +1,39 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ympd
+# REQUIRE: DAEMON NETWORKING musicpd
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable ympd:
+#
+# ympd_enable (bool): set to NO by default.
+# Set it to YES to enable ympd.
+#
+# ympd_flags (string): optional flags to pass through to daemon
+
+. /etc/rc.subr
+
+name=ympd
+rcvar=ympd_enable
+desc="A lightweight web UI for audio/musicpd"
+
+# defaults
+: ${ympd_enable:=NO}
+: ${ympd_flags:=""}
+
+load_rc_config ${name}
+
+start_cmd="ympd_start"
+
+command="%%PREFIX%%/bin/${name}"
+pidfile="/var/run/${name}.pid"
+
+ympd_start () {
+ echo "Starting ympd."
+ /usr/sbin/daemon -t ${name} -f -p ${pidfile} ${command} ${ympd_flags}
+}
+
+run_rc_command "$1"
diff --git a/audio/ympd/pkg-descr b/audio/ympd/pkg-descr
new file mode 100644
index 000000000000..22b990375613
--- /dev/null
+++ b/audio/ympd/pkg-descr
@@ -0,0 +1,5 @@
+A lightweight MPD (Music Player Daemon) web client written in C, that
+runs without a dedicated webserver or interpreters like PHP, NodeJS or
+Ruby. It's tuned for minimal resource usage, and minimal configuration.
+
+WWW: https://www.ympd.org/
diff --git a/audio/ympd/pkg-message b/audio/ympd/pkg-message
new file mode 100644
index 000000000000..427b1426784e
--- /dev/null
+++ b/audio/ympd/pkg-message
@@ -0,0 +1,11 @@
+To configure ympd, assuming it is running on the same system as
+audio/musicpd itself:
+
+sysrc ympd_enable=YES
+service ympd start
+
+You may optionally configure additional flags for the daemon:
+
+sysrc ympd_flags="--webport localhost:9000 --user=nobody"
+
+See ympd(1) for further details.