aboutsummaryrefslogtreecommitdiff
path: root/audio/zinf/Makefile
diff options
context:
space:
mode:
authorTorsten Blum <torstenb@FreeBSD.org>2001-07-02 08:24:09 +0000
committerTorsten Blum <torstenb@FreeBSD.org>2001-07-02 08:24:09 +0000
commit98d2a1cac159f18a91adff8f898320a185c30875 (patch)
tree6ba2a9aa121564eb727bbff0987f8de46311c9ce /audio/zinf/Makefile
parent7bddb8b594d0920a34e0ab70ff006cd9c866ed6a (diff)
downloadports-98d2a1cac159f18a91adff8f898320a185c30875.tar.gz
ports-98d2a1cac159f18a91adff8f898320a185c30875.zip
Notes
Diffstat (limited to 'audio/zinf/Makefile')
-rw-r--r--audio/zinf/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index 70d766c4bb2e..a68258a7bb41 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= freeamp
-PORTVERSION= 2.1.rc5
+PORTVERSION= 2.1.0
PORTREVISION= 1
CATEGORIES= audio gnome
MASTER_SITES= http://www.freeamp.org/download/src/
MAINTAINER= ports@FreeBSD.org
-BROKEN= "incompatibility with release versions of musicbrainz API."
-
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= musicbrainz.1:${PORTSDIR}/audio/musicbrainz \
id3:${PORTSDIR}/audio/id3lib \
@@ -25,7 +23,8 @@ USE_BZIP2= yes
USE_XLIB= yes
USE_GNOMECTRL= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOCONF =yes
+
CONFIGURE_ARGS+= --prefix=${PREFIX}
.include <bsd.port.pre.mk>
@@ -36,4 +35,11 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -D_M_IX86"
CONFIGURE_ENV= CFLAGS="${CFLAGS} -D_M_ALPHA"
.endif
+post-install:
+ if [ ! -d ... ]; then \
+ ${MKDIR} ${LOCALBASE}/etc/sdr/plugins; \
+ fi;\
+ ${INSTALL_DATA} ${FILESDIR}/sdr2.plugin.S100.audio.rtp.mpa.freeamp \
+ ${LOCALBASE}/etc/sdr/plugins/
+
.include <bsd.port.post.mk>