aboutsummaryrefslogtreecommitdiff
path: root/audio/zinf
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-18 18:52:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-18 18:52:52 +0000
commit786835fc3ea639d16e74eeae34c42022f299f6b9 (patch)
tree437d2f0bb78ed333d9de84196498d05853641390 /audio/zinf
parent983ca5050777a63c9c9fd4d877ca1d61e114038b (diff)
downloadports-786835fc3ea639d16e74eeae34c42022f299f6b9.tar.gz
ports-786835fc3ea639d16e74eeae34c42022f299f6b9.zip
Notes
Diffstat (limited to 'audio/zinf')
-rw-r--r--audio/zinf/Makefile18
-rw-r--r--audio/zinf/distinfo4
-rw-r--r--audio/zinf/files/patch-base-Makefile.in16
-rw-r--r--audio/zinf/files/patch-base-include-event.h13
-rw-r--r--audio/zinf/files/patch-base-include-eventdata.h11
-rw-r--r--audio/zinf/files/patch-base-src-player.cpp20
-rw-r--r--audio/zinf/files/patch-base-src-properties.cpp12
-rw-r--r--audio/zinf/files/patch-base-src-propimpl.cpp13
-rw-r--r--audio/zinf/files/patch-config-ltmain.sh21
-rw-r--r--audio/zinf/files/patch-configure14
-rw-r--r--audio/zinf/files/patch-io-soundcard-unix-linux-soundcardpmo.cpp11
-rw-r--r--audio/zinf/files/patch-io-src-pullbuffer.cpp17
-rw-r--r--audio/zinf/files/patch-io-wavout-src-wav.cpp21
-rw-r--r--audio/zinf/files/patch-lmc-wav-src-wavlmc.cpp10
-rw-r--r--audio/zinf/files/patch-ui-musicbrowser-unix-src-musicsearch.cpp12
-rw-r--r--audio/zinf/files/patch-ui-zinf-include-DialControl.h12
-rw-r--r--audio/zinf/files/patch-ui-zinf-src-ThemeZip.cpp40
-rw-r--r--audio/zinf/pkg-plist5
18 files changed, 82 insertions, 188 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index 85115149f4de..d45566b76356 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zinf
-PORTVERSION= 2.2.4
-PORTREVISION= 3
+PORTVERSION= 2.2.5
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,22 +19,18 @@ LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
gdbm.3:${PORTSDIR}/databases/gdbm
USE_X_PREFIX= yes
-USE_GNOME= gdkpixbuf gnomehack gnometarget
+USE_GNOME= gnomehack gnometarget gtk20 lthack
WANT_GNOME= yes
USE_PERL5= yes
-USE_FREETYPE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
LIBTOOLFLAGS= # none
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-ipv6
-CPPFLAGS= -I${LOCALBASE}/include/freetype1/freetype \
- -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CFLAGS+= -O0
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@@ -52,6 +47,7 @@ CPPFLAGS+= "-D_M_ALPHA"
.if ${OSVERSION} < 500035
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CFLAGS+= -O0
CPPFLAGS+= -I${LOCALBASE}/include/stlport
LDFLAGS+= -lstlport_gcc
.endif
@@ -81,12 +77,6 @@ CONFIGURE_ARGS+= --disable-vorbis
PLIST_SUB+= VORBIS="@comment "
.endif
-# Stop a flood of complaints and PRs from people who can't be bothered
-# to keep their ports and packages up to date.
-.if exists(${LOCALBASE}/include/freetype/freetype.h)
-.error UPGRADE print/freetype TO CURRENT VERSION!
-.endif
-
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "You may use the following build options:"
diff --git a/audio/zinf/distinfo b/audio/zinf/distinfo
index 47755985e206..890b51aad8c5 100644
--- a/audio/zinf/distinfo
+++ b/audio/zinf/distinfo
@@ -1,2 +1,2 @@
-MD5 (zinf-2.2.4.tar.gz) = 7520bbbffa466b86753c461f3c3a075f
-SIZE (zinf-2.2.4.tar.gz) = 1722083
+MD5 (zinf-2.2.5.tar.gz) = 1f2512ff445458d363425533607b471a
+SIZE (zinf-2.2.5.tar.gz) = 2043701
diff --git a/audio/zinf/files/patch-base-Makefile.in b/audio/zinf/files/patch-base-Makefile.in
index bf726d9d86e7..4c1924ee8d9b 100644
--- a/audio/zinf/files/patch-base-Makefile.in
+++ b/audio/zinf/files/patch-base-Makefile.in
@@ -1,11 +1,11 @@
---- base/Makefile.in.orig Mon Aug 4 01:31:49 2003
-+++ base/Makefile.in Mon Aug 18 19:02:03 2003
-@@ -230,7 +230,7 @@
- src/undomanager.cpp src/timer.cpp src/missingfile.cpp
+--- base/Makefile.in.orig Sun Feb 15 08:34:57 2004
++++ base/Makefile.in Mon Feb 16 13:02:37 2004
+@@ -245,7 +245,7 @@
- zinf_LDADD = $(top_builddir)/io/libio.la unix/libunix.la $(GDBM_LIBS) \
-- $(THREAD_LIBS) -ldl
-+ $(THREAD_LIBS) $(INTLLIBS)
- zinf_LDFLAGS = -export-dynamic
+ zinf_LDADD = $(top_builddir)/io/libio.la unix/libunix.la \
+- $(ZINF_LIBS) $(GDBM_LIBS) $(THREAD_LIBS) $(GLIB_LIBS) -ldl
++ $(ZINF_LIBS) $(GDBM_LIBS) $(THREAD_LIBS) $(GLIB_LIBS)
+
+ zinf_LDFLAGS = -export-dynamic -L$(top_builddir)/mdb
diff --git a/audio/zinf/files/patch-base-include-event.h b/audio/zinf/files/patch-base-include-event.h
new file mode 100644
index 000000000000..2b0741654902
--- /dev/null
+++ b/audio/zinf/files/patch-base-include-event.h
@@ -0,0 +1,13 @@
+--- base/include/event.h.orig Wed Sep 17 02:34:53 2003
++++ base/include/event.h Mon Feb 16 12:15:13 2004
+@@ -24,7 +24,10 @@
+ #ifndef INCLUDED_EVENT_H_
+ #define INCLUDED_EVENT_H_
+
++#include <inttypes.h>
++#if HAVE_STDINT_H
+ #include <stdint.h>
++#endif
+ #include "config.h"
+ #include "errors.h"
+
diff --git a/audio/zinf/files/patch-base-include-eventdata.h b/audio/zinf/files/patch-base-include-eventdata.h
deleted file mode 100644
index b9e19c15c8c1..000000000000
--- a/audio/zinf/files/patch-base-include-eventdata.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- base/include/eventdata.h.orig Thu Feb 6 02:52:52 2003
-+++ base/include/eventdata.h Sat Sep 13 02:36:12 2003
-@@ -241,7 +241,7 @@
-
- m_childEvents = new std::vector <Event *>(other.m_childEvents->size());
-
-- copy(other.m_childEvents->begin(), other.m_childEvents->end(),
-+ std::copy(other.m_childEvents->begin(), other.m_childEvents->end(),
- m_childEvents->begin());
- }
-
diff --git a/audio/zinf/files/patch-base-src-player.cpp b/audio/zinf/files/patch-base-src-player.cpp
deleted file mode 100644
index dc9db1ce4657..000000000000
--- a/audio/zinf/files/patch-base-src-player.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- base/src/player.cpp.orig Sun Aug 3 04:17:48 2003
-+++ base/src/player.cpp Thu Aug 21 21:50:28 2003
-@@ -708,7 +708,7 @@
- #ifndef HAVE_GTK
- if (name == "zinf.ui") {
- pref = kTextUIPref;
-- context->prefs->GetPrefString(pref, name);
-+ m_context->prefs->GetPrefString(pref, name);
- }
- #endif
- #endif
-@@ -869,7 +869,7 @@
- // cerr << boost::format("%1% will quit") % The_BRANDING << endl;
-
-
-- cerr << "No UI plugin in '" << thePath << "' matched 'plugins/" << name << "' or 'plugins/" << name << ".ui.'" << endl;
-+ cerr << "If this was the first time you started zinf just try again." << endl;
- cerr << The_BRANDING << " will quit." << endl;
- #endif
- Event *e = new Event(CMD_QuitPlayer);
diff --git a/audio/zinf/files/patch-base-src-properties.cpp b/audio/zinf/files/patch-base-src-properties.cpp
new file mode 100644
index 000000000000..15dcafff4ac8
--- /dev/null
+++ b/audio/zinf/files/patch-base-src-properties.cpp
@@ -0,0 +1,12 @@
+--- base/src/properties.cpp.orig Wed Nov 12 04:59:07 2003
++++ base/src/properties.cpp Mon Feb 16 11:51:23 2004
+@@ -29,7 +29,9 @@
+ #endif
+
+
++#if HAVE_STDINT_H
+ #include <stdint.h>
++#endif
+ // #include <map>
+ #include <vector>
+ #include <string>
diff --git a/audio/zinf/files/patch-base-src-propimpl.cpp b/audio/zinf/files/patch-base-src-propimpl.cpp
deleted file mode 100644
index 0b1c28eb8ac0..000000000000
--- a/audio/zinf/files/patch-base-src-propimpl.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- base/src/propimpl.cpp.orig Thu Feb 6 02:52:47 2003
-+++ base/src/propimpl.cpp Mon Aug 18 17:35:16 2003
-@@ -21,7 +21,10 @@
- $Id: propimpl.cpp,v 1.4 2003/02/05 17:52:47 rottmann Exp $
- ____________________________________________________________________________*/
-
-+#include <inttypes.h>
-+#if HAVE_STDINT_H
- #include <stdint.h>
-+#endif
- #include <map>
- #include <vector>
- #include <string>
diff --git a/audio/zinf/files/patch-config-ltmain.sh b/audio/zinf/files/patch-config-ltmain.sh
deleted file mode 100644
index f70dd783e4fc..000000000000
--- a/audio/zinf/files/patch-config-ltmain.sh
+++ /dev/null
@@ -1,21 +0,0 @@
---- config/ltmain.sh.orig Wed Jul 23 11:20:18 2003
-+++ config/ltmain.sh Mon Aug 18 22:41:00 2003
-@@ -1075,12 +1075,17 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
- esac
- fi
-+ deplibs="$deplibs $arg"
-+ continue
-+ ;;
-+
-+ -?thread)
- deplibs="$deplibs $arg"
- continue
- ;;
diff --git a/audio/zinf/files/patch-configure b/audio/zinf/files/patch-configure
index 49691105fd86..afd15949a868 100644
--- a/audio/zinf/files/patch-configure
+++ b/audio/zinf/files/patch-configure
@@ -1,14 +1,6 @@
---- configure.orig Mon Aug 4 01:28:11 2003
-+++ configure Thu Aug 21 21:13:45 2003
-@@ -8480,6 +8480,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -13429,6 +13430,7 @@
+--- configure.orig Mon Feb 16 13:03:02 2004
++++ configure Mon Feb 16 13:11:47 2004
+@@ -24258,6 +24258,7 @@
;;
freebsd*)
ZINF_OS="freebsd";
diff --git a/audio/zinf/files/patch-io-soundcard-unix-linux-soundcardpmo.cpp b/audio/zinf/files/patch-io-soundcard-unix-linux-soundcardpmo.cpp
deleted file mode 100644
index ed51459264b3..000000000000
--- a/audio/zinf/files/patch-io-soundcard-unix-linux-soundcardpmo.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- io/soundcard/unix/linux/soundcardpmo.cpp.orig Fri May 30 20:01:42 2003
-+++ io/soundcard/unix/linux/soundcardpmo.cpp Thu Aug 21 21:48:48 2003
-@@ -210,7 +210,7 @@
- int junkvar = 0;
-
- #if !SMALL_ENDIAN
-- mask = AFMT_S16_BE
-+ mask = AFMT_S16_BE;
- if(ioctl(audio_fd,SNDCTL_DSP_SETFMT,&mask) == -1){
- ReportError(_("Cannot set card to Big Endian."));
- return(Error) pmoError_IOCTL_SNDCTL_DSP_SETFMT;
diff --git a/audio/zinf/files/patch-io-src-pullbuffer.cpp b/audio/zinf/files/patch-io-src-pullbuffer.cpp
index a88c229d866c..6344b0d2eb3e 100644
--- a/audio/zinf/files/patch-io-src-pullbuffer.cpp
+++ b/audio/zinf/files/patch-io-src-pullbuffer.cpp
@@ -1,22 +1,13 @@
---- io/src/pullbuffer.cpp.orig Sat Mar 15 10:01:51 2003
-+++ io/src/pullbuffer.cpp Thu Aug 21 21:53:22 2003
-@@ -26,6 +26,10 @@
+--- io/src/pullbuffer.cpp.orig Wed Sep 17 02:35:05 2003
++++ io/src/pullbuffer.cpp Mon Feb 16 11:42:36 2004
+@@ -26,7 +26,10 @@
#include <stdlib.h>
#include <string.h>
#include <assert.h>
+#include <inttypes.h>
+#if HAVE_STDINT_H
-+#include <stdint.h>
+ #include <stdint.h>
+#endif
#ifndef WIN32
#include <unistd.h>
#endif
-@@ -168,7 +172,7 @@
-
- pPtr = (char *)pBuffer;
-
-- if (pPtr >= (char *)((unsigned int)m_pPullBuffer + m_iBufferSize))
-+ if (pPtr >= (char *)((uintptr_t)m_pPullBuffer + m_iBufferSize))
- pPtr -= m_iBufferSize;
-
- pBuffer = (void *)pPtr;
diff --git a/audio/zinf/files/patch-io-wavout-src-wav.cpp b/audio/zinf/files/patch-io-wavout-src-wav.cpp
deleted file mode 100644
index f9abc93765d8..000000000000
--- a/audio/zinf/files/patch-io-wavout-src-wav.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
---- io/wavout/src/wav.cpp.orig Tue Mar 18 03:53:30 2003
-+++ io/wavout/src/wav.cpp Sun Nov 9 12:54:05 2003
-@@ -101,7 +101,7 @@
- if (m_FP == NULL) return;
-
- #if !SMALL_ENDIAN
-- m_WH.Length = SWAB32(DataWritten + sizeof(WaveHeader) - 4);
-+ m_WH.Length = SWAB32(SWAB32(m_WH.DataLength) + sizeof(WaveHeader) - 4);
- #else
- m_WH.Length = m_WH.DataLength + sizeof(WaveHeader) - 4;
- #endif
-@@ -117,8 +117,7 @@
- DWORD WaveWriter::Write(const char *data, DWORD data_size)
- {
- #if !SMALL_ENDIAN
-- DataWritten+=data_size;
-- m_WH.DataLength=SWAB32(DataWritten);
-+ m_WH.DataLength=SWAB32(SWAB32(m_WH.DataLength) + data_size);
- #else
- m_WH.DataLength+=data_size;
- #endif
diff --git a/audio/zinf/files/patch-lmc-wav-src-wavlmc.cpp b/audio/zinf/files/patch-lmc-wav-src-wavlmc.cpp
deleted file mode 100644
index 4449341d02b9..000000000000
--- a/audio/zinf/files/patch-lmc-wav-src-wavlmc.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- lmc/wav/src/wavlmc.cpp.orig Sat Mar 15 10:01:52 2003
-+++ lmc/wav/src/wavlmc.cpp Thu Aug 21 19:49:36 2003
-@@ -49,6 +49,7 @@
- #include "facontext.h"
- #include "log.h"
- #include "debug.h"
-+#include "swab.h"
-
- #define DB Debug_v("%s:%d\n", __FILE__, __LINE__);
-
diff --git a/audio/zinf/files/patch-ui-musicbrowser-unix-src-musicsearch.cpp b/audio/zinf/files/patch-ui-musicbrowser-unix-src-musicsearch.cpp
new file mode 100644
index 000000000000..ad92635cc7ad
--- /dev/null
+++ b/audio/zinf/files/patch-ui-musicbrowser-unix-src-musicsearch.cpp
@@ -0,0 +1,12 @@
+--- ui/musicbrowser/unix/src/musicsearch.cpp.orig Thu Feb 5 07:06:40 2004
++++ ui/musicbrowser/unix/src/musicsearch.cpp Mon Feb 16 14:08:17 2004
+@@ -33,7 +33,9 @@
+ #include "eventdata.h"
+ #include "fileselector.h"
+ #include "musiccatalog.h"
++#ifdef EXPERIMENTAL
+ #include "musicdb.h"
++#endif
+ #include "musicsearchui.h"
+ #include "musicbrowserui.h"
+
diff --git a/audio/zinf/files/patch-ui-zinf-include-DialControl.h b/audio/zinf/files/patch-ui-zinf-include-DialControl.h
new file mode 100644
index 000000000000..64a5dfea974a
--- /dev/null
+++ b/audio/zinf/files/patch-ui-zinf-include-DialControl.h
@@ -0,0 +1,12 @@
+--- ui/zinf/include/DialControl.h.orig Wed Sep 17 02:35:32 2003
++++ ui/zinf/include/DialControl.h Mon Feb 16 12:46:03 2004
+@@ -24,7 +24,9 @@
+ #ifndef INCLUDED_DIALCONTROL_H__
+ #define INCLUDED_DIALCONTROL_H__
+
++#if HAVE_STDINT_H
+ #include <stdint.h>
++#endif
+ #include "config.h"
+
+ #include <string>
diff --git a/audio/zinf/files/patch-ui-zinf-src-ThemeZip.cpp b/audio/zinf/files/patch-ui-zinf-src-ThemeZip.cpp
index 329ae901ce37..3c2c7f711ebd 100644
--- a/audio/zinf/files/patch-ui-zinf-src-ThemeZip.cpp
+++ b/audio/zinf/files/patch-ui-zinf-src-ThemeZip.cpp
@@ -1,40 +1,16 @@
---- ui/zinf/src/ThemeZip.cpp.orig Sun Feb 23 09:35:06 2003
-+++ ui/zinf/src/ThemeZip.cpp Thu Aug 21 21:56:19 2003
-@@ -24,6 +24,10 @@
+--- ui/zinf/src/ThemeZip.cpp.orig Wed Sep 17 02:36:22 2003
++++ ui/zinf/src/ThemeZip.cpp Mon Feb 16 13:39:03 2004
+@@ -21,11 +21,12 @@
+ $Id: ThemeZip.cpp,v 1.8 2003/09/16 17:36:22 kgk Exp $
+ ____________________________________________________________________________*/
+
+-#include <stdint.h>
#include <time.h>
#include <stdio.h>
#include <ctype.h>
-+#include <inttypes.h>
+#if HAVE_STDINT_H
-+#include <stdint.h>
+ #include <stdint.h>
+#endif
#ifdef WIN32
#include <windows.h>
-@@ -145,7 +149,7 @@
- oFile = *(*i);
- pPtr = strrchr(oFile.c_str(), DIR_MARKER);
- if (pPtr)
-- oFile.erase(0, ((int)pPtr - (int)oFile.c_str()) + 1);
-+ oFile.erase(0, ((uintptr_t)pPtr - (uintptr_t)oFile.c_str()) + 1);
-
- pIn = fopen((*i)->c_str(), "rb");
- if (pIn == NULL)
-@@ -424,7 +428,7 @@
-
- oUnpackFile = string(TarRecord.header.name);
- // in case we have sub-directory in tar, take only filename
-- unsigned int uPos;
-+ uintptr_t uPos;
- uPos=oUnpackFile.rfind('/');
- if(uPos!=oUnpackFile.npos) oUnpackFile.erase(0,uPos+1);
-
-@@ -553,7 +557,7 @@
- // see if it is directory record we are looking for
- if(TarRecord.header.typeflag == DIRTYPE)
- {
-- unsigned int uPos;
-+ uintptr_t uPos;
- oDescriptiveName = string (TarRecord.header.name);
-
- // erase trailing slash
diff --git a/audio/zinf/pkg-plist b/audio/zinf/pkg-plist
index 6f936ba4982d..ace94b0de606 100644
--- a/audio/zinf/pkg-plist
+++ b/audio/zinf/pkg-plist
@@ -1,5 +1,6 @@
bin/zinf
etc/sdr/plugins/sdr2.plugin.S100.audio.rtp.mpa.zinf
+lib/zinf/plugins/albumart.ui
%%LIBARTS%%lib/zinf/plugins/arts.pmo
lib/zinf/plugins/cd.lmc
lib/zinf/plugins/cd.pmo
@@ -7,9 +8,9 @@ lib/zinf/plugins/cmdline.ui
lib/zinf/plugins/download.ui
%%ESOUND%%lib/zinf/plugins/esound.pmo
lib/zinf/plugins/http.pmi
+lib/zinf/plugins/id3lib.mdf
lib/zinf/plugins/irman.ui
lib/zinf/plugins/kjofol.ftf
-lib/zinf/plugins/id3lib.mdf
lib/zinf/plugins/lcd.ui
lib/zinf/plugins/local.pmi
lib/zinf/plugins/m3u.plf
@@ -28,6 +29,8 @@ lib/zinf/plugins/wavout.pmo
lib/zinf/plugins/winamp.ftf
lib/zinf/plugins/xingmp3.lmc
lib/zinf/plugins/zinf.ui
+share/locale/ca_ES/LC_MESSAGES/zinf.mo
+share/locale/ru/LC_MESSAGES/zinf.mo
share/zinf/themes/Aquatica.fat
share/zinf/themes/Zinf.fat
share/zinf/themes/ZinfClassic.fat