aboutsummaryrefslogtreecommitdiff
path: root/audio/zinf
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-07-03 12:46:58 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-07-03 12:46:58 +0000
commita2cad3a1c17959ef3e29df085f25b88a264ce6c8 (patch)
treeba37a6af8b914f188360e99d05e9e80fb6327835 /audio/zinf
parent0dae4d7036f39fd7b0aa11f15d9826782f9d2f0a (diff)
downloadports-a2cad3a1c17959ef3e29df085f25b88a264ce6c8.tar.gz
ports-a2cad3a1c17959ef3e29df085f25b88a264ce6c8.zip
Notes
Diffstat (limited to 'audio/zinf')
-rw-r--r--audio/zinf/Makefile43
-rw-r--r--audio/zinf/files/patch-aa194
-rw-r--r--audio/zinf/files/patch-ab19
-rw-r--r--audio/zinf/files/patch-ac22
-rw-r--r--audio/zinf/pkg-plist346
5 files changed, 401 insertions, 223 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index a68258a7bb41..02df99a3e53d 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -7,39 +7,54 @@
PORTNAME= freeamp
PORTVERSION= 2.1.0
-PORTREVISION= 1
-CATEGORIES= audio gnome
+PORTREVISION= 2
+CATEGORIES= audio
MASTER_SITES= http://www.freeamp.org/download/src/
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= musicbrainz.1:${PORTSDIR}/audio/musicbrainz \
- id3:${PORTSDIR}/audio/id3lib \
+ ORBit.2:${PORTSDIR}/devel/ORBit \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
ttf.4:${PORTSDIR}/print/freetype
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
-USE_XLIB= yes
-USE_GNOMECTRL= yes
+WANT_ESOUND= yes
+USE_GTK= yes
USE_GMAKE= yes
-USE_AUTOCONF =yes
-
-CONFIGURE_ARGS+= --prefix=${PREFIX}
+USE_AUTOCONF= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -D_M_IX86"
+CFLAGS+= "-D_M_IX86"
.elif ${ARCH} == "alpha"
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -D_M_ALPHA"
+CFLAGS+= "-D_M_ALPHA"
+.endif
+
+.if defined(HAVE_ESOUND)
+USE_ESOUND= yes
+PLIST_SUB+= ESOUND=""
+.else
+CONFIGURE_ARGS+= --disable-esd
+PLIST_SUB+= ESOUND="@comment "
+.endif
+
+.if defined(WITH_LIBARTS)
+LIB_DEPENDS= libartsc.0:${PORTSDIR}/x11/kdelibs2
+PLIST_SUB+= LIBARTS=""
+.else
+CONFIGURE_ARGS+= --disable-arts
+PLIST_SUB+= LIBARTS="@comment "
.endif
post-install:
- if [ ! -d ... ]; then \
- ${MKDIR} ${LOCALBASE}/etc/sdr/plugins; \
- fi;\
+ @${MKDIR} ${PREFIX}/etc/sdr/plugins
${INSTALL_DATA} ${FILESDIR}/sdr2.plugin.S100.audio.rtp.mpa.freeamp \
- ${LOCALBASE}/etc/sdr/plugins/
+ ${PREFIX}/etc/sdr/plugins
.include <bsd.port.post.mk>
diff --git a/audio/zinf/files/patch-aa b/audio/zinf/files/patch-aa
index 93832dff5bbf..d8f7aedd8bd4 100644
--- a/audio/zinf/files/patch-aa
+++ b/audio/zinf/files/patch-aa
@@ -1,19 +1,175 @@
-*** configure.in.orig Sun Jul 1 15:31:13 2001
---- configure.in Sun Jul 1 15:32:03 2001
-***************
-*** 928,934 ****
- AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- AC_CHECK_LIB(musicbrainz, mb_New, ,
-! AC_MSG_ERROR([FreeAmp requires that the MusicBrainz client library be installed.]),-ldl)
- AC_LANG_RESTORE
-
- AC_CONFIG_HEADER(config/config.h)
---- 928,934 ----
- AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- AC_CHECK_LIB(musicbrainz, mb_New, ,
-! AC_MSG_ERROR([FreeAmp requires that the MusicBrainz client library be installed.]))
- AC_LANG_RESTORE
-
- AC_CONFIG_HEADER(config/config.h)
+--- configure.in.orig Sat Apr 14 02:44:47 2001
++++ configure.in Mon Jul 2 21:43:50 2001
+@@ -174,8 +174,8 @@
+ ;;
+ freebsd*)
+ host_os="freebsd"
+- CFLAGS="$CFLAGS -D_THREAD_SAFE -pthread -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic -L/usr/local/lib"
++ CFLAGS="$CFLAGS"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+ ;;
+ netbsd*)
+ host_os="freebsd"
+@@ -326,9 +326,9 @@
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ esd_micro_version=`$ESD_CONFIG $esd_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+- ac_save_CFLAGS="$CFLAGS"
++ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_LIBS="$LIBS"
+- CFLAGS="$CFLAGS $ESD_CFLAGS"
++ CPPFLAGS="$CPPFLAGS $ESD_CFLAGS"
+ LIBS="$LIBS $ESD_LIBS"
+ rm -f conf.esdtest
+ AC_MSG_CHECKING(for ESD - version >= $min_esd_version)
+@@ -387,7 +387,7 @@
+ }
+
+ ],, have_esound=false, have_esound=false)
+- CFLAGS="$ac_save_CFLAGS"
++ CPPFLAGS="$ac_save_CPPFLAGS"
+ LIBS="$ac_save_LIBS"
+ AC_LANG_RESTORE
+ rm -f conf.esdtest
+@@ -460,9 +460,9 @@
+ gtk_config_major=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+ gtk_config_minor=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ gtk_config_micro=`$GTK_CONFIG --version | sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+- ac_save_CFLAGS="$CFLAGS"
++ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_LIBS="$LIBS"
+- CFLAGS="$CFLAGS $GTK_CFLAGS"
++ CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
+ LIBS="$GTK_LIBS $LIBS"
+
+ AC_TRY_RUN([
+@@ -489,7 +489,7 @@
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
+ return 1;
+ }], , have_gtk=false, have_gtk=false])
+- CFLAGS="$ac_save_CFLAGS"
++ CPPFLAGS="$ac_save_CPPFLAGS"
+ LIBS="$ac_save_LIBS"
+ if test "$have_gtk" = "false"; then
+ AC_MSG_RESULT(no)
+@@ -510,7 +510,7 @@
+ OSINC="$OSINC -I$srcdir/ui/download/unix/include"
+ OSINC="$OSINC -I$srcdir/ui/musicbrowser/include"
+ OSINC="$OSINC -I$srcdir/ftc/kjofol"
+- CFLAGS="$CFLAGS $GTK_CFLAGS"
++ CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
+ AC_DEFINE(HAVE_GTK)
+ elif test "$host_os" = "beos"; then
+ OSDEPPLUGINS="$OSDEPPLUGINS plugins/musicbrowser.ui"
+@@ -536,7 +536,7 @@
+ AC_SUBST(GTK_LIBS)
+ AC_SUBST(EXTRALIBS)
+
+-AC_SUBST(CFLAGS)
++AC_SUBST(CPPFLAGS)
+
+ dnl orbit crap
+ save_CPPFLAGS="$CPPFLAGS"
+@@ -656,7 +656,7 @@
+ alsa_min_major_version=0
+ alsa_min_minor_version=5
+ alsa_min_micro_version=0
+- ac_save_CFLAGS="$CFLAGS"
++ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_LIBS="$LIBS"
+
+ LIBS="$LIBS -lasound"
+@@ -701,7 +701,7 @@
+ ], , have_alsa=false, have_alsa=false
+ )
+ AC_LANG_RESTORE
+- CFLAGS="$ac_save_CFLAGS"
++ CPPFLAGS="$ac_save_CPPFLAGS"
+ LIBS="$ac_save_LIBS"
+ if test "$have_alsa" = "false"; then
+ AC_MSG_RESULT(no)
+@@ -748,13 +748,21 @@
+ have_arts="false")
+ fi
+
++AC_ARG_ENABLE(arts, [ --disable-arts Don't compile the libArts output plugin], enable_arts=no, enable_arts=yes)
++
++if test "x$enable_arts" = "xno"; then
++ have_arts="false";
++fi
++
+ ARTS_LIBS=""
+-AC_CHECK_LIB(artsc, arts_init,
+- OSDEPPLUGINS="$OSDEPPLUGINS plugins/arts.pmo";
+- OSINC="$OSINC -I$srcdir/io/arts/include"
+- ARTS_LIBS="-lartsc -laudiofile"
+- AC_MSG_RESULT([compiling arts pmo plugin])
+-)
++if test "$have_arts" = "true"; then
++ AC_CHECK_LIB(artsc, arts_init,
++ OSDEPPLUGINS="$OSDEPPLUGINS plugins/arts.pmo";
++ OSINC="$OSINC -I$srcdir/io/arts/include"
++ ARTS_LIBS="-lartsc -laudiofile"
++ AC_MSG_RESULT([compiling arts pmo plugin])
++ )
++fi
+
+ AC_SUBST(ARTS_LIBS)
+ AC_SUBST(EXTRALIBS)
+@@ -808,9 +816,9 @@
+ gdk_pixbuf_micro_version=`$GDK_PIXBUF_CONFIG $gdk_pixbuf_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_gdk_pixbuftest" = "xyes" ; then
+- ac_save_CFLAGS="$CFLAGS"
++ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_LIBS="$LIBS"
+- CFLAGS="$CFLAGS $GDK_PIXBUF_CFLAGS"
++ CPPFLAGS="$CPPFLAGS $GDK_PIXBUF_CFLAGS"
+ LIBS="$LIBS $GDK_PIXBUF_LIBS"
+ dnl
+ dnl Now check if the installed GDK_PIXBUF is sufficiently new. (Also sanity
+@@ -872,7 +880,7 @@
+ }
+
+ ],, no_gdk_pixbuf=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+- CFLAGS="$ac_save_CFLAGS"
++ CPPFLAGS="$ac_save_CPPFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+@@ -891,7 +899,7 @@
+ :
+ else
+ echo "*** Could not run GDK_PIXBUF test program, checking why..."
+- CFLAGS="$CFLAGS $GDK_PIXBUF_CFLAGS"
++ CPPFLAGS="$CPPFLAGS $GDK_PIXBUF_CFLAGS"
+ LIBS="$LIBS $GDK_PIXBUF_LIBS"
+ AC_TRY_LINK([
+ #include <stdio.h>
+@@ -910,7 +918,7 @@
+ echo "*** exact error that occured. This usually means GDK_PIXBUF was incorrectly installed"
+ echo "*** or that you have moved GDK_PIXBUF since it was installed. In the latter case, you"
+ echo "*** may want to edit the gdk-pixbuf-config script: $GDK_PIXBUF_CONFIG" ])
+- CFLAGS="$ac_save_CFLAGS"
++ CPPFLAGS="$ac_save_CPPFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+@@ -922,13 +930,13 @@
+ AC_SUBST(GDK_PIXBUF_LIBS)
+ rm -f conf.gdk_pixbuftest
+
+-CFLAGS="$CFLAGS $GDK_PIXBUF_CFLAGS"
+-AC_SUBST(CFLAGS)
++CPPFLAGS="$CPPFLAGS $GDK_PIXBUF_CFLAGS"
++AC_SUBST(CPPFLAGS)
+
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ AC_CHECK_LIB(musicbrainz, mb_New, ,
+- AC_MSG_ERROR([FreeAmp requires that the MusicBrainz client library be installed.]),-ldl)
++ AC_MSG_ERROR([FreeAmp requires that the MusicBrainz client library be installed.]))
+ AC_LANG_RESTORE
+
+ AC_CONFIG_HEADER(config/config.h)
diff --git a/audio/zinf/files/patch-ab b/audio/zinf/files/patch-ab
deleted file mode 100644
index 74c70f279b31..000000000000
--- a/audio/zinf/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
-*** config/config.h.in.orig Sun Jul 1 18:51:35 2001
---- config/config.h.in Sun Jul 1 18:51:49 2001
-***************
-*** 46,52 ****
- #define BRANDING_UPDATE_SERVER "fatman.freeamp.org"
- #define BRANDING_UPDATE_PATH "/update/freeamp/"
- #define BRANDING_DEFAULT_THEME "FreeAmp.fat"
-! #define BRANDING_SHARE_PATH "/../share/freeamp"
- #define BRANDING_APP_NAME "freeamp"
-
- #define FREEAMP_PATH_ENV "FREEAMP_PATH"
---- 46,52 ----
- #define BRANDING_UPDATE_SERVER "fatman.freeamp.org"
- #define BRANDING_UPDATE_PATH "/update/freeamp/"
- #define BRANDING_DEFAULT_THEME "FreeAmp.fat"
-! #define BRANDING_SHARE_PATH "/../share/gnome/freeamp"
- #define BRANDING_APP_NAME "freeamp"
-
- #define FREEAMP_PATH_ENV "FREEAMP_PATH"
diff --git a/audio/zinf/files/patch-ac b/audio/zinf/files/patch-ac
new file mode 100644
index 000000000000..9ac6033089d5
--- /dev/null
+++ b/audio/zinf/files/patch-ac
@@ -0,0 +1,22 @@
+--- Makefile.header.in.orig Sun Jan 28 15:43:24 2001
++++ Makefile.header.in Sat Jun 30 07:33:57 2001
+@@ -71,7 +71,7 @@
+
+ INCLUDES = -I. -I$(srcdir)/lib/gdbm -I$(srcdir)/base/include -I$(srcdir)/config -I$(srcdir)/io/include -I$(srcdir)/ui/include -I$(srcdir)/lmc/include -I$(srcdir)/io/soundcard/unix/$(UNIX_AUDIO_API)/include -I$(srcdir)/lmc/xingmp3/include -I$(srcdir)/lmc/cd/include -I$(srcdir)/plm/portable/pmp300/sba -I$(srcdir)/lib/xml/include -I$(srcdir)/lib/zlib/include -I$(srcdir)/lib/unzip/include -I$(srcdir)/io/cd/unix/include -I$(srcdir)/base/aps -I$(srcdir)/io/wavout/include -I$(srcdir)/ui/lcd/include -I$(srcdir)/ui/irman/include -I$(srcdir)/lib/http/include -I$(srcdir)/io/signature/include -I$(srcdir)/plm/metadata/id3v2 $(OSINC)
+
+-CXXFLAGS = $(EXTRA_CXXFLAGS)
++CXXFLAGS = @CXXFLAGS@ -D_REENTRANT
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(srcdir)/config/mkinstalldirs
+ CONFIG_HEADER = ./config/config.h
+@@ -87,8 +87,8 @@
+ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+
+-COMPILE = $(CC) $(DEFS) $(INCLUDES) $(CFLAGS) $(RELOC)
+-CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(CXXFLAGS)
++COMPILE = $(CC) $(DEFS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(RELOC)
++CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(CXXFLAGS) $(CPPFLAGS)
+ CXXCOMPILE += $(RELOC)
+
+ CXXLINK = $(CXXLD) $(CXXFLAGS) $(LDFLAGS) $(RELOC) -o $@
diff --git a/audio/zinf/pkg-plist b/audio/zinf/pkg-plist
index d1207e1fa629..0d4a5095f58f 100644
--- a/audio/zinf/pkg-plist
+++ b/audio/zinf/pkg-plist
@@ -1,15 +1,11 @@
bin/freeamp
etc/sdr/plugins/sdr2.plugin.S100.audio.rtp.mpa.freeamp
-share/gnome/freeamp/themes/Aquatica.fat
-share/gnome/freeamp/themes/EMusic.fat
-share/gnome/freeamp/themes/FreeAmp.fat
-share/gnome/freeamp/themes/FreeAmpClassic.fat
-share/gnome/freeamp/themes/Relatable.fat
-share/gnome/freeamp/themes/Tommy.fat
+%%LIBARTS%%lib/freeamp/plugins/arts.pmo
lib/freeamp/plugins/cd.lmc
lib/freeamp/plugins/cd.pmo
lib/freeamp/plugins/corba.ui
lib/freeamp/plugins/download.ui
+%%ESOUND%%lib/freeamp/plugins/esound.pmo
lib/freeamp/plugins/freeamp.ui
lib/freeamp/plugins/freeampcmd.ui
lib/freeamp/plugins/httpinput.pmi
@@ -34,171 +30,179 @@ lib/freeamp/plugins/vorbis.lmc
lib/freeamp/plugins/vorbis.mdf
lib/freeamp/plugins/wavout.pmo
lib/freeamp/plugins/winamp.ftf
-lib/freeamp/plugins/xingmp3.lmc
lib/freeamp/plugins/winamp_theme.xml
-share/gnome/freeamp/help/getting_help.html
-share/gnome/freeamp/help/keyboard_shortcuts.html
-share/gnome/freeamp/help/adding_items_to_the_bottom_of_the_playlist_queue.html
-share/gnome/freeamp/help/adding_items_to_the_playlist_for_immediate_playback.html
-share/gnome/freeamp/help/adding_music_to_your_music_collection.html
-share/gnome/freeamp/help/adding_tracks_to_a_playlist.html
-share/gnome/freeamp/help/adjusting_the_playback_volume.html
-share/gnome/freeamp/help/appearance_topics.html
-share/gnome/freeamp/help/bw_logo.gif
-share/gnome/freeamp/help/changing_information_about_a_track.html
-share/gnome/freeamp/help/changing_the_order_of_tracks_in_a_playlist.html
-share/gnome/freeamp/help/changing_the_player_theme.html
-share/gnome/freeamp/help/changing_the_tool_view_in_my_music.html
-share/gnome/freeamp/help/clearing_a_playlist.html
-share/gnome/freeamp/help/configuring_player_settings.html
-share/gnome/freeamp/help/configuring_settings_topics.html
-share/gnome/freeamp/help/Copy of configuring_settings_topics.html
-share/gnome/freeamp/help/musicbro.gif
-share/gnome/freeamp/help/creating_a_new_playlist.html
-share/gnome/freeamp/help/creating_and_managing_topics.html
-share/gnome/freeamp/help/creating_and_modifying_topics.html
-share/gnome/freeamp/help/creating_custom_themes.html
-share/gnome/freeamp/help/creating_relatable_playlists.html
-share/gnome/freeamp/help/currentlylisten.gif
-share/gnome/freeamp/help/deleting_an_mp3_file_from_your_computer.html
-share/gnome/freeamp/help/download.gif
-share/gnome/freeamp/help/download_manager.html
-share/gnome/freeamp/help/download_manager_entry.html
-share/gnome/freeamp/help/downloading_mp3_files_from_a_web_site.html
-share/gnome/freeamp/help/drive_selection_entry.html
-share/gnome/freeamp/help/edit_info_entry.html
-share/gnome/freeamp/help/edit_track_info.html
-share/gnome/freeamp/help/editing_the_currently_playing_playlist.html
-share/gnome/freeamp/help/ejecting_audio_cds.html
-share/gnome/freeamp/help/equal.gif
-share/gnome/freeamp/help/files.gif
-share/gnome/freeamp/help/freeampmain_eq.jpg
-share/gnome/freeamp/help/freeampmain_eqclosed.gif
-share/gnome/freeamp/help/freeampmain_eqopen.gif
-share/gnome/freeamp/help/help.html
-share/gnome/freeamp/help/glossary.html
-share/gnome/freeamp/help/help.gif
-share/gnome/freeamp/help/helpstyle.css
-share/gnome/freeamp/help/adding_a_custom_theme.html
-share/gnome/freeamp/help/menu_topics.html
-share/gnome/freeamp/help/min.gif
-share/gnome/freeamp/help/moving_to_the_next_track.html
-share/gnome/freeamp/help/moving_to_the_previous_track.html
-share/gnome/freeamp/help/music_browser_entry.html
-share/gnome/freeamp/help/my_music.html
-share/gnome/freeamp/help/mymusic.gif
-share/gnome/freeamp/help/mymusicfolders.gif
-share/gnome/freeamp/help/nextrack.gif
-share/gnome/freeamp/help/opening_a_playlist.html
-share/gnome/freeamp/help/options.gif
-share/gnome/freeamp/help/overview_topics.html
-share/gnome/freeamp/help/pause.gif
-share/gnome/freeamp/help/pause2.gif
-share/gnome/freeamp/help/pausing_downloading.html
-share/gnome/freeamp/help/pausing_playback.html
-share/gnome/freeamp/help/play.gif
-share/gnome/freeamp/help/playing_audio_cds.html
-share/gnome/freeamp/help/playing_mp3_files.html
-share/gnome/freeamp/help/playing_streams.html
-share/gnome/freeamp/help/playing_topics.html
-share/gnome/freeamp/help/playing_tracks_in_random_order.html
-share/gnome/freeamp/help/postit.gif
-share/gnome/freeamp/help/preferences_about.html
-share/gnome/freeamp/help/preferences_about_entry.html
-share/gnome/freeamp/help/preferences_advanced.html
-share/gnome/freeamp/help/preferences_advanced_entry.html
-share/gnome/freeamp/help/preferences_directory_entry.html
-share/gnome/freeamp/help/preferences_folders.html
-share/gnome/freeamp/help/preferences_general.html
-share/gnome/freeamp/help/preferences_general_entry.html
-share/gnome/freeamp/help/preferences_plugins.html
-share/gnome/freeamp/help/preferences_plugins_entry.html
-share/gnome/freeamp/help/preferences_relatable.html
-share/gnome/freeamp/help/preferences_relatable_entry.html
-share/gnome/freeamp/help/preferences_streaming.html
-share/gnome/freeamp/help/preferences_streaming_entry.html
-share/gnome/freeamp/help/preferences_themes.html
-share/gnome/freeamp/help/preferences_themes_entry.html
-share/gnome/freeamp/help/what_are_relatable_features_entry.html
-share/gnome/freeamp/help/prev_track.gif
-share/gnome/freeamp/help/prevtrack.gif
-share/gnome/freeamp/help/quit.gif
-share/gnome/freeamp/help/random1.gif
-share/gnome/freeamp/help/random2.gif
-share/gnome/freeamp/help/relatable_button.gif
-share/gnome/freeamp/help/relatable_entry.html
-share/gnome/freeamp/help/relatable_eqclosed.gif
-share/gnome/freeamp/help/relatable_equopen.gif
-share/gnome/freeamp/help/relatable_profile.html
-share/gnome/freeamp/help/relatable_streams.html
-share/gnome/freeamp/help/relatable_suggest.gif
-share/gnome/freeamp/help/relatablelogo.gif
-share/gnome/freeamp/help/relatablesig.gif
-share/gnome/freeamp/help/removing_a_playlist_from_your_music_collection.html
-share/gnome/freeamp/help/removing_a_track_from_the_playlist.html
-share/gnome/freeamp/help/removing_a_track_from_your_music_collection.html
-share/gnome/freeamp/help/repeat1.gif
-share/gnome/freeamp/help/repeatall.gif
-share/gnome/freeamp/help/repeating_playback.html
-share/gnome/freeamp/help/repeatno.gif
-share/gnome/freeamp/help/resuming_downloading.html
-share/gnome/freeamp/help/resuming_playback.html
-share/gnome/freeamp/help/saving_a_playlist.html
-share/gnome/freeamp/help/saving_a_stream_on_your_computer.html
-share/gnome/freeamp/help/scroll.gif
-share/gnome/freeamp/help/search_computer_for_music.html
-share/gnome/freeamp/help/searching_for_music_on_your_computer.html
-share/gnome/freeamp/help/seeking_in_the_current_track.html
-share/gnome/freeamp/help/setting_file_associations_or_mime_types.html
-share/gnome/freeamp/help/setting_the_default_playlist_queue_option.html
-share/gnome/freeamp/help/setting_the_folder_location_to_save_your_music.html
-share/gnome/freeamp/help/Shortcut to preferences_advanced.html.lnk
-share/gnome/freeamp/help/stop.gif
-share/gnome/freeamp/help/spacetravel.gif
-share/gnome/freeamp/help/sorting_tracks_in_the_playlist.html
-share/gnome/freeamp/help/spacetravel_ret.gif
-share/gnome/freeamp/help/spacetraveleq.gif
-share/gnome/freeamp/help/spacetraveleq_ret.gif
-share/gnome/freeamp/help/spacetravelmed.gif
-share/gnome/freeamp/help/spacetravelsm.gif
-share/gnome/freeamp/help/stopping_playback.html
-share/gnome/freeamp/help/streaming_topics.html
-share/gnome/freeamp/help/taddfiles.gif
-share/gnome/freeamp/help/tadditems.gif
-share/gnome/freeamp/help/technical_support.html
-share/gnome/freeamp/help/teditinfo.gif
-share/gnome/freeamp/help/the_page_could_not_be_found.html
-share/gnome/freeamp/help/timportitems.gif
-share/gnome/freeamp/help/tnewplaylist.gif
-share/gnome/freeamp/help/tremoveitems.gif
-share/gnome/freeamp/help/tsaveplaylist.gif
-share/gnome/freeamp/help/update_topics.html
-share/gnome/freeamp/help/updating_the_player.html
-share/gnome/freeamp/help/view.gif
-share/gnome/freeamp/help/viewing_id3_topics.html
-share/gnome/freeamp/help/viewing_the_track_duration.html
-share/gnome/freeamp/help/viewing_the_track_name.html
-share/gnome/freeamp/help/volume.gif
-share/gnome/freeamp/help/what_are_id3_tags.html
-share/gnome/freeamp/help/what_are_relatable_features.html
-share/gnome/freeamp/help/what_are_themes.html
-share/gnome/freeamp/help/what_is_a_playlist.html
-share/gnome/freeamp/help/what_is_my_music.html
-share/gnome/freeamp/help/what_is_streaming.html
-share/gnome/freeamp/help/what_is_the_player.html
-share/gnome/freeamp/help/what_kind_of_mp3_files_can_i_play.html
-share/gnome/freeamp/help/working_with_the_my_music_collection_folders.html
-share/gnome/freeamp/help/main_window.html
-share/gnome/freeamp/help/contents.html
-share/gnome/freeamp/help/preferences_musicbrowser.html
-share/gnome/freeamp/help/preferences_musicbrowser_entry.html
-share/gnome/freeamp/help/setting_the_playlist_display_information.html
-share/gnome/freeamp/help/freeampmain_eq.gif
-share/gnome/freeamp/help/what_are_bitzi_features.html
-share/gnome/freeamp/help/preferences_musicbrainz.html
-share/gnome/freeamp/help/bitzilogo.gif
-@dirrm share/gnome/freeamp/help
-@dirrm share/gnome/freeamp/themes
-@dirrm share/gnome/freeamp
+lib/freeamp/plugins/xingmp3.lmc
+share/freeamp/help/Copy of configuring_settings_topics.html
+share/freeamp/help/Shortcut to preferences_advanced.html.lnk
+share/freeamp/help/adding_a_custom_theme.html
+share/freeamp/help/adding_items_to_the_bottom_of_the_playlist_queue.html
+share/freeamp/help/adding_items_to_the_playlist_for_immediate_playback.html
+share/freeamp/help/adding_music_to_your_music_collection.html
+share/freeamp/help/adding_tracks_to_a_playlist.html
+share/freeamp/help/adjusting_the_playback_volume.html
+share/freeamp/help/appearance_topics.html
+share/freeamp/help/bitzilogo.gif
+share/freeamp/help/bw_logo.gif
+share/freeamp/help/changing_information_about_a_track.html
+share/freeamp/help/changing_the_order_of_tracks_in_a_playlist.html
+share/freeamp/help/changing_the_player_theme.html
+share/freeamp/help/changing_the_tool_view_in_my_music.html
+share/freeamp/help/clearing_a_playlist.html
+share/freeamp/help/configuring_player_settings.html
+share/freeamp/help/configuring_settings_topics.html
+share/freeamp/help/contents.html
+share/freeamp/help/creating_a_new_playlist.html
+share/freeamp/help/creating_and_managing_topics.html
+share/freeamp/help/creating_and_modifying_topics.html
+share/freeamp/help/creating_custom_themes.html
+share/freeamp/help/creating_relatable_playlists.html
+share/freeamp/help/currentlylisten.gif
+share/freeamp/help/deleting_an_mp3_file_from_your_computer.html
+share/freeamp/help/download.gif
+share/freeamp/help/download_manager.html
+share/freeamp/help/download_manager_entry.html
+share/freeamp/help/downloading_mp3_files_from_a_web_site.html
+share/freeamp/help/drive_selection_entry.html
+share/freeamp/help/edit_info_entry.html
+share/freeamp/help/edit_track_info.html
+share/freeamp/help/editing_the_currently_playing_playlist.html
+share/freeamp/help/ejecting_audio_cds.html
+share/freeamp/help/equal.gif
+share/freeamp/help/files.gif
+share/freeamp/help/freeampmain_eq.gif
+share/freeamp/help/freeampmain_eq.jpg
+share/freeamp/help/freeampmain_eqclosed.gif
+share/freeamp/help/freeampmain_eqopen.gif
+share/freeamp/help/getting_help.html
+share/freeamp/help/glossary.html
+share/freeamp/help/help.gif
+share/freeamp/help/help.html
+share/freeamp/help/helpstyle.css
+share/freeamp/help/keyboard_shortcuts.html
+share/freeamp/help/main_window.html
+share/freeamp/help/menu_topics.html
+share/freeamp/help/min.gif
+share/freeamp/help/moving_to_the_next_track.html
+share/freeamp/help/moving_to_the_previous_track.html
+share/freeamp/help/music_browser_entry.html
+share/freeamp/help/musicbro.gif
+share/freeamp/help/my_music.html
+share/freeamp/help/mymusic.gif
+share/freeamp/help/mymusicfolders.gif
+share/freeamp/help/nextrack.gif
+share/freeamp/help/opening_a_playlist.html
+share/freeamp/help/options.gif
+share/freeamp/help/overview_topics.html
+share/freeamp/help/pause.gif
+share/freeamp/help/pause2.gif
+share/freeamp/help/pausing_downloading.html
+share/freeamp/help/pausing_playback.html
+share/freeamp/help/play.gif
+share/freeamp/help/playing_audio_cds.html
+share/freeamp/help/playing_mp3_files.html
+share/freeamp/help/playing_streams.html
+share/freeamp/help/playing_topics.html
+share/freeamp/help/playing_tracks_in_random_order.html
+share/freeamp/help/postit.gif
+share/freeamp/help/preferences_about.html
+share/freeamp/help/preferences_about_entry.html
+share/freeamp/help/preferences_advanced.html
+share/freeamp/help/preferences_advanced_entry.html
+share/freeamp/help/preferences_directory_entry.html
+share/freeamp/help/preferences_folders.html
+share/freeamp/help/preferences_general.html
+share/freeamp/help/preferences_general_entry.html
+share/freeamp/help/preferences_musicbrainz.html
+share/freeamp/help/preferences_musicbrowser.html
+share/freeamp/help/preferences_musicbrowser_entry.html
+share/freeamp/help/preferences_plugins.html
+share/freeamp/help/preferences_plugins_entry.html
+share/freeamp/help/preferences_relatable.html
+share/freeamp/help/preferences_relatable_entry.html
+share/freeamp/help/preferences_streaming.html
+share/freeamp/help/preferences_streaming_entry.html
+share/freeamp/help/preferences_themes.html
+share/freeamp/help/preferences_themes_entry.html
+share/freeamp/help/prev_track.gif
+share/freeamp/help/prevtrack.gif
+share/freeamp/help/quit.gif
+share/freeamp/help/random1.gif
+share/freeamp/help/random2.gif
+share/freeamp/help/relatable_button.gif
+share/freeamp/help/relatable_entry.html
+share/freeamp/help/relatable_eqclosed.gif
+share/freeamp/help/relatable_equopen.gif
+share/freeamp/help/relatable_profile.html
+share/freeamp/help/relatable_streams.html
+share/freeamp/help/relatable_suggest.gif
+share/freeamp/help/relatablelogo.gif
+share/freeamp/help/relatablesig.gif
+share/freeamp/help/removing_a_playlist_from_your_music_collection.html
+share/freeamp/help/removing_a_track_from_the_playlist.html
+share/freeamp/help/removing_a_track_from_your_music_collection.html
+share/freeamp/help/repeat1.gif
+share/freeamp/help/repeatall.gif
+share/freeamp/help/repeating_playback.html
+share/freeamp/help/repeatno.gif
+share/freeamp/help/resuming_downloading.html
+share/freeamp/help/resuming_playback.html
+share/freeamp/help/saving_a_playlist.html
+share/freeamp/help/saving_a_stream_on_your_computer.html
+share/freeamp/help/scroll.gif
+share/freeamp/help/search_computer_for_music.html
+share/freeamp/help/searching_for_music_on_your_computer.html
+share/freeamp/help/seeking_in_the_current_track.html
+share/freeamp/help/setting_file_associations_or_mime_types.html
+share/freeamp/help/setting_the_default_playlist_queue_option.html
+share/freeamp/help/setting_the_folder_location_to_save_your_music.html
+share/freeamp/help/setting_the_playlist_display_information.html
+share/freeamp/help/sorting_tracks_in_the_playlist.html
+share/freeamp/help/spacetravel.gif
+share/freeamp/help/spacetravel_ret.gif
+share/freeamp/help/spacetraveleq.gif
+share/freeamp/help/spacetraveleq_ret.gif
+share/freeamp/help/spacetravelmed.gif
+share/freeamp/help/spacetravelsm.gif
+share/freeamp/help/stop.gif
+share/freeamp/help/stopping_playback.html
+share/freeamp/help/streaming_topics.html
+share/freeamp/help/taddfiles.gif
+share/freeamp/help/tadditems.gif
+share/freeamp/help/technical_support.html
+share/freeamp/help/teditinfo.gif
+share/freeamp/help/the_page_could_not_be_found.html
+share/freeamp/help/timportitems.gif
+share/freeamp/help/tnewplaylist.gif
+share/freeamp/help/tremoveitems.gif
+share/freeamp/help/tsaveplaylist.gif
+share/freeamp/help/update_topics.html
+share/freeamp/help/updating_the_player.html
+share/freeamp/help/view.gif
+share/freeamp/help/viewing_id3_topics.html
+share/freeamp/help/viewing_the_track_duration.html
+share/freeamp/help/viewing_the_track_name.html
+share/freeamp/help/volume.gif
+share/freeamp/help/what_are_bitzi_features.html
+share/freeamp/help/what_are_id3_tags.html
+share/freeamp/help/what_are_relatable_features.html
+share/freeamp/help/what_are_relatable_features_entry.html
+share/freeamp/help/what_are_themes.html
+share/freeamp/help/what_is_a_playlist.html
+share/freeamp/help/what_is_my_music.html
+share/freeamp/help/what_is_streaming.html
+share/freeamp/help/what_is_the_player.html
+share/freeamp/help/what_kind_of_mp3_files_can_i_play.html
+share/freeamp/help/working_with_the_my_music_collection_folders.html
+share/freeamp/themes/Aquatica.fat
+share/freeamp/themes/EMusic.fat
+share/freeamp/themes/FreeAmp.fat
+share/freeamp/themes/FreeAmpClassic.fat
+share/freeamp/themes/Relatable.fat
+share/freeamp/themes/Tommy.fat
+@dirrm share/freeamp/themes
+@dirrm share/freeamp/help
+@dirrm share/freeamp
@dirrm lib/freeamp/plugins
@dirrm lib/freeamp
+@unexec rmdir %D/etc/sdr/plugins 2>/dev/null || true
+@unexec rmdir %D/etc/sdr 2&>/dev/null || true