aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-03-06 22:55:59 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-03-06 22:55:59 +0000
commit504ec80031ee09a340288ae155a00c5941fb4254 (patch)
tree9fd5cfaa1ce40d4abb621f79e72e0f862fbdc953 /audio
parent6e24ca6748a783308c4b62613218ac5d911af015 (diff)
Tomahawk is a music player that fundamentally changes the way music is
consumed and shared. It decouples the name of the song from the source it was shared from - and fulfills the request using all of your available sources. This creates a universal translation layer across music repositories, streaming services and geographic territories. WWW: http://www.tomahawk-player.org/
Notes
Notes: svn path=/head/; revision=313554
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/tomahawk/Makefile61
-rw-r--r--audio/tomahawk/distinfo2
-rw-r--r--audio/tomahawk/files/patch-src__libtomahawk__Source.cpp11
-rw-r--r--audio/tomahawk/files/patch-src__main.cpp13
-rw-r--r--audio/tomahawk/pkg-descr10
-rw-r--r--audio/tomahawk/pkg-plist33
7 files changed, 131 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index bc309b770316..37e04edb9738 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -763,6 +763,7 @@
SUBDIR += timidity++-tcltk
SUBDIR += timidity++-xaw
SUBDIR += timidity++-xskin
+ SUBDIR += tomahawk
SUBDIR += toolame
SUBDIR += tosha
SUBDIR += tracker
diff --git a/audio/tomahawk/Makefile b/audio/tomahawk/Makefile
new file mode 100644
index 000000000000..0c3cc96e96a8
--- /dev/null
+++ b/audio/tomahawk/Makefile
@@ -0,0 +1,61 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tomahawk
+PORTVERSION= 0.6.0
+#PORTREVISION= 0
+CATEGORIES= audio
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Multi-source, social, and smart music player
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= clucene>=2.3.3.4:${PORTSDIR}/textproc/clucene
+LIB_DEPENDS= attica:${PORTSDIR}/x11-toolkits/attica \
+ boost_thread:${PORTSDIR}/devel/boost-libs \
+ echonest:${PORTSDIR}/audio/libechonest \
+ jreen:${PORTSDIR}/net-im/jreen \
+ lastfm:${PORTSDIR}/audio/liblastfm \
+ qca:${PORTSDIR}/devel/qca \
+ qjson:${PORTSDIR}/devel/qjson \
+ quazip:${PORTSDIR}/archivers/quazip \
+ tag:${PORTSDIR}/audio/taglib
+RUN_DEPENDS= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc \
+ phonon-gstreamer>=4.6.3:${PORTSDIR}/multimedia/phonon-gstreamer \
+ qca-ossl>=2.0.0.b3_4:${PORTSDIR}/security/qca-ossl
+
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING="Release" \
+ -DCMAKE_COLOR_MAKEFILE:BOOL="OFF" \
+ -DWITH_BREAKPAD:BOOL="OFF" \
+ -DWITH_BUILD:STRING="Release"
+
+GH_ACCOUNT= tomahawk-player
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${DISTVERSION}
+GH_COMMIT= 2b8cc4f
+
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= QTWEETLIB
+OPTIONS_DEFAULT= QTWEETLIB
+QTWEETLIB_DESC= Enable Twitter SIP plugin
+
+USE_CMAKE= yes
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+
+USE_QT4= dbus designer gui linguist_build moc_build \
+ network phonon qmake_build qtestlib rcc_build \
+ sql-sqlite2 svg uic_build xml
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQTWEETLIB}
+LIB_DEPENDS+= QTweetLib:${PORTSDIR}/net/qtweetlib
+.else
+CMAKE_ARGS+= -DWITH_QTweetLib:BOOL="OFF"
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/tomahawk/distinfo b/audio/tomahawk/distinfo
new file mode 100644
index 000000000000..7f51ef1855ce
--- /dev/null
+++ b/audio/tomahawk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tomahawk-0.6.0.tar.gz) = 62a4921ba876f192a6c46e800a3e3f874da276a9815fcbcb8f24cbb020e44ae2
+SIZE (tomahawk-0.6.0.tar.gz) = 6470677
diff --git a/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp b/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp
new file mode 100644
index 000000000000..86f18dc1512c
--- /dev/null
+++ b/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp
@@ -0,0 +1,11 @@
+--- ./src/libtomahawk/Source.cpp.orig 2013-02-13 21:31:17.000000000 +0100
++++ ./src/libtomahawk/Source.cpp 2013-02-13 21:32:00.000000000 +0100
+@@ -148,7 +148,7 @@
+ m_avatar = new QPixmap( avatar );
+ m_fancyAvatar = 0;
+
+- TomahawkUtils::Cache::instance()->putData( "Sources", 7776000000 /* 90 days */, m_username, ba );
++ TomahawkUtils::Cache::instance()->putData( "Sources", Q_INT64_C(7776000000) /* 90 days */, m_username, ba );
+ m_avatarUpdated = true;
+ }
+
diff --git a/audio/tomahawk/files/patch-src__main.cpp b/audio/tomahawk/files/patch-src__main.cpp
new file mode 100644
index 000000000000..15132377717e
--- /dev/null
+++ b/audio/tomahawk/files/patch-src__main.cpp
@@ -0,0 +1,13 @@
+--- ./src/main.cpp.orig 2013-02-13 21:57:24.000000000 +0100
++++ ./src/main.cpp 2013-02-13 21:57:46.000000000 +0100
+@@ -34,8 +34,10 @@
+
+ #ifndef ENABLE_HEADLESS
+ #include "TomahawkSettingsGui.h"
++#ifdef WITH_BREAKPAD
+ #include "breakpad/BreakPad.h"
+ #endif
++#endif
+
+
+ #ifdef Q_OS_WIN
diff --git a/audio/tomahawk/pkg-descr b/audio/tomahawk/pkg-descr
new file mode 100644
index 000000000000..8594ccd4a7dc
--- /dev/null
+++ b/audio/tomahawk/pkg-descr
@@ -0,0 +1,10 @@
+Tomahawk is a music player that fundamentally changes the way music is
+consumed and shared.
+
+It decouples the name of the song from the source it was shared from - and
+fulfills the request using all of your available sources.
+
+This creates a universal translation layer across music repositories,
+streaming services and geographic territories.
+
+WWW: http://www.tomahawk-player.org/
diff --git a/audio/tomahawk/pkg-plist b/audio/tomahawk/pkg-plist
new file mode 100644
index 000000000000..f8b39ba8a7a8
--- /dev/null
+++ b/audio/tomahawk/pkg-plist
@@ -0,0 +1,33 @@
+@comment $FreeBSD$
+bin/tomahawk
+lib/libtomahawk_account_google.so
+lib/libtomahawk_account_twitter.so
+lib/libtomahawk_account_xmpp.so
+lib/libtomahawk_account_zeroconf.so
+lib/libtomahawk_infoplugin_charts.so
+lib/libtomahawk_infoplugin_discogs.so
+lib/libtomahawk_infoplugin_echonest.so
+lib/libtomahawk_infoplugin_fdonotify.so
+lib/libtomahawk_infoplugin_hypem.so
+lib/libtomahawk_infoplugin_mpris.so
+lib/libtomahawk_infoplugin_musicbrainz.so
+lib/libtomahawk_infoplugin_musixmatch.so
+lib/libtomahawk_infoplugin_newreleases.so
+lib/libtomahawk_infoplugin_rovi.so
+lib/libtomahawk_infoplugin_spotify.so
+lib/libtomahawk_portfwd.so
+lib/libtomahawklib.so
+libexec/tomahawk_crash_reporter
+share/applications/tomahawk.desktop
+share/icons/hicolor/128x128-grayscale/apps/tomahawk.png
+share/icons/hicolor/128x128/apps/tomahawk.png
+share/icons/hicolor/16x16/apps/tomahawk.png
+share/icons/hicolor/256x256/apps/tomahawk.png
+share/icons/hicolor/32x32/apps/tomahawk.png
+share/icons/hicolor/512x512/apps/tomahawk.png
+share/icons/hicolor/64x64/apps/tomahawk.png
+share/icons/hicolor/scalable/apps/tomahawk.svg
+@dirrmtry share/icons/hicolor/128x128-grayscale/apps
+@dirrmtry share/icons/hicolor/128x128-grayscale
+@dirrmtry share/icons/hicolor/512x512/apps
+@dirrmtry share/icons/hicolor/512x512