aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-11-13 21:36:36 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-11-13 21:36:36 +0000
commit526f1dd967165b631fd0533f8691c291c094e4a8 (patch)
treefb6355850dc79612ab70641cc8c03117bd1ab75e /audio
parent643a708b8207ff6cf1b5fa16a9b057fefeed89ef (diff)
downloadports-526f1dd967165b631fd0533f8691c291c094e4a8.tar.gz
ports-526f1dd967165b631fd0533f8691c291c094e4a8.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/sdl2_mixer/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/audio/sdl2_mixer/Makefile b/audio/sdl2_mixer/Makefile
index b6221e145a38..0dc04131eb46 100644
--- a/audio/sdl2_mixer/Makefile
+++ b/audio/sdl2_mixer/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sdl2_mixer
PORTVERSION= 2.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL2_mixer-${PORTVERSION}
@@ -19,8 +19,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= yes
-OPTIONS_DEFINE= FLUIDSYNTH FLAC VORBIS
-OPTIONS_DEFAULT= FLUIDSYNTH MODPLUG FLAC VORBIS
+OPTIONS_DEFINE= FLUIDSYNTH FLAC SMPEG VORBIS
+OPTIONS_DEFAULT= FLUIDSYNTH MODPLUG FLAC SMPEG VORBIS
OPTIONS_RADIO= MOD
OPTIONS_RADIO_MOD= MIKMOD MODPLUG
@@ -28,6 +28,7 @@ FLUIDSYNTH_DESC= Enable SoundFont2 Midi support via fluidsynth
MIKMOD_DESC= Enable MOD music via libMikMod
MODPLUG_DESC= Enable MOD music via libModPlug
FLAC_DESC= Enable FLAC encoding support via flac
+SMPEG_DESC= Enable MP3 music via SMPEG2
VORBIS_DESC= Enable Ogg Vorbis music
MIKMOD_LIB_DEPENDS= libmikmod.so:${PORTSDIR}/audio/libmikmod
@@ -43,6 +44,10 @@ FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth
FLUIDSYNTH_CONFIGURE_ON= --enable-music-midi --enable-music-midi-fluidsynth
FLUIDSYNTH_CONFIGURE_OFF= --disable-music-midi --disable-music-midi-fluidsynth
+SMPEG_LIB_DEPENDS= libsmpeg2.so:${PORTSDIR}/multimedia/smpeg2
+SMPEG_CONFIGURE_ON= --enable-music-mp3 --enable-music-mp3-smpeg
+SMPEG_CONFIGURE_OFF= --disable-music-mp3 --disable-music-mp3-smpeg
+
VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
VORBIS_CONFIGURE_ENABLE= music-ogg