aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-12-30 17:57:04 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-12-30 17:57:04 +0000
commit6ee31886c911678177a10c557fb2840d9ba0b523 (patch)
tree2f9548d7bf4165d372787d883bcf8215757bf1fd /audio
parent59ca196eee2e4df784fdb535740747b8cf800435 (diff)
downloadports-6ee31886c911678177a10c557fb2840d9ba0b523.tar.gz
ports-6ee31886c911678177a10c557fb2840d9ba0b523.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/portaudio/Makefile74
-rw-r--r--audio/portaudio/files/patch-pa_tests-patest__record.c (renamed from audio/portaudio/files/patch-pa_tests::patest_record.c)4
-rw-r--r--audio/portaudio/files/patch-pa_tests-patest__wire.c (renamed from audio/portaudio/files/patch-pa_tests::patest_wire.c)4
-rw-r--r--audio/portaudio/pkg-descr17
-rw-r--r--audio/portaudio/pkg-plist46
5 files changed, 79 insertions, 66 deletions
diff --git a/audio/portaudio/Makefile b/audio/portaudio/Makefile
index f5d32b863020..8fa93678a148 100644
--- a/audio/portaudio/Makefile
+++ b/audio/portaudio/Makefile
@@ -1,62 +1,72 @@
-# New ports collection makefile for: portaudio
-# Date created: 18 May 2003
-# Whom: michaelnottebrock@gmx.net and lioux@FreeBSD.org
-#
+# Created by: michaelnottebrock@gmx.net and lioux@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= portaudio
PORTVERSION= 18.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www.portaudio.com/archives/
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/./_/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Portable cross-platform Audio API
+LICENSE= MIT
+
USE_ZIP= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_DOS2UNIX= yes
USE_LDCONFIG= yes
-USE_DOS2UNIX= yes
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_CFLAGS}
PLIST_SUB+= SHLIB_VERSION=${SHLIB_VERSION}
SHLIB_VERSION= 0
-pre-everything::
-.if !defined(WITH_PATESTS)
- @${ECHO_MSG}
- @${ECHO_MSG} "You can additionally build portaudio's testsuite by defining WITH_PATESTS."
- @${ECHO_MSG}
-PLIST_SUB+= WITH_PATESTS="@comment "
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= README.txt index.html
+
+DOCSRCDIR2= ${WRKSRC}/docs
+DOCSDIR2= ${DOCSDIR}/docs
+DOC_FILES2= *.html *.txt *.pdf
+
+OPTIONS_DEFINE= PATEST
+OPTIONS_DEFAULT= PATEST
+
+PATEST_DESC= PortAudio Test Programs
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPATEST}
+PLIST_SUB+= PATEST=""
.else
-PLIST_SUB+= WITH_PATESTS=""
+PLIST_SUB+= PATEST="@comment "
.endif
post-patch:
-# replace obsolete headers, and fix up thread library
- @${FIND} ${WRKSRC} -type f \
- | ${XARGS} -x -n 10 \
- ${REINPLACE_CMD} -E \
- -e 's|malloc.h|stdlib.h|' \
- -e 's|machine\/soundcard.h|sys\/soundcard.h|' \
- -e 's|-lpthread|${PTHREAD_LIBS}|'
+ @${REINPLACE_CMD} -e 's|#include <malloc.h>|#include <stdlib.h>|' ${WRKSRC}/pa_unix_oss/pa_unix.h
+ @${REINPLACE_CMD} -e 's|machine/soundcard.h|sys/soundcard.h|' ${WRKSRC}/pa_unix_oss/pa_unix_oss.c
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure ${WRKSRC}/configure.in \
+ ${WRKSRC}/pa_unix_oss/Makefile
+
pre-configure:
-# Make configure executable
@${CHMOD} +x ${WRKSRC}/configure
-.if !defined(WITH_PATESTS)
-post-configure:
- @${REINPLACE_CMD} -e 's|tests$$||' ${WRKSRC}/Makefile
-.endif
-
post-install:
-.if defined(WITH_PATESTS)
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
-.endif
@${LN} -sf libportaudio.so \
${PREFIX}/lib/libportaudio.so.${SHLIB_VERSION}
+.if ${PORT_OPTIONS:MPATEST}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${PREFIX}/bin
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
+.endif
.include <bsd.port.mk>
diff --git a/audio/portaudio/files/patch-pa_tests::patest_record.c b/audio/portaudio/files/patch-pa_tests-patest__record.c
index e24e9f28ed52..e462fc9a8c6a 100644
--- a/audio/portaudio/files/patch-pa_tests::patest_record.c
+++ b/audio/portaudio/files/patch-pa_tests-patest__record.c
@@ -1,5 +1,5 @@
---- pa_tests/patest_record.c.orig Sun Dec 7 14:48:31 2003
-+++ pa_tests/patest_record.c Sun Dec 7 14:48:53 2003
+--- pa_tests/patest_record.c.orig 2012-12-22 13:48:25.000000000 +0100
++++ pa_tests/patest_record.c 2012-12-22 13:48:25.000000000 +0100
@@ -138,10 +138,10 @@
SAMPLE *wptr = (SAMPLE*)outputBuffer;
unsigned int i;
diff --git a/audio/portaudio/files/patch-pa_tests::patest_wire.c b/audio/portaudio/files/patch-pa_tests-patest__wire.c
index 0f158d80fb41..e9f3d5dbcf43 100644
--- a/audio/portaudio/files/patch-pa_tests::patest_wire.c
+++ b/audio/portaudio/files/patch-pa_tests-patest__wire.c
@@ -1,5 +1,5 @@
---- pa_tests/patest_wire.c.orig Sun Dec 7 14:49:15 2003
-+++ pa_tests/patest_wire.c Sun Dec 7 14:49:52 2003
+--- pa_tests/patest_wire.c.orig 2012-12-22 13:48:25.000000000 +0100
++++ pa_tests/patest_wire.c 2012-12-22 13:48:25.000000000 +0100
@@ -74,9 +74,9 @@
SAMPLE *out = (SAMPLE*)outputBuffer;
SAMPLE *in = (SAMPLE*)inputBuffer;
diff --git a/audio/portaudio/pkg-descr b/audio/portaudio/pkg-descr
index 50e3e30dc13f..e7271f667ece 100644
--- a/audio/portaudio/pkg-descr
+++ b/audio/portaudio/pkg-descr
@@ -1,9 +1,12 @@
-PortAudio is a free, cross platform, open-source, audio I/O library.
-It lets you write simple audio programs in 'C' that will compile
-and run on many platforms including Windows, Macintosh (8,9,X),
-Unix (OSS), SGI, and BeOS. PortAudio is intended to promote the
-exchange of audio synthesis software between developers on different
-platforms, and was recently selected as the audio component of a
-larger PortMusic project that includes MIDI and sound file support.
+PortAudio is a free, cross-platform, open-source, audio I/O library.
+It lets you write simple audio programs in 'C' or C++ that will compile and run
+on many platforms including Windows, Macintosh OS X, and Unix (OSS/ALSA).
+It is intended to promote the exchange of audio software between developers
+on different platforms. Many applications use PortAudio for Audio I/O.
+
+PortAudio provides a very simple API for recording and/or playing sound using
+a simple callback function or a blocking read/write interface.
+Example programs are included that play sine waves, process audio input
+(guitar fuzz), record and playback audio, list available audio devices, etc.
WWW: http://www.portaudio.com/
diff --git a/audio/portaudio/pkg-plist b/audio/portaudio/pkg-plist
index 0b42b5cf9c38..a8a0c5b9c597 100644
--- a/audio/portaudio/pkg-plist
+++ b/audio/portaudio/pkg-plist
@@ -1,26 +1,26 @@
-%%WITH_PATESTS%%bin/patest_buffer
-%%WITH_PATESTS%%bin/patest_clip
-%%WITH_PATESTS%%bin/patest_dither
-%%WITH_PATESTS%%bin/patest_hang
-%%WITH_PATESTS%%bin/patest_latency
-%%WITH_PATESTS%%bin/patest_leftright
-%%WITH_PATESTS%%bin/patest_longsine
-%%WITH_PATESTS%%bin/patest_many
-%%WITH_PATESTS%%bin/patest_maxsines
-%%WITH_PATESTS%%bin/patest_multi_sine
-%%WITH_PATESTS%%bin/patest_pink
-%%WITH_PATESTS%%bin/patest_record
-%%WITH_PATESTS%%bin/patest_ringmix
-%%WITH_PATESTS%%bin/patest_saw
-%%WITH_PATESTS%%bin/patest_sine
-%%WITH_PATESTS%%bin/patest_sine8
-%%WITH_PATESTS%%bin/patest_sine_formats
-%%WITH_PATESTS%%bin/patest_sine_time
-%%WITH_PATESTS%%bin/patest_stop
-%%WITH_PATESTS%%bin/patest_sync
-%%WITH_PATESTS%%bin/patest_toomanysines
-%%WITH_PATESTS%%bin/patest_underflow
-%%WITH_PATESTS%%bin/patest_wire
+%%PATEST%%bin/patest_buffer
+%%PATEST%%bin/patest_clip
+%%PATEST%%bin/patest_dither
+%%PATEST%%bin/patest_hang
+%%PATEST%%bin/patest_latency
+%%PATEST%%bin/patest_leftright
+%%PATEST%%bin/patest_longsine
+%%PATEST%%bin/patest_many
+%%PATEST%%bin/patest_maxsines
+%%PATEST%%bin/patest_multi_sine
+%%PATEST%%bin/patest_pink
+%%PATEST%%bin/patest_record
+%%PATEST%%bin/patest_ringmix
+%%PATEST%%bin/patest_saw
+%%PATEST%%bin/patest_sine
+%%PATEST%%bin/patest_sine8
+%%PATEST%%bin/patest_sine_formats
+%%PATEST%%bin/patest_sine_time
+%%PATEST%%bin/patest_stop
+%%PATEST%%bin/patest_sync
+%%PATEST%%bin/patest_toomanysines
+%%PATEST%%bin/patest_underflow
+%%PATEST%%bin/patest_wire
include/portaudio.h
lib/libportaudio.a
lib/libportaudio.so