aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-08-10 06:44:43 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-08-10 06:44:43 +0000
commitb98592c11533d4b1faaa588501cc3dcb95b31408 (patch)
tree957d33b6420157ae2942113e0d9f9af7c988e6b9 /audio
parentce1f6608f852128aa0344f5c20f7b4e4585e3dbe (diff)
Set USE_GCC=2.95 to fix build on 5.x. Mark musicbox and icqnix as BROKEN
on 5.x machines (compile and configure failure, respectively). PR: 52731 Submitted by: trevor
Notes
Notes: svn path=/head/; revision=86702
Diffstat (limited to 'audio')
-rw-r--r--audio/musicbox/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/musicbox/Makefile b/audio/musicbox/Makefile
index d3523eb8d527..8afbd3107743 100644
--- a/audio/musicbox/Makefile
+++ b/audio/musicbox/Makefile
@@ -18,6 +18,7 @@ COMMENT= X11 front-end for mpg123
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
+USE_GCC= 2.95
USE_QT_VER= 1
DOCS= ChangeLog README
EVAL_PREFIX+= QT1DIR=qt1
@@ -26,6 +27,12 @@ PLIST= ${WRKDIR}/pkg-plist
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/musicbox-1.01
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501013
+BROKEN= "compilation error"
+.endif
+
pre-install:
${ECHO_CMD} bin/musicbox > ${PLIST}
.if !defined(NOPORTDOCS)
@@ -44,4 +51,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>