aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-24 22:07:58 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-24 22:07:58 +0000
commitbf661166e1db4cba4e6e0fb4494b998ba4d94248 (patch)
tree1e8e05efce243030e5d652e565db891803d0a1ce /audio
parent9881b0413ba28b30cd87a00993636ae4e3b908f5 (diff)
downloadports-bf661166e1db4cba4e6e0fb4494b998ba4d94248.tar.gz
ports-bf661166e1db4cba4e6e0fb4494b998ba4d94248.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms2/Makefile2
-rw-r--r--audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx12
2 files changed, 13 insertions, 1 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index d0566aca4299..b701d10e8de0 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmms2
PORTVERSION= 0.2.d.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx b/audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx
new file mode 100644
index 000000000000..30fc647a8ad7
--- /dev/null
+++ b/audio/xmms2/files/patch-src_clients_lib_python_xmmsclient.pyx
@@ -0,0 +1,12 @@
+--- src/clients/lib/python/xmmsclient.pyx.orig Tue May 23 01:02:46 2006
++++ src/clients/lib/python/xmmsclient.pyx Tue May 23 01:03:14 2006
+@@ -273,7 +273,8 @@
+ if k[1] == item:
+ return v
+ try:
+- return dict.__getitem__(self, (src, item))
++ x = dict.__getitem__(self, (src, item))
++ return x
+ except KeyError:
+ pass
+ raise KeyError, item