aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-06-09 10:59:46 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-06-09 10:59:46 +0000
commit70c73d6b0a25413dffaef8c4cdac447a3541cfb9 (patch)
treee8759fc3182443e2c1e81c76fdb8451ff018c7ed /audio
parentc8b2a18d150b9d1a3827b0c09810405c23bf3e48 (diff)
downloadports-70c73d6b0a25413dffaef8c4cdac447a3541cfb9.tar.gz
ports-70c73d6b0a25413dffaef8c4cdac447a3541cfb9.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms2/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 500ef0945cef..e76befa252e6 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -30,10 +30,12 @@ PLIST_SUB+= INCLUDEDIR="include/${PORTNAME}" LIBDIR="lib/${PORTNAME}"
CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= AIRPLAY AO APE AVCODEC CDDA CURL ET FAAD FAM FLAC \
- GME GVFS ICES JACK MAD MDNS_APPLE MDNS_AVAHI MMS \
+ GME GVFS ICES JACK MAD MDNS MMS \
MODPLUG MPG123 MUSEPACK OFA PULSEAUDIO SAMBA SID \
SNDFILE SPEEX TREMOR VISUAL VOCODER VORBIS WAVPACK XML
-OPTIONS_DEFAULT= CURL FAAD FLAC MAD MDNS_APPLE VORBIS
+OPTIONS_SINGLE= MDNS
+OPTIONS_SINGLE_MDNS= MDNS_APPLE MDNS_AVAHI
+OPTIONS_DEFAULT= CURL FAAD FLAC MAD MDNS MDNS_APPLE VORBIS
AIRPLAY_DESC= Support output via Airport Express
APE_DESC= Support to playback Monkey's Audio files
@@ -47,8 +49,9 @@ GME_DESC= Support to playback video game music files
GVFS_DESC= Support to playback files via GVFS
ICES_DESC= Support to playback files to an icecast server
MAD_DESC= Support to playback MP3 files
-MDNS_APPLE_DESC= Support to announce XMMS2d via mDNS (Apple)
-MDNS_AVAHI_DESC= Support to announce XMMS2d via mDNS (Avahi)
+MDNS_DESC= Support to announce XMMS2d via mDNS (Choose implementation)
+MDNS_APPLE_DESC= Use Apple mDNS implementation
+MDNS_AVAHI_DESC= Use Avahi mDNS implementation
MMS_DESC= Support to playback streams via MMS
MPG123_DESC= Support to playback MP3 files
OFA_DESC= Support to collect MusicDNS fingerprints
@@ -208,9 +211,7 @@ EXCLUDE+= --without-plugins="mad"
PLIST_SUB+= MAD="@comment "
.endif
-.if ${PORT_OPTIONS:MMDNS_APPLE} && ${PORT_OPTIONS:MMDNS_AVAHI}
-IGNORE= you may choose either MDNS_APPLE or MDNS_AVAHI, but not both
-.elif !${PORT_OPTIONS:MMDNS_APPLE} && !${PORT_OPTIONS:MMDNS_AVAHI}
+.if empty(PORT_OPTIONS:MMDNS)
EXCLUDE+= --without-optionals="mdns"
.endif