aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-05-14 10:28:17 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-05-14 10:28:17 +0000
commit38635ecbf65d6ba8d1b27ba05b66a910605882af (patch)
tree55dbb61136379dfe1145be2a3dea181bcedbf264 /audio
parentfa779be375a8d763286dbcebe1e9462d1ac7f1ab (diff)
downloadports-38635ecbf65d6ba8d1b27ba05b66a910605882af.tar.gz
ports-38635ecbf65d6ba8d1b27ba05b66a910605882af.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/muine/Makefile2
-rw-r--r--audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index e587284ce004..c61aa92d29ab 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -8,7 +8,7 @@
PORTNAME= muine
PORTVERSION= 0.8.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio gnome
MASTER_SITES= GNOME
diff --git a/audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c b/audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c
new file mode 100644
index 000000000000..fb5ec48b3769
--- /dev/null
+++ b/audio/muine/files/patch-libmuine_rb-cell-renderer-pixbuf.c
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- libmuine/rb-cell-renderer-pixbuf.c.orig
++++ libmuine/rb-cell-renderer-pixbuf.c
+@@ -295,14 +295,14 @@
+
+ if ((flags & GTK_CELL_RENDERER_SELECTED) == GTK_CELL_RENDERER_SELECTED)
+ {
+- if (GTK_WIDGET_HAS_FOCUS (widget))
++ if (gtk_widget_has_focus (widget))
+ state = GTK_STATE_SELECTED;
+ else
+ state = GTK_STATE_ACTIVE;
+ }
+ else
+ {
+- if (GTK_WIDGET_STATE (widget) == GTK_STATE_INSENSITIVE)
++ if (GTK_OBJECT_FLAGS (widget) == GTK_STATE_INSENSITIVE)
+ state = GTK_STATE_INSENSITIVE;
+ else
+ state = GTK_STATE_NORMAL;