aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-05 07:28:52 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-05 07:28:52 +0000
commit8435dc68f051a4507c749632f115341e584d85d9 (patch)
tree12f7e77d956b8aca4f14b07f18ce6afa04770826 /audio
parent8e94adc0e83db134a17db8015d89a146b5488724 (diff)
downloadports-8435dc68f051a4507c749632f115341e584d85d9.tar.gz
ports-8435dc68f051a4507c749632f115341e584d85d9.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/solfege/Makefile23
-rw-r--r--audio/solfege/distinfo4
-rw-r--r--audio/solfege/files/patch-soundcard::macro_to_function.c12
-rw-r--r--audio/solfege/pkg-plist254
4 files changed, 120 insertions, 173 deletions
diff --git a/audio/solfege/Makefile b/audio/solfege/Makefile
index 06016deff3ee..6b12e93f4611 100644
--- a/audio/solfege/Makefile
+++ b/audio/solfege/Makefile
@@ -7,42 +7,41 @@
#
PORTNAME= solfege
-PORTVERSION= 2.1.1
-PORTREVISION= 3
+PORTVERSION= 2.2.1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -nosound
+DISTNAME= ${PORTNAME}-easybuild-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Free eartraining software
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- swig:${PORTSDIR}/devel/swig13 \
- xsltproc:${PORTSDIR}/textproc/libxslt \
- ${LOCALBASE}/share/xsl/docbook/html/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix pygnomeextras
USE_PYTHON= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
-CONFIGURE_ARGS= --disable-oss-sound \
- --enable-docbook-stylesheet=${LOCALBASE}/share/xsl/docbook/html/chunk.xsl
+CONFIGURE_ARGS= --disable-oss-sound
PLIST_SUB= VERSION=${PORTVERSION}
-MAN1= solfege.1
+MAN1= lessonfile_editor.1 solfege.1
post-patch:
@${GREP} -lR "/usr/bin/python2.2" ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -e 's|/usr/bin/python2.2|${SETENV} python|g'
+ @${REINPLACE_CMD} -e 's|type=sequencer-device|type=fake-synth| g; \
+ s|/usr/bin|${LOCALBASE}/bin|g' ${WRKSRC}/default.config
@${REINPLACE_CMD} -e 's|share/solfege|share/gnome/solfege|g' \
${WRKSRC}/run-solfege.py.in
@${REINPLACE_CMD} -e 's|(datadir)/locale|(prefix)/share/locale|g' \
${WRKSRC}/po/Makefile
- @${REINPLACE_CMD} -e 's|type=sequencer-device|type=fake-synth|' \
- ${WRKSRC}/default.config
+ @${REINPLACE_CMD} -e 's|share", "solfege|share", "gnome", "solfege|g' \
+ ${WRKSRC}/src/configureoutput.py.in
+ @${REINPLACE_CMD} -e 's|gnome.canvas|gnomecanvas|g' \
+ ${WRKSRC}/src/inputwidgets.py
.include <bsd.port.mk>
diff --git a/audio/solfege/distinfo b/audio/solfege/distinfo
index 9ee6dfcb8dc9..6a15e1ec606d 100644
--- a/audio/solfege/distinfo
+++ b/audio/solfege/distinfo
@@ -1,2 +1,2 @@
-MD5 (solfege-2.1.1.tar.gz) = 06f13ca884fbfca9111a8426e0fc2bb8
-SIZE (solfege-2.1.1.tar.gz) = 610378
+MD5 (solfege-easybuild-2.2.1.tar.gz) = e1af74051effb8a4cfa869debbac26a9
+SIZE (solfege-easybuild-2.2.1.tar.gz) = 821352
diff --git a/audio/solfege/files/patch-soundcard::macro_to_function.c b/audio/solfege/files/patch-soundcard::macro_to_function.c
new file mode 100644
index 000000000000..0a158742b6de
--- /dev/null
+++ b/audio/solfege/files/patch-soundcard::macro_to_function.c
@@ -0,0 +1,12 @@
+--- soundcard/macro_to_function.c.orig Mon Mar 21 05:18:34 2005
++++ soundcard/macro_to_function.c Tue Mar 22 00:28:40 2005
+@@ -24,7 +24,9 @@
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+
++#ifdef HAVE_LINUX_AWE_VOICE_H
+ #include <linux/awe_voice.h>
++#endif
+
+ extern int _seqbufptr;
+ extern int _seqbuflen;
diff --git a/audio/solfege/pkg-plist b/audio/solfege/pkg-plist
index fea7cb2d06ee..ebb92c63c2c2 100644
--- a/audio/solfege/pkg-plist
+++ b/audio/solfege/pkg-plist
@@ -1,7 +1,8 @@
+bin/lessonfile_editor
bin/solfege
bin/solfege%%VERSION%%
-etc/solfege2.1
-share/gnome/apps/Applications/solfege.desktop
+etc/solfege
+share/gnome/applications/solfege.desktop
share/gnome/pixmaps/solfege.png
share/gnome/solfege/%%VERSION%%/default.config
share/gnome/solfege/%%VERSION%%/example-lesson-files/chord-satb
@@ -52,19 +53,37 @@ share/gnome/solfege/%%VERSION%%/feta/feta20-rests-4.xpm
share/gnome/solfege/%%VERSION%%/feta/feta20-rests-5.xpm
share/gnome/solfege/%%VERSION%%/feta/feta20-rests-6.xpm
share/gnome/solfege/%%VERSION%%/feta/feta20-rests-7.xpm
-share/gnome/solfege/%%VERSION%%/graphics/chord24.png
-share/gnome/solfege/%%VERSION%%/graphics/compareintervals24.png
-share/gnome/solfege/%%VERSION%%/graphics/dictation24.png
-share/gnome/solfege/%%VERSION%%/graphics/happyface-32x32.png
-share/gnome/solfege/%%VERSION%%/graphics/harmonicinterval24.png
-share/gnome/solfege/%%VERSION%%/graphics/harmonicprogression24.png
+share/gnome/solfege/%%VERSION%%/gnomeemu/gnome/__init__.py
+share/gnome/solfege/%%VERSION%%/gnomeemu/gnome/canvas.py
+share/gnome/solfege/%%VERSION%%/gnomeemu/gnome/ui.py
+share/gnome/solfege/%%VERSION%%/gnomeemu/gnome/uiconsts.py
+share/gnome/solfege/%%VERSION%%/graphics/chord-voicing.png
+share/gnome/solfege/%%VERSION%%/graphics/chord.png
+share/gnome/solfege/%%VERSION%%/graphics/compare-intervals.png
+share/gnome/solfege/%%VERSION%%/graphics/dictation.png
+share/gnome/solfege/%%VERSION%%/graphics/double-flat.png
+share/gnome/solfege/%%VERSION%%/graphics/double-flat.svg
+share/gnome/solfege/%%VERSION%%/graphics/double-sharp.png
+share/gnome/solfege/%%VERSION%%/graphics/double-sharp.svg
+share/gnome/solfege/%%VERSION%%/graphics/erase.png
+share/gnome/solfege/%%VERSION%%/graphics/erase.svg
+share/gnome/solfege/%%VERSION%%/graphics/flat.png
+share/gnome/solfege/%%VERSION%%/graphics/flat.svg
+share/gnome/solfege/%%VERSION%%/graphics/happyface.png
+share/gnome/solfege/%%VERSION%%/graphics/harmonic-interval.png
+share/gnome/solfege/%%VERSION%%/graphics/harmonic-progression-dictation.png
share/gnome/solfege/%%VERSION%%/graphics/holder.png
-share/gnome/solfege/%%VERSION%%/graphics/idbyname24.png
-share/gnome/solfege/%%VERSION%%/graphics/identify-bpm24.png
-share/gnome/solfege/%%VERSION%%/graphics/identifychord24.png
-share/gnome/solfege/%%VERSION%%/graphics/identifyscale24.png
-share/gnome/solfege/%%VERSION%%/graphics/idtone24.png
-share/gnome/solfege/%%VERSION%%/graphics/melodicinterval24.png
+share/gnome/solfege/%%VERSION%%/graphics/id-by-name.png
+share/gnome/solfege/%%VERSION%%/graphics/id-tone.png
+share/gnome/solfege/%%VERSION%%/graphics/identify-bpm.png
+share/gnome/solfege/%%VERSION%%/graphics/identify-chord.png
+share/gnome/solfege/%%VERSION%%/graphics/identify-scale.png
+share/gnome/solfege/%%VERSION%%/graphics/image-not-found.png
+share/gnome/solfege/%%VERSION%%/graphics/melodic-interval.png
+share/gnome/solfege/%%VERSION%%/graphics/natural.png
+share/gnome/solfege/%%VERSION%%/graphics/natural.svg
+share/gnome/solfege/%%VERSION%%/graphics/notehead.png
+share/gnome/solfege/%%VERSION%%/graphics/notehead.svg
share/gnome/solfege/%%VERSION%%/graphics/rhythm-c12c12c12.png
share/gnome/solfege/%%VERSION%%/graphics/rhythm-c12c12r12.png
share/gnome/solfege/%%VERSION%%/graphics/rhythm-c12r12c12.png
@@ -88,14 +107,16 @@ share/gnome/solfege/%%VERSION%%/graphics/rhythm-r8c16c16.png
share/gnome/solfege/%%VERSION%%/graphics/rhythm-r8c8.png
share/gnome/solfege/%%VERSION%%/graphics/rhythm-r8r16c16.png
share/gnome/solfege/%%VERSION%%/graphics/rhythm-wrong.png
-share/gnome/solfege/%%VERSION%%/graphics/rhythm24.png
-share/gnome/solfege/%%VERSION%%/graphics/sadface-32x32.png
-share/gnome/solfege/%%VERSION%%/graphics/singchord24.png
-share/gnome/solfege/%%VERSION%%/graphics/singinterval24.png
+share/gnome/solfege/%%VERSION%%/graphics/rhythm.png
+share/gnome/solfege/%%VERSION%%/graphics/sadface.png
+share/gnome/solfege/%%VERSION%%/graphics/sharp.png
+share/gnome/solfege/%%VERSION%%/graphics/sharp.svg
+share/gnome/solfege/%%VERSION%%/graphics/sing-chord.png
+share/gnome/solfege/%%VERSION%%/graphics/sing-interval.png
share/gnome/solfege/%%VERSION%%/graphics/solfege.png
share/gnome/solfege/%%VERSION%%/graphics/solfege.xpm
share/gnome/solfege/%%VERSION%%/graphics/test-sound.png
-share/gnome/solfege/%%VERSION%%/graphics/twelvetone24.png
+share/gnome/solfege/%%VERSION%%/graphics/twelve-tone.png
share/gnome/solfege/%%VERSION%%/lesson-files/altered-1
share/gnome/solfege/%%VERSION%%/lesson-files/altered-2
share/gnome/solfege/%%VERSION%%/lesson-files/atonal-1
@@ -107,13 +128,6 @@ share/gnome/solfege/%%VERSION%%/lesson-files/chord-all
share/gnome/solfege/%%VERSION%%/lesson-files/chord-all-inv
share/gnome/solfege/%%VERSION%%/lesson-files/chord-dim-aug
share/gnome/solfege/%%VERSION%%/lesson-files/chord-dim-aug-min-major
-share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.97
-share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.98
-share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.99
-share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.995
-share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.996
-share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.997
-share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.998
share/gnome/solfege/%%VERSION%%/lesson-files/chord-m7-7
share/gnome/solfege/%%VERSION%%/lesson-files/chord-m7-7-inv
share/gnome/solfege/%%VERSION%%/lesson-files/chord-m7-7-inv-not
@@ -126,6 +140,13 @@ share/gnome/solfege/%%VERSION%%/lesson-files/chord-min-major-7
share/gnome/solfege/%%VERSION%%/lesson-files/chord-min-major-close-open
share/gnome/solfege/%%VERSION%%/lesson-files/chord-min-major-inv
share/gnome/solfege/%%VERSION%%/lesson-files/chord-min-major-inv-not
+share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.97
+share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.98
+share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.99
+share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.995
+share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.996
+share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.997
+share/gnome/solfege/%%VERSION%%/lesson-files/csound-fifth-0.998
share/gnome/solfege/%%VERSION%%/lesson-files/diatonic-1
share/gnome/solfege/%%VERSION%%/lesson-files/diatonic-2
share/gnome/solfege/%%VERSION%%/lesson-files/durmoll
@@ -138,6 +159,7 @@ share/gnome/solfege/%%VERSION%%/lesson-files/progression-atte
share/gnome/solfege/%%VERSION%%/lesson-files/progression-x
share/gnome/solfege/%%VERSION%%/lesson-files/scales
share/gnome/solfege/%%VERSION%%/lesson-files/scales-thirds
+share/gnome/solfege/%%VERSION%%/lesson-files/share/fanfare.midi
share/gnome/solfege/%%VERSION%%/lesson-files/share/fifth-pure-220.00.wav
share/gnome/solfege/%%VERSION%%/lesson-files/share/fifth-pure-247.5.wav
share/gnome/solfege/%%VERSION%%/lesson-files/share/fifth-pure-293.33.wav
@@ -146,6 +168,11 @@ share/gnome/solfege/%%VERSION%%/lesson-files/share/fifth-small-247.5.wav
share/gnome/solfege/%%VERSION%%/lesson-files/share/fifth-small-293.33.wav
share/gnome/solfege/%%VERSION%%/lesson-files/share/fil1.orc
share/gnome/solfege/%%VERSION%%/lesson-files/share/fil1.sco
+share/gnome/solfege/%%VERSION%%/lesson-files/sing-chord-tone
+share/gnome/solfege/%%VERSION%%/lesson-files/sing-the-fifth
+share/gnome/solfege/%%VERSION%%/lesson-files/sing-the-root
+share/gnome/solfege/%%VERSION%%/lesson-files/sing-the-seventh
+share/gnome/solfege/%%VERSION%%/lesson-files/sing-the-third
share/gnome/solfege/%%VERSION%%/lesson-files/singchord-1
share/gnome/solfege/%%VERSION%%/lesson-files/singchord-2
share/gnome/solfege/%%VERSION%%/lesson-files/singchord-3
@@ -159,37 +186,16 @@ share/gnome/solfege/%%VERSION%%/lesson-files/volkslieder1
share/gnome/solfege/%%VERSION%%/lesson-files/volkslieder2
share/gnome/solfege/%%VERSION%%/mpd/__init__.py
share/gnome/solfege/%%VERSION%%/mpd/_exceptions.py
-share/gnome/solfege/%%VERSION%%/mpd/_exceptions.pyc
-share/gnome/solfege/%%VERSION%%/mpd/_exceptions.pyo
share/gnome/solfege/%%VERSION%%/mpd/const.py
-share/gnome/solfege/%%VERSION%%/mpd/const.pyc
-share/gnome/solfege/%%VERSION%%/mpd/const.pyo
share/gnome/solfege/%%VERSION%%/mpd/duration.py
-share/gnome/solfege/%%VERSION%%/mpd/duration.pyc
-share/gnome/solfege/%%VERSION%%/mpd/duration.pyo
share/gnome/solfege/%%VERSION%%/mpd/engravers.py
-share/gnome/solfege/%%VERSION%%/mpd/engravers.pyc
-share/gnome/solfege/%%VERSION%%/mpd/engravers.pyo
share/gnome/solfege/%%VERSION%%/mpd/interval.py
-share/gnome/solfege/%%VERSION%%/mpd/interval.pyc
-share/gnome/solfege/%%VERSION%%/mpd/interval.pyo
share/gnome/solfege/%%VERSION%%/mpd/mpdutils.py
-share/gnome/solfege/%%VERSION%%/mpd/mpdutils.pyc
-share/gnome/solfege/%%VERSION%%/mpd/mpdutils.pyo
share/gnome/solfege/%%VERSION%%/mpd/musicalpitch.py
-share/gnome/solfege/%%VERSION%%/mpd/musicalpitch.pyc
-share/gnome/solfege/%%VERSION%%/mpd/musicalpitch.pyo
share/gnome/solfege/%%VERSION%%/mpd/musicdisplayer.py
-share/gnome/solfege/%%VERSION%%/mpd/musicdisplayer.pyc
-share/gnome/solfege/%%VERSION%%/mpd/musicdisplayer.pyo
share/gnome/solfege/%%VERSION%%/mpd/parser.py
-share/gnome/solfege/%%VERSION%%/mpd/parser.pyc
-share/gnome/solfege/%%VERSION%%/mpd/parser.pyo
share/gnome/solfege/%%VERSION%%/mpd/requests.py
-share/gnome/solfege/%%VERSION%%/mpd/requests.pyc
-share/gnome/solfege/%%VERSION%%/mpd/requests.pyo
share/gnome/solfege/%%VERSION%%/online-docs/C/AUTHORS.html
-share/gnome/solfege/%%VERSION%%/online-docs/C/apa.html
share/gnome/solfege/%%VERSION%%/online-docs/C/bug-reporting.html
share/gnome/solfege/%%VERSION%%/online-docs/C/ch01.html
share/gnome/solfege/%%VERSION%%/online-docs/C/ch02.html
@@ -210,13 +216,26 @@ share/gnome/solfege/%%VERSION%%/online-docs/C/identify-bpm-help.html
share/gnome/solfege/%%VERSION%%/online-docs/C/identify-scale-help.html
share/gnome/solfege/%%VERSION%%/online-docs/C/index.html
share/gnome/solfege/%%VERSION%%/online-docs/C/lessonfiles.html
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-1666014298.midi
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-1666014298.png
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-2021449257.midi
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-2021449257.png
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-662113668.midi
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-662113668.png
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-783452687.midi
+share/gnome/solfege/%%VERSION%%/online-docs/C/lily-783452687.png
share/gnome/solfege/%%VERSION%%/online-docs/C/melodic-interval-help.html
+share/gnome/solfege/%%VERSION%%/online-docs/C/missing-helpfile.html
share/gnome/solfege/%%VERSION%%/online-docs/C/music-format.html
share/gnome/solfege/%%VERSION%%/online-docs/C/online-resources.html
share/gnome/solfege/%%VERSION%%/online-docs/C/preferences-window.html
share/gnome/solfege/%%VERSION%%/online-docs/C/rhythm-help.html
share/gnome/solfege/%%VERSION%%/online-docs/C/sing-chord-help.html
share/gnome/solfege/%%VERSION%%/online-docs/C/sing-interval-help.html
+share/gnome/solfege/%%VERSION%%/online-docs/C/singanswer-help.html
+share/gnome/solfege/%%VERSION%%/online-docs/C/solfege.html
+share/gnome/solfege/%%VERSION%%/online-docs/C/theory-intervals.html
+share/gnome/solfege/%%VERSION%%/online-docs/C/toc.html
share/gnome/solfege/%%VERSION%%/online-docs/C/translating-solfege.html
share/gnome/solfege/%%VERSION%%/online-docs/C/twelve-tone-help.html
share/gnome/solfege/%%VERSION%%/online-docs/C/ui.html
@@ -246,10 +265,13 @@ share/gnome/solfege/%%VERSION%%/online-docs/es_MX/preferences-window.html
share/gnome/solfege/%%VERSION%%/online-docs/es_MX/rhythm-help.html
share/gnome/solfege/%%VERSION%%/online-docs/es_MX/sing-chord-help.html
share/gnome/solfege/%%VERSION%%/online-docs/es_MX/sing-interval-help.html
+share/gnome/solfege/%%VERSION%%/online-docs/es_MX/solfege.html
+share/gnome/solfege/%%VERSION%%/online-docs/es_MX/toc.html
share/gnome/solfege/%%VERSION%%/online-docs/es_MX/translating-solfege.html
share/gnome/solfege/%%VERSION%%/online-docs/es_MX/twelve-tone-help.html
share/gnome/solfege/%%VERSION%%/online-docs/es_MX/ui.html
share/gnome/solfege/%%VERSION%%/online-docs/es_MX/welcome.html
+share/gnome/solfege/%%VERSION%%/online-docs/nl/welcome.html
share/gnome/solfege/%%VERSION%%/online-docs/no/ch01.html
share/gnome/solfege/%%VERSION%%/online-docs/no/ch02.html
share/gnome/solfege/%%VERSION%%/online-docs/no/chord-help.html
@@ -268,6 +290,8 @@ share/gnome/solfege/%%VERSION%%/online-docs/no/online-resources.html
share/gnome/solfege/%%VERSION%%/online-docs/no/rhythm-help.html
share/gnome/solfege/%%VERSION%%/online-docs/no/sing-chord-help.html
share/gnome/solfege/%%VERSION%%/online-docs/no/sing-interval-help.html
+share/gnome/solfege/%%VERSION%%/online-docs/no/solfege.html
+share/gnome/solfege/%%VERSION%%/online-docs/no/toc.html
share/gnome/solfege/%%VERSION%%/online-docs/no/twelve-tone-help.html
share/gnome/solfege/%%VERSION%%/online-docs/no/welcome.html
share/gnome/solfege/%%VERSION%%/online-docs/png/addvoice.png
@@ -283,172 +307,79 @@ share/gnome/solfege/%%VERSION%%/online-docs/png/tie.png
share/gnome/solfege/%%VERSION%%/online-docs/png/tuple.png
share/gnome/solfege/%%VERSION%%/online-docs/ru/index.html
share/gnome/solfege/%%VERSION%%/online-docs/ru/intro.html
+share/gnome/solfege/%%VERSION%%/online-docs/ru/solfege.html
+share/gnome/solfege/%%VERSION%%/online-docs/ru/toc.html
share/gnome/solfege/%%VERSION%%/online-docs/ru/welcome.html
share/gnome/solfege/%%VERSION%%/solfege.gtkrc
share/gnome/solfege/%%VERSION%%/soundcard/__init__.py
share/gnome/solfege/%%VERSION%%/soundcard/fakesynth.py
-share/gnome/solfege/%%VERSION%%/soundcard/fakesynth.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/fakesynth.pyo
share/gnome/solfege/%%VERSION%%/soundcard/mfutils.py
-share/gnome/solfege/%%VERSION%%/soundcard/mfutils.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/mfutils.pyo
share/gnome/solfege/%%VERSION%%/soundcard/midifilesynth.py
-share/gnome/solfege/%%VERSION%%/soundcard/midifilesynth.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/midifilesynth.pyo
share/gnome/solfege/%%VERSION%%/soundcard/oss_common.py
-share/gnome/solfege/%%VERSION%%/soundcard/oss_common.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/oss_common.pyo
share/gnome/solfege/%%VERSION%%/soundcard/oss_sequencer.py
-share/gnome/solfege/%%VERSION%%/soundcard/oss_sequencer.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/oss_sequencer.pyo
share/gnome/solfege/%%VERSION%%/soundcard/oss_sequencer2.py
-share/gnome/solfege/%%VERSION%%/soundcard/oss_sequencer2.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/oss_sequencer2.pyo
share/gnome/solfege/%%VERSION%%/soundcard/rat.py
-share/gnome/solfege/%%VERSION%%/soundcard/rat.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/rat.pyo
share/gnome/solfege/%%VERSION%%/soundcard/solfege_c_midi.py
-share/gnome/solfege/%%VERSION%%/soundcard/solfege_c_midi.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/solfege_c_midi.pyo
share/gnome/solfege/%%VERSION%%/soundcard/soundcardexceptions.py
-share/gnome/solfege/%%VERSION%%/soundcard/soundcardexceptions.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/soundcardexceptions.pyo
share/gnome/solfege/%%VERSION%%/soundcard/track.py
-share/gnome/solfege/%%VERSION%%/soundcard/track.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/track.pyo
share/gnome/solfege/%%VERSION%%/soundcard/winsynth.py
-share/gnome/solfege/%%VERSION%%/soundcard/winsynth.pyc
-share/gnome/solfege/%%VERSION%%/soundcard/winsynth.pyo
share/gnome/solfege/%%VERSION%%/src/__init__.py
share/gnome/solfege/%%VERSION%%/src/abstract.py
-share/gnome/solfege/%%VERSION%%/src/abstract.pyc
-share/gnome/solfege/%%VERSION%%/src/abstract.pyo
share/gnome/solfege/%%VERSION%%/src/app.py
-share/gnome/solfege/%%VERSION%%/src/app.pyc
-share/gnome/solfege/%%VERSION%%/src/app.pyo
share/gnome/solfege/%%VERSION%%/src/cfg.py
-share/gnome/solfege/%%VERSION%%/src/cfg.pyc
-share/gnome/solfege/%%VERSION%%/src/cfg.pyo
share/gnome/solfege/%%VERSION%%/src/chord.py
-share/gnome/solfege/%%VERSION%%/src/chord.pyc
-share/gnome/solfege/%%VERSION%%/src/chord.pyo
share/gnome/solfege/%%VERSION%%/src/chordvoicing.py
-share/gnome/solfege/%%VERSION%%/src/chordvoicing.pyc
-share/gnome/solfege/%%VERSION%%/src/chordvoicing.pyo
share/gnome/solfege/%%VERSION%%/src/compareintervals.py
-share/gnome/solfege/%%VERSION%%/src/compareintervals.pyc
-share/gnome/solfege/%%VERSION%%/src/compareintervals.pyo
share/gnome/solfege/%%VERSION%%/src/configureoutput.py
-share/gnome/solfege/%%VERSION%%/src/configureoutput.pyc
-share/gnome/solfege/%%VERSION%%/src/configureoutput.pyo
share/gnome/solfege/%%VERSION%%/src/configwindow.py
-share/gnome/solfege/%%VERSION%%/src/configwindow.pyc
-share/gnome/solfege/%%VERSION%%/src/configwindow.pyo
share/gnome/solfege/%%VERSION%%/src/const.py
-share/gnome/solfege/%%VERSION%%/src/const.pyc
-share/gnome/solfege/%%VERSION%%/src/const.pyo
share/gnome/solfege/%%VERSION%%/src/dataparser.py
-share/gnome/solfege/%%VERSION%%/src/dataparser.pyc
-share/gnome/solfege/%%VERSION%%/src/dataparser.pyo
share/gnome/solfege/%%VERSION%%/src/dictation.py
-share/gnome/solfege/%%VERSION%%/src/dictation.pyc
-share/gnome/solfege/%%VERSION%%/src/dictation.pyo
+share/gnome/solfege/%%VERSION%%/src/exercise_setup.py
+share/gnome/solfege/%%VERSION%%/src/gethomedir.py
share/gnome/solfege/%%VERSION%%/src/gu.py
-share/gnome/solfege/%%VERSION%%/src/gu.pyc
-share/gnome/solfege/%%VERSION%%/src/gu.pyo
share/gnome/solfege/%%VERSION%%/src/harmonicinterval.py
-share/gnome/solfege/%%VERSION%%/src/harmonicinterval.pyc
-share/gnome/solfege/%%VERSION%%/src/harmonicinterval.pyo
share/gnome/solfege/%%VERSION%%/src/harmonicprogressiondictation.py
-share/gnome/solfege/%%VERSION%%/src/harmonicprogressiondictation.pyc
-share/gnome/solfege/%%VERSION%%/src/harmonicprogressiondictation.pyo
share/gnome/solfege/%%VERSION%%/src/history.py
-share/gnome/solfege/%%VERSION%%/src/history.pyc
-share/gnome/solfege/%%VERSION%%/src/history.pyo
share/gnome/solfege/%%VERSION%%/src/htmlwidget.py
-share/gnome/solfege/%%VERSION%%/src/htmlwidget.pyc
-share/gnome/solfege/%%VERSION%%/src/htmlwidget.pyo
share/gnome/solfege/%%VERSION%%/src/i18n.py
-share/gnome/solfege/%%VERSION%%/src/i18n.pyc
-share/gnome/solfege/%%VERSION%%/src/i18n.pyo
share/gnome/solfege/%%VERSION%%/src/idbyname.py
-share/gnome/solfege/%%VERSION%%/src/idbyname.pyc
-share/gnome/solfege/%%VERSION%%/src/idbyname.pyo
share/gnome/solfege/%%VERSION%%/src/identifybpm.py
-share/gnome/solfege/%%VERSION%%/src/identifybpm.pyc
-share/gnome/solfege/%%VERSION%%/src/identifybpm.pyo
share/gnome/solfege/%%VERSION%%/src/idtone.py
-share/gnome/solfege/%%VERSION%%/src/idtone.pyc
-share/gnome/solfege/%%VERSION%%/src/idtone.pyo
share/gnome/solfege/%%VERSION%%/src/inputwidgets.py
-share/gnome/solfege/%%VERSION%%/src/inputwidgets.pyc
-share/gnome/solfege/%%VERSION%%/src/inputwidgets.pyo
share/gnome/solfege/%%VERSION%%/src/instrumentselector.py
-share/gnome/solfege/%%VERSION%%/src/instrumentselector.pyc
-share/gnome/solfege/%%VERSION%%/src/instrumentselector.pyo
-share/gnome/solfege/%%VERSION%%/src/intervals.py
-share/gnome/solfege/%%VERSION%%/src/intervals.pyc
-share/gnome/solfege/%%VERSION%%/src/intervals.pyo
share/gnome/solfege/%%VERSION%%/src/lessonfile.py
-share/gnome/solfege/%%VERSION%%/src/lessonfile.pyc
-share/gnome/solfege/%%VERSION%%/src/lessonfile.pyo
+share/gnome/solfege/%%VERSION%%/src/lessonfile_editor_main.py
share/gnome/solfege/%%VERSION%%/src/mainwin.py
-share/gnome/solfege/%%VERSION%%/src/mainwin.pyc
-share/gnome/solfege/%%VERSION%%/src/mainwin.pyo
share/gnome/solfege/%%VERSION%%/src/melodicinterval.py
-share/gnome/solfege/%%VERSION%%/src/melodicinterval.pyc
-share/gnome/solfege/%%VERSION%%/src/melodicinterval.pyo
share/gnome/solfege/%%VERSION%%/src/multipleintervalconfigwidget.py
-share/gnome/solfege/%%VERSION%%/src/multipleintervalconfigwidget.pyc
-share/gnome/solfege/%%VERSION%%/src/multipleintervalconfigwidget.pyo
share/gnome/solfege/%%VERSION%%/src/notenamespinbutton.py
-share/gnome/solfege/%%VERSION%%/src/notenamespinbutton.pyc
-share/gnome/solfege/%%VERSION%%/src/notenamespinbutton.pyo
-share/gnome/solfege/%%VERSION%%/src/polyrhythm.py
-share/gnome/solfege/%%VERSION%%/src/polyrhythm.pyc
-share/gnome/solfege/%%VERSION%%/src/polyrhythm.pyo
share/gnome/solfege/%%VERSION%%/src/pyscript.py
-share/gnome/solfege/%%VERSION%%/src/pyscript.pyc
-share/gnome/solfege/%%VERSION%%/src/pyscript.pyo
share/gnome/solfege/%%VERSION%%/src/rhythm.py
-share/gnome/solfege/%%VERSION%%/src/rhythm.pyc
-share/gnome/solfege/%%VERSION%%/src/rhythm.pyo
share/gnome/solfege/%%VERSION%%/src/selectlessonfilewidget.py
-share/gnome/solfege/%%VERSION%%/src/selectlessonfilewidget.pyc
-share/gnome/solfege/%%VERSION%%/src/selectlessonfilewidget.pyo
+share/gnome/solfege/%%VERSION%%/src/singanswer.py
share/gnome/solfege/%%VERSION%%/src/singchord.py
-share/gnome/solfege/%%VERSION%%/src/singchord.pyc
-share/gnome/solfege/%%VERSION%%/src/singchord.pyo
share/gnome/solfege/%%VERSION%%/src/singinterval.py
-share/gnome/solfege/%%VERSION%%/src/singinterval.pyc
-share/gnome/solfege/%%VERSION%%/src/singinterval.pyo
share/gnome/solfege/%%VERSION%%/src/specialwidgets.py
-share/gnome/solfege/%%VERSION%%/src/specialwidgets.pyc
-share/gnome/solfege/%%VERSION%%/src/specialwidgets.pyo
share/gnome/solfege/%%VERSION%%/src/statistics.py
-share/gnome/solfege/%%VERSION%%/src/statistics.pyc
-share/gnome/solfege/%%VERSION%%/src/statistics.pyo
share/gnome/solfege/%%VERSION%%/src/statisticsviewer.py
-share/gnome/solfege/%%VERSION%%/src/statisticsviewer.pyc
-share/gnome/solfege/%%VERSION%%/src/statisticsviewer.pyo
+share/gnome/solfege/%%VERSION%%/src/stock.py
share/gnome/solfege/%%VERSION%%/src/tracebackwindow.py
-share/gnome/solfege/%%VERSION%%/src/tracebackwindow.pyc
-share/gnome/solfege/%%VERSION%%/src/tracebackwindow.pyo
share/gnome/solfege/%%VERSION%%/src/tuner.py
-share/gnome/solfege/%%VERSION%%/src/tuner.pyc
-share/gnome/solfege/%%VERSION%%/src/tuner.pyo
share/gnome/solfege/%%VERSION%%/src/twelvetone.py
-share/gnome/solfege/%%VERSION%%/src/twelvetone.pyc
-share/gnome/solfege/%%VERSION%%/src/twelvetone.pyo
-share/gnome/solfege/%%VERSION%%/src/txtui.py
-share/gnome/solfege/%%VERSION%%/src/txtui.pyc
-share/gnome/solfege/%%VERSION%%/src/txtui.pyo
share/gnome/solfege/%%VERSION%%/src/utils.py
-share/gnome/solfege/%%VERSION%%/src/utils.pyc
-share/gnome/solfege/%%VERSION%%/src/utils.pyo
share/gnome/solfege/%%VERSION%%/src/widgets.py
-share/gnome/solfege/%%VERSION%%/src/widgets.pyc
-share/gnome/solfege/%%VERSION%%/src/widgets.pyo
+share/gnome/solfege/%%VERSION%%/themes/svg/chord-voicing.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/chord.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/happyface.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/harmonic-interval.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/id-by-name.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/mal.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/melodic-interval.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/sadface.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/sing-chord.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/sing-interval.svg
+share/gnome/solfege/%%VERSION%%/themes/svg/solfege.svg
share/locale/da/LC_MESSAGES/solfege.mo
share/locale/de/LC_MESSAGES/solfege.mo
share/locale/es/LC_MESSAGES/solfege.mo
@@ -458,19 +389,24 @@ share/locale/it/LC_MESSAGES/solfege.mo
share/locale/nl/LC_MESSAGES/solfege.mo
share/locale/no/LC_MESSAGES/solfege.mo
share/locale/ru/LC_MESSAGES/solfege.mo
+@dirrm share/gnome/solfege/%%VERSION%%/themes/svg
+@dirrm share/gnome/solfege/%%VERSION%%/themes
@dirrm share/gnome/solfege/%%VERSION%%/src
@dirrm share/gnome/solfege/%%VERSION%%/soundcard
@dirrm share/gnome/solfege/%%VERSION%%/online-docs/ru
@dirrm share/gnome/solfege/%%VERSION%%/online-docs/png
@dirrm share/gnome/solfege/%%VERSION%%/online-docs/no
+@dirrm share/gnome/solfege/%%VERSION%%/online-docs/nl
@dirrm share/gnome/solfege/%%VERSION%%/online-docs/es_MX
@dirrm share/gnome/solfege/%%VERSION%%/online-docs/C
@dirrm share/gnome/solfege/%%VERSION%%/online-docs
@dirrm share/gnome/solfege/%%VERSION%%/mpd
-@dirrm share/gnome/solfege/%%VERSION%%/lesson-files/bin
@dirrm share/gnome/solfege/%%VERSION%%/lesson-files/share
+@dirrm share/gnome/solfege/%%VERSION%%/lesson-files/bin
@dirrm share/gnome/solfege/%%VERSION%%/lesson-files
@dirrm share/gnome/solfege/%%VERSION%%/graphics
+@dirrm share/gnome/solfege/%%VERSION%%/gnomeemu/gnome
+@dirrm share/gnome/solfege/%%VERSION%%/gnomeemu
@dirrm share/gnome/solfege/%%VERSION%%/feta
@dirrm share/gnome/solfege/%%VERSION%%/example-lesson-files
@dirrm share/gnome/solfege/%%VERSION%%