aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2009-03-30 18:21:21 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2009-03-30 18:21:21 +0000
commite1f6a6e1a8adf14ab4c1739cef617b657adb4bd9 (patch)
tree94d770b1114d48f29c61a5032212004baa969d29 /audio
parent8ac0de0f82ef8dba385fe3cb85cef8eb44125fa8 (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/jack/Makefile10
-rw-r--r--audio/jack/distinfo6
-rw-r--r--audio/jack/files/patch-drivers-dummy-dummy_driver.c11
-rw-r--r--audio/jack/files/patch-drivers-dummy-dummy_driver.h11
-rw-r--r--audio/jack/files/patch-drivers-netjack-net_driver.c11
-rw-r--r--audio/jack/files/patch-jackd_engine.c29
-rw-r--r--audio/jack/files/patch-libjack-midiport.c11
-rw-r--r--audio/jack/pkg-plist26
8 files changed, 85 insertions, 30 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 0de92dcab41a..df591ac0dc54 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= jackit
-PORTVERSION= 0.109.2
-PORTREVISION= 1
+PORTVERSION= 0.116.2
CATEGORIES= audio
-MASTER_SITES= SF
+MASTER_SITES= http://jackaudio.org/downloads/
DISTNAME= jack-audio-connection-kit-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= A low-latency audio server
LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
- sndfile.1:${PORTSDIR}/audio/libsndfile
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ celt.0:${PORTSDIR}/audio/celt
OPTIONS= DOCS "Build HTML documentation. Requires doxygen/TeX." off
@@ -27,6 +28,7 @@ CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" LDFLAGS="-L${LOCALBASE}/lib" \
CONFIGURE_ARGS+=--enable-portaudio \
--with-default-tmpdir=/tmp
GNU_CONFIGURE= yes
+USE_GMAKE= yes
USE_LDCONFIG= yes
USE_GNOME= pkgconfig gnometarget gnomehack
diff --git a/audio/jack/distinfo b/audio/jack/distinfo
index 432772d27614..1c6770d194e2 100644
--- a/audio/jack/distinfo
+++ b/audio/jack/distinfo
@@ -1,3 +1,3 @@
-MD5 (jack-audio-connection-kit-0.109.2.tar.gz) = 4d8f795a6c566b9753a86038367e7e32
-SHA256 (jack-audio-connection-kit-0.109.2.tar.gz) = 27a7a70e5be0dbcdd98ee1a505399e006e06b4f58fcd3b8cd25763aa7e43bfd4
-SIZE (jack-audio-connection-kit-0.109.2.tar.gz) = 831141
+MD5 (jack-audio-connection-kit-0.116.2.tar.gz) = 9c0ae9880e9b6e081f1a238fe6a28bd5
+SHA256 (jack-audio-connection-kit-0.116.2.tar.gz) = ce6e1f61a3b003137af56b749e5ed4274584167c0877ea9ef2d83f47b11c8d3d
+SIZE (jack-audio-connection-kit-0.116.2.tar.gz) = 944106
diff --git a/audio/jack/files/patch-drivers-dummy-dummy_driver.c b/audio/jack/files/patch-drivers-dummy-dummy_driver.c
new file mode 100644
index 000000000000..7390b093b411
--- /dev/null
+++ b/audio/jack/files/patch-drivers-dummy-dummy_driver.c
@@ -0,0 +1,11 @@
+--- drivers/dummy/dummy_driver.c.orig 2009-02-12 04:44:04.000000000 +0100
++++ drivers/dummy/dummy_driver.c 2009-02-12 04:44:15.000000000 +0100
+@@ -73,7 +73,7 @@
+ }
+ }
+
+-#ifdef HAVE_CLOCK_GETTIME
++#if HAVE_CLOCK_GETTIME
+ static inline unsigned long long ts_to_nsec(struct timespec ts)
+ {
+ return ts.tv_sec * 1000000000LL + ts.tv_nsec;
diff --git a/audio/jack/files/patch-drivers-dummy-dummy_driver.h b/audio/jack/files/patch-drivers-dummy-dummy_driver.h
new file mode 100644
index 000000000000..17561dc3445a
--- /dev/null
+++ b/audio/jack/files/patch-drivers-dummy-dummy_driver.h
@@ -0,0 +1,11 @@
+--- drivers/dummy/dummy_driver.h.orig 2009-02-12 05:04:38.000000000 +0100
++++ drivers/dummy/dummy_driver.h 2009-02-12 05:04:44.000000000 +0100
+@@ -44,7 +44,7 @@
+ jack_nframes_t period_size;
+ unsigned long wait_time;
+
+-#ifdef HAVE_CLOCK_GETTIME
++#if HAVE_CLOCK_GETTIME
+ struct timespec next_wakeup;
+ #else
+ jack_time_t next_time;
diff --git a/audio/jack/files/patch-drivers-netjack-net_driver.c b/audio/jack/files/patch-drivers-netjack-net_driver.c
new file mode 100644
index 000000000000..d8b746cf8507
--- /dev/null
+++ b/audio/jack/files/patch-drivers-netjack-net_driver.c
@@ -0,0 +1,11 @@
+--- drivers/netjack/net_driver.c.orig 2009-02-11 20:49:54.000000000 +0100
++++ drivers/netjack/net_driver.c 2009-02-11 20:50:05.000000000 +0100
+@@ -497,7 +497,7 @@
+ {
+ int r;
+
+-#ifdef __APPLE__
++#if !defined(MSG_CONFIRM)
+ static const int flag = 0;
+ #else
+ static const int flag = MSG_CONFIRM;
diff --git a/audio/jack/files/patch-jackd_engine.c b/audio/jack/files/patch-jackd_engine.c
index 2fc649645e1c..bc15f97194c2 100644
--- a/audio/jack/files/patch-jackd_engine.c
+++ b/audio/jack/files/patch-jackd_engine.c
@@ -1,11 +1,20 @@
---- jackd/engine.c.orig Wed Dec 6 23:40:20 2006
-+++ jackd/engine.c Wed Dec 6 23:40:58 2006
-@@ -1444,7 +1444,7 @@
- (engine, pfd[i].fd)) {
- jack_error ("could not handle external"
- " client request");
+--- jackd/engine.c.orig 2008-12-02 17:29:23.000000000 +0100
++++ jackd/engine.c 2009-02-11 20:38:52.000000000 +0100
+@@ -1383,7 +1383,7 @@
+ if ((r = read (client->request_fd, &req, sizeof (req)))
+ < (ssize_t) sizeof (req)) {
+ if (r == 0) {
-#ifdef JACK_USE_MACH_THREADS
-+#if 1
- /* poll is implemented using
- select (see the macosx/fakepoll
- code). When the socket is closed
++#ifndef __linux
+ /* poll is implemented using
+ select (see the macosx/fakepoll
+ code). When the socket is closed
+@@ -1396,7 +1396,7 @@
+ and remove the client.
+ */
+ jack_mark_client_socket_error (engine, fd);
+-#endif /* JACK_USE_MACH_THREADS */
++#endif /* !__linux */
+ return 1;
+ } else {
+ jack_error ("cannot read request from client (%d/%d/%s)",
diff --git a/audio/jack/files/patch-libjack-midiport.c b/audio/jack/files/patch-libjack-midiport.c
deleted file mode 100644
index d1e475776cb5..000000000000
--- a/audio/jack/files/patch-libjack-midiport.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libjack/midiport.c.orig Sat Dec 16 13:50:17 2006
-+++ libjack/midiport.c Fri Jan 19 00:25:32 2007
-@@ -77,7 +77,7 @@
- (jack_midi_port_info_private_t *) port_buffer;
-
- if (event_idx >= info->event_count)
-- return ENODATA;
-+ return ENOMSG;
-
- port_event = (jack_midi_port_internal_event_t *) (info + 1);
- port_event += event_idx;
diff --git a/audio/jack/pkg-plist b/audio/jack/pkg-plist
index e5731b2be8a9..9321304a8404 100644
--- a/audio/jack/pkg-plist
+++ b/audio/jack/pkg-plist
@@ -1,5 +1,4 @@
bin/jack_alias
-bin/jack_bufsize
bin/jack_connect
bin/jack_disconnect
bin/jack_evmon
@@ -15,6 +14,8 @@ bin/jack_showtime
bin/jack_simple_client
bin/jack_transport
bin/jack_unload
+bin/jack_transport_client
+bin/jack_netsource
bin/jackd
bin/jackrec
include/jack/intclient.h
@@ -36,9 +37,14 @@ lib/jack/jack_oss.la
lib/jack/jack_oss.so
lib/jack/jack_portaudio.la
lib/jack/jack_portaudio.so
+lib/jack/jack_net.la
+lib/jack/jack_net.so
lib/libjack.la
lib/libjack.so
lib/libjack.so.0
+lib/libjackserver.la
+lib/libjackserver.so
+lib/libjackserver.so.0
libdata/pkgconfig/jack.pc
%%DOCS%%share/jack-audio-connection-kit/reference/html/annotated.html
%%DOCS%%share/jack-audio-connection-kit/reference/html/classes.html
@@ -80,7 +86,6 @@ libdata/pkgconfig/jack.pc
%%DOCS%%share/jack-audio-connection-kit/reference/html/statistics_8h-source.html
%%DOCS%%share/jack-audio-connection-kit/reference/html/statistics_8h.html
%%DOCS%%share/jack-audio-connection-kit/reference/html/struct__jack__midi__event.html
-%%DOCS%%share/jack-audio-connection-kit/reference/html/structjack__midi__event__t.html
%%DOCS%%share/jack-audio-connection-kit/reference/html/structjack__position__t.html
%%DOCS%%share/jack-audio-connection-kit/reference/html/structjack__ringbuffer__data__t.html
%%DOCS%%share/jack-audio-connection-kit/reference/html/structjack__ringbuffer__t.html
@@ -97,6 +102,23 @@ libdata/pkgconfig/jack.pc
%%DOCS%%share/jack-audio-connection-kit/reference/html/doxygen.png
%%DOCS%%share/jack-audio-connection-kit/reference/html/fsm.png
%%DOCS%%share/jack-audio-connection-kit/reference/html/doxygen.css
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__ClientCallbacks.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__ClientFunctions.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__ClientThreads.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__ErrorOutput.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__Functions.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__MIDIAPI.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__NonCallbackAPI.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__PortFunctions.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__PortSearching.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__ServerControl.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__Setting.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__The.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__TimeFunctions.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/group__TransportControl.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/modules.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/structPOST__PACKED__STRUCTURE.html
+%%DOCS%%share/jack-audio-connection-kit/reference/html/struct____attribute____.html
%%DOCS%%@dirrm share/jack-audio-connection-kit/reference/html
%%DOCS%%@dirrm share/jack-audio-connection-kit/reference
%%DOCS%%@dirrm share/jack-audio-connection-kit