aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-05-12 14:37:54 +0000
committerMark Felder <feld@FreeBSD.org>2015-05-12 14:37:54 +0000
commit1ab9e43c342ad21250cde6d4d23d0158577ab4ec (patch)
tree2acf409c41f7159b0c0c27dffe6ae9f26e333653 /audio
parentb4068421d3a03b98ccb89d641e7f002087df0724 (diff)
downloadports-1ab9e43c342ad21250cde6d4d23d0158577ab4ec.tar.gz
ports-1ab9e43c342ad21250cde6d4d23d0158577ab4ec.zip
MFH: r385052
Approved by: portmgr Disable PCH when compiler is GCC to unbreak builds on 8.x and 9.x
Notes
Notes: svn path=/branches/2015Q2/; revision=386153
Diffstat (limited to 'audio')
-rw-r--r--audio/mumble/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index 0e1527e97144..279f3dc07720 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex \
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-USES= gmake pkgconfig qmake
+USES= compiler gmake pkgconfig qmake
USE_LDCONFIG= yes
USE_QT4= gui svg iconengines_run xml sql network l10n \
linguist_build moc_build rcc_build uic_build \
@@ -53,6 +53,13 @@ CONFIG+= no-bonjour
LIB_DEPENDS+= libdns_sd.so:${PORTSDIR}/net/mDNSResponder
.endif
+.include <bsd.port.pre.mk>
+
+# PCH is broken on GCC
+.if ${COMPILER_TYPE} == gcc
+CONFIG+= no-pch
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/overlay_gl/overlay_gl.pro
@@ -74,4 +81,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/icons/mumble.svg ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
${INSTALL_MAN} ${WRKSRC}/man/mumble.1 ${STAGEDIR}${MANPREFIX}/man/man1/mumble.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>