aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-09-08 02:25:14 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-09-08 02:25:14 +0000
commit0d0680aaab03c9cbc9d3e2cd3f69f85ef8ae7228 (patch)
tree5c919de3c3054f9e1751ac43d262d258c9f9960b /audio
parentd5bd4d2dc334d453a58b65ed6dd4dd958a061789 (diff)
downloadports-0d0680aaab03c9cbc9d3e2cd3f69f85ef8ae7228.tar.gz
ports-0d0680aaab03c9cbc9d3e2cd3f69f85ef8ae7228.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/esound/Makefile3
-rw-r--r--audio/esound/distinfo6
-rw-r--r--audio/esound/files/patch-ad17
-rw-r--r--audio/esound/files/patch-audio_oss.c16
4 files changed, 13 insertions, 29 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index 999660b88d1c..8f0f1e4735b3 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= esound
-PORTVERSION= 0.2.39
-PORTREVISION= 1
+PORTVERSION= 0.2.40
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
diff --git a/audio/esound/distinfo b/audio/esound/distinfo
index 72f71054c418..571cce564ad1 100644
--- a/audio/esound/distinfo
+++ b/audio/esound/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome/esound-0.2.39.tar.bz2) = d950b9cd0d7b5406cc4bb16bcdcea8f4
-SHA256 (gnome/esound-0.2.39.tar.bz2) = 41ce2f8c84f7703d0b62ed1f49d0885ac006563d86f8cacaa0c770180b81c289
-SIZE (gnome/esound-0.2.39.tar.bz2) = 423581
+MD5 (gnome/esound-0.2.40.tar.bz2) = e9009889ab81269f3021ebcad8addb96
+SHA256 (gnome/esound-0.2.40.tar.bz2) = 74b6d9f3dd68ee0b8d95d4d2c78cbd913807cb6c0739d05d8dd75a73fc84d4a7
+SIZE (gnome/esound-0.2.40.tar.bz2) = 423798
diff --git a/audio/esound/files/patch-ad b/audio/esound/files/patch-ad
index 20eeeab10606..c2059f5d0703 100644
--- a/audio/esound/files/patch-ad
+++ b/audio/esound/files/patch-ad
@@ -1,5 +1,5 @@
---- esdlib.c.orig 2008-07-15 11:35:15.000000000 -0400
-+++ esdlib.c 2008-07-18 00:33:42.000000000 -0400
+--- esdlib.c.orig 2008-07-30 17:08:59.000000000 -0400
++++ esdlib.c 2008-09-07 22:19:48.000000000 -0400
@@ -21,6 +21,8 @@
#include <errno.h>
#include <sys/wait.h>
@@ -9,16 +9,7 @@
#include <sys/un.h>
-@@ -152,6 +154,8 @@ write_timeout (int fd, const char *buf,
-
- if (n > 0)
- nwritten += n;
-+ else if (n < 0)
-+ break;
- } while (nwritten < buflen);
-
- fcntl (fd, F_SETFL, flags);
-@@ -889,8 +893,7 @@ int esd_open_sound( const char *host )
+@@ -895,8 +897,7 @@ int esd_open_sound( const char *host )
setsid();
cmd = malloc(strlen(SERVERDIR"/esd -spawnfd 999999") + (esd_spawn_options?strlen(esd_spawn_options):0));
@@ -28,7 +19,7 @@
execl("/bin/sh", "/bin/sh", "-c", cmd, NULL);
perror("execl");
_exit(1);
-@@ -1703,3 +1706,34 @@ int esd_close( int esd )
+@@ -1709,3 +1710,34 @@ int esd_close( int esd )
return close( esd );
}
diff --git a/audio/esound/files/patch-audio_oss.c b/audio/esound/files/patch-audio_oss.c
index a5d30b0dddb2..ba70a323ca36 100644
--- a/audio/esound/files/patch-audio_oss.c
+++ b/audio/esound/files/patch-audio_oss.c
@@ -1,21 +1,15 @@
---- audio_oss.c.orig 2008-07-15 12:00:03.000000000 -0400
-+++ audio_oss.c 2008-07-17 13:56:25.000000000 -0400
-@@ -1,4 +1,5 @@
- #include "config.h"
-+#include <errno.h>
+--- audio_oss.c.orig 2008-07-29 14:07:50.000000000 -0400
++++ audio_oss.c 2008-09-07 22:22:15.000000000 -0400
+@@ -12,8 +13,14 @@
- #ifdef HAVE_MACHINE_SOUNDCARD_H
- # include <machine/soundcard.h>
-@@ -10,9 +11,14 @@
- # endif
- #endif
+ #include <errno.h>
+#if defined(__sparc__) || defined(__powerpc__)
+#define AFMT_S16_NE AFMT_S16_BE
+#else
+#define AFMT_S16_NE AFMT_S16_LE
+#endif
-
++
/* FreeBSD uses a different identifier? what other BSDs? */
-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
+#ifndef SNDCTL_DSP_SETDUPLEX