aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-03-23 02:48:34 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-03-23 02:48:34 +0000
commitbf0f31ee2b9d75459012a2b9d618a960b3359f0a (patch)
tree01fa72c8d5140bf58062ece3719d68909281401b /audio
parentcef8fdc10abe954a78cdb95b47fbe15f50275331 (diff)
downloadports-bf0f31ee2b9d75459012a2b9d618a960b3359f0a.tar.gz
ports-bf0f31ee2b9d75459012a2b9d618a960b3359f0a.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/cueplayer/Makefile23
-rw-r--r--audio/cueplayer/distinfo6
-rw-r--r--audio/cueplayer/pkg-plist21
3 files changed, 17 insertions, 33 deletions
diff --git a/audio/cueplayer/Makefile b/audio/cueplayer/Makefile
index 0b71b2ea1928..b7e4bfe840dc 100644
--- a/audio/cueplayer/Makefile
+++ b/audio/cueplayer/Makefile
@@ -6,32 +6,31 @@
#
PORTNAME= cueplayer
-PORTVERSION= 0.21
+PORTVERSION= 0.23
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= g.veniamin@googlemail.com
COMMENT= CUE player
USE_QT_VER= 4
QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build network
-USE_GSTREAMER= yes
+USE_GSTREAMER= flac good dvd lame ugly ffmpeg taglib ogg vorbis soup libmms wavpack
DESKTOP_ENTRIES="Cueplayer" "Lightweight media player based on Qt and Gstreamer" \
- "${DATADIR}/knotify.png" "${PORTNAME}" \
+ "${DATADIR}/${PORTNAME}.png" "${PORTNAME}" \
"AudioVideo;Audio;Video;" ${FALSE}
post-patch:
- ${REINPLACE_CMD} -e 's,images/,share/${PORTNAME}/,g' \
- ${WRKSRC}/*.cpp
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/share/cueplayer/,${DATADIR}/,g' \
+ main.cpp ${PORTNAME}.pro
+ ${REINPLACE_CMD} -e 's,/usr/share,${PREFIX},g' \
+ ${WRKSRC}/${PORTNAME}.pro
do-configure:
- cd ${WRKSRC} && ${QMAKE}
+ cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX}
-do-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/images/${PORTNAME}.png ${DATADIR}
.include <bsd.port.mk>
diff --git a/audio/cueplayer/distinfo b/audio/cueplayer/distinfo
index eb455094bbd0..7652e9b8ad45 100644
--- a/audio/cueplayer/distinfo
+++ b/audio/cueplayer/distinfo
@@ -1,3 +1,3 @@
-MD5 (cueplayer-0.21.tar.gz) = fd6006d5083ff7e4523cbbd9727ee970
-SHA256 (cueplayer-0.21.tar.gz) = 75079618000c5072e36d70e82c896a7dbc750a5e7b3d9482f98c62f837db3a3d
-SIZE (cueplayer-0.21.tar.gz) = 68338
+MD5 (cueplayer-0.23.tar.gz) = de3e0149fe9e3b2a23c5f22b30a912ff
+SHA256 (cueplayer-0.23.tar.gz) = 7dbd1cfa02efde2abb5fdbe34e6af0cb48e88cb7008548be314559f835de2bb2
+SIZE (cueplayer-0.23.tar.gz) = 81580
diff --git a/audio/cueplayer/pkg-plist b/audio/cueplayer/pkg-plist
index 130ac2bc09b7..2425b7a90465 100644
--- a/audio/cueplayer/pkg-plist
+++ b/audio/cueplayer/pkg-plist
@@ -1,20 +1,5 @@
bin/cueplayer
-%%DATADIR%%/application-exit.png
-%%DATADIR%%/convertor.png
-%%DATADIR%%/fileopen.png
-%%DATADIR%%/format-indent-more.png
-%%DATADIR%%/format-list-unordered.png
-%%DATADIR%%/help-about.png
-%%DATADIR%%/hint.png
-%%DATADIR%%/knotify.png
-%%DATADIR%%/media-optical.png
-%%DATADIR%%/net-stream.png
-%%DATADIR%%/next.png
-%%DATADIR%%/pause.png
-%%DATADIR%%/play.png
-%%DATADIR%%/prev.png
-%%DATADIR%%/speaker.png
-%%DATADIR%%/stop.png
-%%DATADIR%%/text-field.png
-%%DATADIR%%/tool-animator.png
+%%DATADIR%%/loc/cueplayer_pl.qm
+%%DATADIR%%/cueplayer.png
+@dirrm %%DATADIR%%/loc
@dirrm %%DATADIR%%