aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2003-08-12 22:24:45 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2003-08-12 22:24:45 +0000
commit046715d1a89673d543e34d5a668d9cdf0f8c9771 (patch)
tree58d990bc1bdb2263580dbf062b244d4fdaefccba /audio
parent23d19a26d29e9689e0f07c600320d4b86776feef (diff)
downloadports-046715d1a89673d543e34d5a668d9cdf0f8c9771.tar.gz
ports-046715d1a89673d543e34d5a668d9cdf0f8c9771.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/icecast2/Makefile40
-rw-r--r--audio/icecast2/distinfo2
-rw-r--r--audio/icecast2/files/patch-conf::Makefile.in11
-rw-r--r--audio/icecast2/pkg-plist21
-rw-r--r--audio/ices/Makefile42
-rw-r--r--audio/ices/distinfo2
-rw-r--r--audio/ices/files/patch-configure11
-rw-r--r--audio/ices/pkg-plist4
8 files changed, 69 insertions, 64 deletions
diff --git a/audio/icecast2/Makefile b/audio/icecast2/Makefile
index a61ccbac4091..f88442fa51de 100644
--- a/audio/icecast2/Makefile
+++ b/audio/icecast2/Makefile
@@ -6,53 +6,27 @@
#
PORTNAME= icecast2
-PORTVERSION= 20021112
+PORTVERSION= 2.0.a.2.20030811
+PORTEPOCH= 1
CATEGORIES= audio net ipv6
MASTER_SITES= http://tigress.com/lofi/\
http://lofi.dyndns.org/
-DISTNAME= icecast-devel-${PORTVERSION}
+DISTNAME= icecast-2.0-alpha-2-20030811
-MAINTAINER= michaelnottebrock@gmx.net
+MAINTAINER= lofi@freebsd.org
COMMENT= A streaming mp3/ogg-vorbis audio server
-LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ ogg.4:${PORTSDIR}/audio/libogg \
shout.3:${PORTSDIR}/audio/libshout2 \
vorbis.2:${PORTSDIR}/audio/libvorbis \
xslt.1:${PORTSDIR}/textproc/libxslt
-AUTOMAKE_ARGS= --add-missing
-AUTOMAKE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-oggtest --disable-vorbistest --disable-shouttest
CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-USE_AUTOMAKE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_REINPLACE= yes
-USE_BZIP2= yes
-
-WRKSRC= ${WRKDIR}/icecast
-post-configure:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/src/Makefile
- @${REINPLACE_CMD} -e 's|-O20|${CFLAGS}|' ${WRKSRC}/conf/Makefile \
- ${WRKSRC}/doc/Makefile \
- ${WRKSRC}/src/avl/Makefile \
- ${WRKSRC}/src/log/Makefile \
- ${WRKSRC}/src/net/Makefile \
- ${WRKSRC}/src/httpp/Makefile \
- ${WRKSRC}/src/thread/Makefile \
- ${WRKSRC}/src/timing/Makefile \
- ${WRKSRC}/src/Makefile \
- ${WRKSRC}/web/Makefile \
- ${WRKSRC}/win32/res/Makefile \
- ${WRKSRC}/win32/Makefile \
- ${WRKSRC}/Makefile
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/conf/icecast.xml ${DOCSDIR}
-.endif
+WRKSRC= ${WRKDIR}/icecast-2.0-alpha-2
.include <bsd.port.mk>
diff --git a/audio/icecast2/distinfo b/audio/icecast2/distinfo
index 7eb2b953547b..c33185891ff5 100644
--- a/audio/icecast2/distinfo
+++ b/audio/icecast2/distinfo
@@ -1 +1 @@
-MD5 (icecast-devel-20021112.tar.bz2) = b2515e44fc1de1b8114792396f2aaf8b
+MD5 (icecast-2.0-alpha-2-20030811.tar.gz) = fc1dc4173a81daa741cef14cadbf6ce1
diff --git a/audio/icecast2/files/patch-conf::Makefile.in b/audio/icecast2/files/patch-conf::Makefile.in
new file mode 100644
index 000000000000..30a227006ab0
--- /dev/null
+++ b/audio/icecast2/files/patch-conf::Makefile.in
@@ -0,0 +1,11 @@
+--- conf/Makefile.in.orig Mon Aug 11 16:35:19 2003
++++ conf/Makefile.in Mon Aug 11 16:35:31 2003
+@@ -278,7 +278,7 @@
+ install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+ test -f $(DESTDIR)$(sysconfdir)/icecast.xml || \
+- $(INSTALL_DATA) icecast.xml.dist $(DESTDIR)$(sysconfdir)/icecast.xml
++ $(INSTALL_DATA) icecast.xml.dist $(DESTDIR)$(sysconfdir)/icecast.xml.sample
+
+ icecast.xml.dist: $(srcdir)/icecast.xml.in
+ $(edit) $(srcdir)/icecast.xml.in > icecast.xml.dist
diff --git a/audio/icecast2/pkg-plist b/audio/icecast2/pkg-plist
index e9e270b92c4c..d97e43000931 100644
--- a/audio/icecast2/pkg-plist
+++ b/audio/icecast2/pkg-plist
@@ -1,3 +1,20 @@
bin/icecast
-%%PORTDOCS%%share/doc/icecast2/icecast.xml
-%%PORTDOCS%%@dirrm share/doc/icecast2
+etc/icecast.xml.sample
+share/doc/icecast/AUTHORS
+share/doc/icecast/COPYING
+share/doc/icecast/NEWS
+share/doc/icecast/README
+share/doc/icecast/TODO
+share/icecast/admin/listclients.xsl
+share/icecast/admin/listmounts.xsl
+share/icecast/admin/moveclients.xsl
+share/icecast/admin/response.xsl
+share/icecast/admin/stats.xsl
+share/icecast/doc/icecast.xml.dist
+share/icecast/web/status.xsl
+share/icecast/web/status2.xsl
+@dirrm share/icecast/web
+@dirrm share/icecast/doc
+@dirrm share/icecast/admin
+@dirrm share/icecast
+@dirrm share/doc/icecast
diff --git a/audio/ices/Makefile b/audio/ices/Makefile
index 719fc488b40c..95f7492066e6 100644
--- a/audio/ices/Makefile
+++ b/audio/ices/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= ices
-PORTVERSION= 20021112
+PORTVERSION= 2.0.b.2.20030811
+PORTEPOCH= 1
CATEGORIES= audio net
MASTER_SITES= http://tigress.com/lofi/ \
http://lofi.dyndns.org/
-DISTNAME= ${PORTNAME}-devel-${PORTVERSION}
+DISTNAME= ${PORTNAME}-2.0-Beta2-20030811
-MAINTAINER= michaelnottebrock@gmx.net
+MAINTAINER= lofi@freebsd.org
COMMENT= A streaming source client for icecast 2
LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
@@ -20,32 +21,21 @@ LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
vorbis.2:${PORTSDIR}/audio/libvorbis \
xml2.5:${PORTSDIR}/textproc/libxml2
-AUTOMAKE_ARGS= --add-missing
-AUTOMAKE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-oggtest --disable-vorbistest --disable-shouttest
CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-USE_AUTOMAKE_VER=15
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_REINPLACE= yes
-USE_BZIP2= yes
-
-WRKSRC= ${WRKDIR}/ices
-
-post-configure:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile
- @${REINPLACE_CMD} -e 's|-O20|${CFLAGS}|g' ${WRKSRC}/conf/Makefile \
- ${WRKSRC}/src/avl/Makefile \
- ${WRKSRC}/src/log/Makefile \
- ${WRKSRC}/src/net/Makefile \
- ${WRKSRC}/src/thread/Makefile \
- ${WRKSRC}/src/timing/Makefile \
- ${WRKSRC}/src/Makefile \
- ${WRKSRC}/Makefile
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/contrib/run_ices ${LOCALBASE}/bin
+WRKSRC= ${WRKDIR}/ices-2.0-Beta2
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/ices-live.xml \
+ ${WRKSRC}/conf/ices-playlist.xml \
+ ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/ices/distinfo b/audio/ices/distinfo
index 2f7daf8ed407..161dba186a74 100644
--- a/audio/ices/distinfo
+++ b/audio/ices/distinfo
@@ -1 +1 @@
-MD5 (ices-devel-20021112.tar.bz2) = 3c6d3f1d6c490dae2f28baea3c3d2ff1
+MD5 (ices-2.0-Beta2-20030811.tar.gz) = 5ccf54d6961eba9ac914090dffb874cc
diff --git a/audio/ices/files/patch-configure b/audio/ices/files/patch-configure
new file mode 100644
index 000000000000..e775361206b7
--- /dev/null
+++ b/audio/ices/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Aug 12 23:46:05 2003
++++ configure Tue Aug 12 23:46:21 2003
+@@ -7801,7 +7801,7 @@
+
+
+ case "$host" in
+- *openbsd*)
++ *openbsd*|*freebsd*)
+ ;;
+ *)
+ cat >>confdefs.h <<\_ACEOF
diff --git a/audio/ices/pkg-plist b/audio/ices/pkg-plist
index 44498d7572a3..34b9a1819362 100644
--- a/audio/ices/pkg-plist
+++ b/audio/ices/pkg-plist
@@ -1,2 +1,4 @@
bin/ices
-bin/run_ices
+%%PORTDOCS%%%%DOCSDIR%%/ices-live.xml
+%%PORTDOCS%%%%DOCSDIR%%/ices-playlist.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%