aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-22 08:45:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-22 08:45:32 +0000
commit967cb805187d521866af6cee2087038cbe166a92 (patch)
tree5d76332a12ea74a075fc29a3697aebd055244ab6 /audio
parentd0d7ed783d6153a4226b1af105c7318bc79709e0 (diff)
downloadports-967cb805187d521866af6cee2087038cbe166a92.tar.gz
ports-967cb805187d521866af6cee2087038cbe166a92.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/rhythmbox-devel/Makefile5
-rw-r--r--audio/rhythmbox-devel/distinfo2
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-shell.c14
-rw-r--r--audio/rhythmbox/Makefile5
-rw-r--r--audio/rhythmbox/distinfo2
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-shell.c14
6 files changed, 34 insertions, 8 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index 7c41df692e3c..f51114346dca 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.4
+PORTVERSION= 0.6.5
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
@@ -32,8 +32,7 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
LIB_DEPENDS+= xine.9:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+= --enable-xine
.else
-#USE_GNOME+= gstreamerplugins
-LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
+USE_GNOME+= gstreamerplugins
.endif
.include <bsd.port.pre.mk>
diff --git a/audio/rhythmbox-devel/distinfo b/audio/rhythmbox-devel/distinfo
index fa6f216a8fa3..5f83b8cc17d2 100644
--- a/audio/rhythmbox-devel/distinfo
+++ b/audio/rhythmbox-devel/distinfo
@@ -1 +1 @@
-MD5 (gnome2/rhythmbox-0.6.4.tar.bz2) = 8aa6809e065bc17fb1a0ef57eb058225
+MD5 (gnome2/rhythmbox-0.6.5.tar.bz2) = c9cf126e219a08b90b77c65396cfcca8
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-shell.c b/audio/rhythmbox-devel/files/patch-shell_rb-shell.c
new file mode 100644
index 000000000000..21af556f5852
--- /dev/null
+++ b/audio/rhythmbox-devel/files/patch-shell_rb-shell.c
@@ -0,0 +1,14 @@
+--- shell/rb-shell.c.orig Thu Jan 22 03:35:39 2004
++++ shell/rb-shell.c Thu Jan 22 03:36:04 2004
+@@ -610,10 +610,10 @@
+ {
+ RBShell *shell = RB_SHELL (bonobo_object (_servant));
+ RBPlaylist *parser;
++ GnomeVFSURI *vfsuri = gnome_vfs_uri_new (uri);
+
+ rb_debug ("handling uri: %s", uri);
+
+- GnomeVFSURI *vfsuri = gnome_vfs_uri_new (uri);
+ if (!vfsuri) {
+ rb_error_dialog (_("Unable to parse URI \"%s\"\n"), uri);
+ return;
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 7c41df692e3c..f51114346dca 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.4
+PORTVERSION= 0.6.5
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
@@ -32,8 +32,7 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
LIB_DEPENDS+= xine.9:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+= --enable-xine
.else
-#USE_GNOME+= gstreamerplugins
-LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
+USE_GNOME+= gstreamerplugins
.endif
.include <bsd.port.pre.mk>
diff --git a/audio/rhythmbox/distinfo b/audio/rhythmbox/distinfo
index fa6f216a8fa3..5f83b8cc17d2 100644
--- a/audio/rhythmbox/distinfo
+++ b/audio/rhythmbox/distinfo
@@ -1 +1 @@
-MD5 (gnome2/rhythmbox-0.6.4.tar.bz2) = 8aa6809e065bc17fb1a0ef57eb058225
+MD5 (gnome2/rhythmbox-0.6.5.tar.bz2) = c9cf126e219a08b90b77c65396cfcca8
diff --git a/audio/rhythmbox/files/patch-shell_rb-shell.c b/audio/rhythmbox/files/patch-shell_rb-shell.c
new file mode 100644
index 000000000000..21af556f5852
--- /dev/null
+++ b/audio/rhythmbox/files/patch-shell_rb-shell.c
@@ -0,0 +1,14 @@
+--- shell/rb-shell.c.orig Thu Jan 22 03:35:39 2004
++++ shell/rb-shell.c Thu Jan 22 03:36:04 2004
+@@ -610,10 +610,10 @@
+ {
+ RBShell *shell = RB_SHELL (bonobo_object (_servant));
+ RBPlaylist *parser;
++ GnomeVFSURI *vfsuri = gnome_vfs_uri_new (uri);
+
+ rb_debug ("handling uri: %s", uri);
+
+- GnomeVFSURI *vfsuri = gnome_vfs_uri_new (uri);
+ if (!vfsuri) {
+ rb_error_dialog (_("Unable to parse URI \"%s\"\n"), uri);
+ return;