aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-02-14 20:22:50 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-02-14 20:22:50 +0000
commit0fa575ea706026f8f393520d55da57dd875aa92b (patch)
tree32d0e0e6313d7e65684ea5a7b9715b15439694bd /audio
parent8b2156e190dac64dc69478682b16ce779e865e69 (diff)
downloadports-0fa575ea706026f8f393520d55da57dd875aa92b.tar.gz
ports-0fa575ea706026f8f393520d55da57dd875aa92b.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/rbscrobbler/Makefile40
-rw-r--r--audio/rbscrobbler/distinfo2
-rw-r--r--audio/rbscrobbler/pkg-descr3
-rw-r--r--audio/rbscrobbler/pkg-plist18
5 files changed, 64 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 9cbfdc0b5740..2462058c2086 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -322,6 +322,7 @@
SUBDIR += radio
SUBDIR += raproxy
SUBDIR += rawrec
+ SUBDIR += rbscrobbler
SUBDIR += rebler
SUBDIR += replay
SUBDIR += resid
diff --git a/audio/rbscrobbler/Makefile b/audio/rbscrobbler/Makefile
new file mode 100644
index 000000000000..7a9ef28d738a
--- /dev/null
+++ b/audio/rbscrobbler/Makefile
@@ -0,0 +1,40 @@
+# New ports collection Makefile for: rbscrobbler
+# Date created: 2005-01-30
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= rbscrobbler
+PORTVERSION= 0.0.8
+CATEGORIES= audio gnome
+MASTER_SITES= http://members.cox.net/alexrevo/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Rhythmbox plugin for Audioscrobbler
+
+BUILD_DEPENDS= rhythmbox:${PORTSDIR}/audio/rhythmbox \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
+RUN_DEPENDS= rhythmbox:${PORTSDIR}/audio/rhythmbox \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
+
+USE_PYTHON= yes
+USE_REINPLACE= yes
+CFLAGS+= "-I${PYTHON_INCLUDEDIR}"
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,CFLAGS =,CFLAGS+= -I${PYTHON_INCLUDEDIR}," \
+ ${WRKSRC}/trayicon/Makefile
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} Audioscrobbler.py Debug.py MyQueue.py \
+ Rhythmbox_Bonobo.py RLInput.py singletonmixin.py ${DATADIR}
+ cd ${WRKSRC}; ${INSTALL_SCRIPT} rbscrobbler.py ${DATADIR}
+ ln -sf ${DATADIR}/rbscrobbler.py ${PREFIX}/bin/rbscrobbler
+ ${MKDIR} ${DATADIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}/images
+ ${MKDIR} ${DATADIR}/trayicon
+ cd ${WRKSRC}; ${INSTALL_DATA} trayicon/__init__.py \
+ trayicon/trayicon.so ${DATADIR}/trayicon
+
+.include <bsd.port.mk>
diff --git a/audio/rbscrobbler/distinfo b/audio/rbscrobbler/distinfo
new file mode 100644
index 000000000000..1ef872c5dee1
--- /dev/null
+++ b/audio/rbscrobbler/distinfo
@@ -0,0 +1,2 @@
+MD5 (rbscrobbler-0.0.8.tar.gz) = 9b9b0d0df99de8d56e9adad0db8c3737
+SIZE (rbscrobbler-0.0.8.tar.gz) = 25237
diff --git a/audio/rbscrobbler/pkg-descr b/audio/rbscrobbler/pkg-descr
new file mode 100644
index 000000000000..0c8805ce98bb
--- /dev/null
+++ b/audio/rbscrobbler/pkg-descr
@@ -0,0 +1,3 @@
+Audioscrobbler plugin for rhythmbox
+
+WWW: http://members.cox.net/alexrevo/
diff --git a/audio/rbscrobbler/pkg-plist b/audio/rbscrobbler/pkg-plist
new file mode 100644
index 000000000000..1bccdf95e218
--- /dev/null
+++ b/audio/rbscrobbler/pkg-plist
@@ -0,0 +1,18 @@
+%%DATADIR%%/Audioscrobbler.py
+%%DATADIR%%/Debug.py
+%%DATADIR%%/MyQueue.py
+%%DATADIR%%/Rhythmbox_Bonobo.py
+%%DATADIR%%/RLInput.py
+%%DATADIR%%/singletonmixin.py
+%%DATADIR%%/rbscrobbler.py
+%%DATADIR%%/images/icon-offline.png
+%%DATADIR%%/images/icon-online.png
+%%DATADIR%%/images/notsubmitted.png
+%%DATADIR%%/images/offline.png
+%%DATADIR%%/images/online.png
+%%DATADIR%%/images/submitted.png
+%%DATADIR%%/trayicon/__init__.py
+%%DATADIR%%/t.so
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/trayicon
+@dirrm %%DATADIR%%