aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-18 08:09:02 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-18 08:09:02 +0000
commit3b0bf49d204e8090f1517cea20974a69f84748f7 (patch)
tree94e31b4b50c4daeee784db70263844e21f703b16 /audio
parent8123aa36741c3819ab59e68964da2cb1a19f9c4f (diff)
downloadports-3b0bf49d204e8090f1517cea20974a69f84748f7.tar.gz
ports-3b0bf49d204e8090f1517cea20974a69f84748f7.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/rhythmbox-devel/Makefile3
-rw-r--r--audio/rhythmbox-devel/distinfo2
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c40
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c18
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c17
-rw-r--r--audio/rhythmbox-devel/files/patch-shell_rb-play-order.c13
-rw-r--r--audio/rhythmbox/Makefile3
-rw-r--r--audio/rhythmbox/distinfo2
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c40
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c18
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c17
-rw-r--r--audio/rhythmbox/files/patch-shell_rb-play-order.c13
12 files changed, 180 insertions, 6 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index c9dc6f5c6e68..c023ab84f7a5 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTVERSION= 0.6.2
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/audio/rhythmbox-devel/distinfo b/audio/rhythmbox-devel/distinfo
index 2412d10fff52..9ce60c7bcbc6 100644
--- a/audio/rhythmbox-devel/distinfo
+++ b/audio/rhythmbox-devel/distinfo
@@ -1 +1 @@
-MD5 (gnome2/rhythmbox-0.6.1.tar.bz2) = 5791f9fb69c9a855d84e1e666b2e86a9
+MD5 (gnome2/rhythmbox-0.6.2.tar.bz2) = a6d05830abf45cda229270b0e5ab5ca4
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c
new file mode 100644
index 000000000000..6778884c75ef
--- /dev/null
+++ b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-by-age.c
@@ -0,0 +1,40 @@
+--- shell/rb-play-order-random-by-age.c.orig Thu Dec 18 02:59:50 2003
++++ shell/rb-play-order-random-by-age.c Thu Dec 18 03:00:34 2003
+@@ -87,6 +87,7 @@
+ rb_random_play_order_by_age_class_init (RBRandomPlayOrderByAgeClass *klass)
+ {
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
++ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+
+ parent_class = g_type_class_peek_parent (klass);
+
+@@ -94,7 +95,6 @@
+ object_class->finalize = rb_random_play_order_by_age_finalize;
+
+
+- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+ porder->get_next = rb_random_play_order_by_age_get_next;
+ porder->go_next = rb_random_play_order_by_age_go_next;
+ porder->get_previous = rb_random_play_order_by_age_get_previous;
+@@ -265,6 +265,8 @@
+ RhythmDBEntry *result = NULL;
+ GArray *entries = get_entry_view_contents (entry_view);
+ int i;
++ double rnd;
++ double total_weight = 0;
+
+ if (entries->len == 0) {
+ /* entry view empty */
+@@ -273,11 +275,10 @@
+
+ /* Algorithm due to treed */
+
+- double total_weight = 0;
+ for (i=0; i<entries->len; ++i) {
+ total_weight += g_array_index (entries, EntryWeight, i).weight;
+ }
+- double rnd = g_random_double_range (0, total_weight);
++ rnd = g_random_double_range (0, total_weight);
+ for (i=0; i<entries->len; ++i) {
+ if (rnd < g_array_index (entries, EntryWeight, i).weight) {
+ result = g_array_index (entries, EntryWeight, i).entry;
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c
new file mode 100644
index 000000000000..bc81e005e11c
--- /dev/null
+++ b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-random-equal-weights.c
@@ -0,0 +1,18 @@
+--- shell/rb-play-order-random-equal-weights.c.orig Thu Dec 18 02:59:09 2003
++++ shell/rb-play-order-random-equal-weights.c Thu Dec 18 02:59:16 2003
+@@ -85,6 +85,7 @@
+ rb_random_play_order_equal_weights_class_init (RBRandomPlayOrderEqualWeightsClass *klass)
+ {
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
++ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+
+ parent_class = g_type_class_peek_parent (klass);
+
+@@ -92,7 +93,6 @@
+ object_class->finalize = rb_random_play_order_equal_weights_finalize;
+
+
+- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+ porder->get_next = rb_random_play_order_equal_weights_get_next;
+ porder->go_next = rb_random_play_order_equal_weights_go_next;
+ porder->get_previous = rb_random_play_order_equal_weights_get_previous;
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c
new file mode 100644
index 000000000000..33d0c3fcedb4
--- /dev/null
+++ b/audio/rhythmbox-devel/files/patch-shell_rb-play-order-shuffle.c
@@ -0,0 +1,17 @@
+--- shell/rb-play-order-shuffle.c.orig Thu Dec 18 02:58:17 2003
++++ shell/rb-play-order-shuffle.c Thu Dec 18 02:58:34 2003
+@@ -111,13 +111,13 @@
+ rb_shuffle_play_order_class_init (RBShufflePlayOrderClass *klass)
+ {
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
++ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+
+ parent_class = g_type_class_peek_parent (klass);
+
+ object_class->constructor = rb_shuffle_play_order_constructor;
+ object_class->finalize = rb_shuffle_play_order_finalize;
+
+- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+ porder->get_next = rb_shuffle_play_order_get_next;
+ porder->go_next = rb_shuffle_play_order_go_next;
+ porder->get_previous = rb_shuffle_play_order_get_previous;
diff --git a/audio/rhythmbox-devel/files/patch-shell_rb-play-order.c b/audio/rhythmbox-devel/files/patch-shell_rb-play-order.c
new file mode 100644
index 000000000000..5e7990b0038d
--- /dev/null
+++ b/audio/rhythmbox-devel/files/patch-shell_rb-play-order.c
@@ -0,0 +1,13 @@
+--- shell/rb-play-order.c.orig Thu Dec 18 02:57:29 2003
++++ shell/rb-play-order.c Thu Dec 18 02:57:41 2003
+@@ -195,9 +195,9 @@
+ rb_play_order_get_entry_view (RBPlayOrder *porder)
+ {
+ RBShellPlayer *player = porder->priv->player;
++ RBSource *source = rb_shell_player_get_source (player);
+ if (player == NULL)
+ return NULL;
+- RBSource *source = rb_shell_player_get_source (player);
+ if (source == NULL)
+ return NULL;
+ return rb_source_get_entry_view (source);
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index c9dc6f5c6e68..c023ab84f7a5 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTVERSION= 0.6.2
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
diff --git a/audio/rhythmbox/distinfo b/audio/rhythmbox/distinfo
index 2412d10fff52..9ce60c7bcbc6 100644
--- a/audio/rhythmbox/distinfo
+++ b/audio/rhythmbox/distinfo
@@ -1 +1 @@
-MD5 (gnome2/rhythmbox-0.6.1.tar.bz2) = 5791f9fb69c9a855d84e1e666b2e86a9
+MD5 (gnome2/rhythmbox-0.6.2.tar.bz2) = a6d05830abf45cda229270b0e5ab5ca4
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c b/audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c
new file mode 100644
index 000000000000..6778884c75ef
--- /dev/null
+++ b/audio/rhythmbox/files/patch-shell_rb-play-order-random-by-age.c
@@ -0,0 +1,40 @@
+--- shell/rb-play-order-random-by-age.c.orig Thu Dec 18 02:59:50 2003
++++ shell/rb-play-order-random-by-age.c Thu Dec 18 03:00:34 2003
+@@ -87,6 +87,7 @@
+ rb_random_play_order_by_age_class_init (RBRandomPlayOrderByAgeClass *klass)
+ {
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
++ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+
+ parent_class = g_type_class_peek_parent (klass);
+
+@@ -94,7 +95,6 @@
+ object_class->finalize = rb_random_play_order_by_age_finalize;
+
+
+- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+ porder->get_next = rb_random_play_order_by_age_get_next;
+ porder->go_next = rb_random_play_order_by_age_go_next;
+ porder->get_previous = rb_random_play_order_by_age_get_previous;
+@@ -265,6 +265,8 @@
+ RhythmDBEntry *result = NULL;
+ GArray *entries = get_entry_view_contents (entry_view);
+ int i;
++ double rnd;
++ double total_weight = 0;
+
+ if (entries->len == 0) {
+ /* entry view empty */
+@@ -273,11 +275,10 @@
+
+ /* Algorithm due to treed */
+
+- double total_weight = 0;
+ for (i=0; i<entries->len; ++i) {
+ total_weight += g_array_index (entries, EntryWeight, i).weight;
+ }
+- double rnd = g_random_double_range (0, total_weight);
++ rnd = g_random_double_range (0, total_weight);
+ for (i=0; i<entries->len; ++i) {
+ if (rnd < g_array_index (entries, EntryWeight, i).weight) {
+ result = g_array_index (entries, EntryWeight, i).entry;
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c b/audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c
new file mode 100644
index 000000000000..bc81e005e11c
--- /dev/null
+++ b/audio/rhythmbox/files/patch-shell_rb-play-order-random-equal-weights.c
@@ -0,0 +1,18 @@
+--- shell/rb-play-order-random-equal-weights.c.orig Thu Dec 18 02:59:09 2003
++++ shell/rb-play-order-random-equal-weights.c Thu Dec 18 02:59:16 2003
+@@ -85,6 +85,7 @@
+ rb_random_play_order_equal_weights_class_init (RBRandomPlayOrderEqualWeightsClass *klass)
+ {
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
++ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+
+ parent_class = g_type_class_peek_parent (klass);
+
+@@ -92,7 +93,6 @@
+ object_class->finalize = rb_random_play_order_equal_weights_finalize;
+
+
+- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+ porder->get_next = rb_random_play_order_equal_weights_get_next;
+ porder->go_next = rb_random_play_order_equal_weights_go_next;
+ porder->get_previous = rb_random_play_order_equal_weights_get_previous;
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c b/audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c
new file mode 100644
index 000000000000..33d0c3fcedb4
--- /dev/null
+++ b/audio/rhythmbox/files/patch-shell_rb-play-order-shuffle.c
@@ -0,0 +1,17 @@
+--- shell/rb-play-order-shuffle.c.orig Thu Dec 18 02:58:17 2003
++++ shell/rb-play-order-shuffle.c Thu Dec 18 02:58:34 2003
+@@ -111,13 +111,13 @@
+ rb_shuffle_play_order_class_init (RBShufflePlayOrderClass *klass)
+ {
+ GObjectClass *object_class = G_OBJECT_CLASS (klass);
++ RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+
+ parent_class = g_type_class_peek_parent (klass);
+
+ object_class->constructor = rb_shuffle_play_order_constructor;
+ object_class->finalize = rb_shuffle_play_order_finalize;
+
+- RBPlayOrderClass *porder = RB_PLAY_ORDER_CLASS (klass);
+ porder->get_next = rb_shuffle_play_order_get_next;
+ porder->go_next = rb_shuffle_play_order_go_next;
+ porder->get_previous = rb_shuffle_play_order_get_previous;
diff --git a/audio/rhythmbox/files/patch-shell_rb-play-order.c b/audio/rhythmbox/files/patch-shell_rb-play-order.c
new file mode 100644
index 000000000000..5e7990b0038d
--- /dev/null
+++ b/audio/rhythmbox/files/patch-shell_rb-play-order.c
@@ -0,0 +1,13 @@
+--- shell/rb-play-order.c.orig Thu Dec 18 02:57:29 2003
++++ shell/rb-play-order.c Thu Dec 18 02:57:41 2003
+@@ -195,9 +195,9 @@
+ rb_play_order_get_entry_view (RBPlayOrder *porder)
+ {
+ RBShellPlayer *player = porder->priv->player;
++ RBSource *source = rb_shell_player_get_source (player);
+ if (player == NULL)
+ return NULL;
+- RBSource *source = rb_shell_player_get_source (player);
+ if (source == NULL)
+ return NULL;
+ return rb_source_get_entry_view (source);